LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-20-2016, 04:08 PM   #1
biosboy4
Member
 
Registered: Aug 2015
Distribution: *DEB, Centos, NXOS
Posts: 242

Rep: Reputation: 38
Darkstat Error


Hello,

I am installing Damn Small Linux as a Cups-PDF print server to interface with some older tire/wheel balancer machines.

I've gotten as far as installing darkstat in this guide: http://cosmolinux.no-ip.org/dsl/dsl.html

but when I type "./configure" in the darkstat directory I get the following:
"configure: error: please specify --with-chroot-dir=/path/to/darksta/chroot"

What am I missing?

Thanks,

DW
 
Old 05-20-2016, 04:33 PM   #2
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware 14.2
Posts: 2,815
Blog Entries: 1

Rep: Reputation: 261Reputation: 261Reputation: 261
It's asking you to specify the directory darkstat is going to use as it's chroot. It's odd you get an error, because there is a default chroot (/var/empty) when using darkstat 3.0.715. Try specifying a chroot when you execute the configure script for darkstat
Code:
./configure --with-chroot-dir=/var/empty
and see if that helps.
 
Old 05-20-2016, 05:25 PM   #3
biosboy4
Member
 
Registered: Aug 2015
Distribution: *DEB, Centos, NXOS
Posts: 242

Original Poster
Rep: Reputation: 38
It worked!

Makes sense since I'm using *.13 lol.

Thank you sir,

Edit/Next Problem:

The guide says "After installation, make sure you have the files /etc/init.d/darkstat and /etc/darkstat/init.cfg (In DSL, for unknow reasons, names are a bit different so rename the files)."

Well I looked and I don't have either of those files after the install, nor do I have any way of knowing what to rename.. lol

Thanks again for your help,

DW

Last edited by biosboy4; 05-20-2016 at 05:35 PM. Reason: Next problem
 
Old 05-21-2016, 02:57 PM   #4
weibullguy
ReliaFree Maintainer
 
Registered: Aug 2004
Location: Kalamazoo, Michigan
Distribution: Slackware 14.2
Posts: 2,815
Blog Entries: 1

Rep: Reputation: 261Reputation: 261Reputation: 261
No idea. Neither of those files ship with the source code. It's a new problem though, so you should open a new thread (only one).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Fatal error in MPI_Init: Other MPI error, error stack:gethostbyname failed(errno 1) turbo67 Linux - Networking 2 10-17-2018 05:06 AM
Error 502 : Display Fatal Error Message, Error pushing image, dbpaCT failed! HaloCheng Linux - Newbie 1 09-12-2012 01:02 PM
Sendmail: eocket wedge , 504 error , dsn error, mail relay connection error djcs Debian 0 03-03-2009 01:41 AM
LXer: DarkStat - Network traffic & bandwidth monitoring in openSUSE LXer Syndicated Linux News 0 10-17-2008 08:50 AM
LXer: Darkstat - Network Traffic Analyzer or Network Monitor LXer Syndicated Linux News 0 07-04-2006 09:33 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 02:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration