LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-16-2016, 02:12 PM   #1
enricong
LQ Newbie
 
Registered: Jun 2005
Posts: 3

Rep: Reputation: 0
CYGWIN OpenGL failure when using multiwindow


I am using Cygwin/X to connect remotely over SSH to a server. I typically use multiwindow. When I start a software requiring OpenGL, I get the following Error and the program exits:

Quote:
X Error of failed request: GLXBadRenderRequest
Major opcode of failed request: 148 (GLX)
Minor opcode of failed request: 1 (X_GLXRender)
Serial number of failed request: 1074
Current serial number in output stream: 1075
glxinfo | grep OpenGL gives:
Quote:
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: Quadro 4000/PCIe/SSE2
OpenGL version string: 1.4 (4.4.0)
OpenGL extensions:
That IS my graphics card.

Now when I start Cygwin Xserver in a non-multiwindow mode, the software works fine.

I notice the output of glxinfo is different:
Quote:
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on llvmpipe (LLVM 3.4, 128 bits)
OpenGL version string: 3.0 Mesa 10.2.8
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
I'd appreciate any suggestions
 
Old 05-29-2016, 06:49 PM   #2
mazinoz
Member
 
Registered: Mar 2003
Location: Mansfield Queensland Australia
Distribution: Linux Mint - Tara
Posts: 497

Rep: Reputation: 35
I'm sorry, but the only thing I can suggest is maybe fiddling around in the kernel's graphics card section and recompiling the kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] OpenGL not working in FC19 due to Catalyst DRI initialization failure sabresong Linux - Software 2 08-01-2013 12:04 PM
LXer: Samsung Adds Multiwindow Mojo to Android LXer Syndicated Linux News 0 01-25-2013 04:41 AM
Have you ever used cygwin, i've met a problem with the command stat from cygwin andy820303 Linux - Newbie 0 03-11-2009 04:37 AM
Opengl assertion failure szemy Linux - Software 0 05-15-2008 08:44 AM
compiling opengl with cygwin adhara Programming 0 07-28-2004 06:58 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration