-   Linux - Software (
-   -   CVS in Eclipse IDE (

gamelord12 02-20-2008 08:28 PM

CVS in Eclipse IDE
I'm somewhat new to Linux. I don't really do much with the command line, and I run Ubuntu on a Dell that had it pre-installed, though I believe that I can be a fast learner when it comes to Linux because I've had extensive use of Windows and I keep up with tech news quite a bit.

With that in mind, I'm taking a computer science class at my university, and all of our Java projects are submitted via CVS to the school's server. Now, on my Windows machine (my desktop) everything works fine. However, I'm not always at my desktop, and I'd like my homework to be more portable. I installed Eclipse 3.2 off of the Ubuntu repositories (it appeared to be the only version there, though I believe the newest is the Europa version). When I try to switch to my CVS explorer pane, it gives me the following error:

Problems opening perspective ''

How can I get this fixed to the point where I can update the files on the school server as easily as I can on Windows. There may be command-line alternatives to updating the files, but while they'd be nice to know, first and foremost I need it to work via the GUI. Thanks for any help anyone can give me.

JWPurple 02-21-2008 11:46 PM

I usually use's packages. You'll have to configure the extssh client in eclipse to connect to the server, but that's pretty easy with their "wizard" setup.

gamelord12 02-22-2008 09:27 AM

Could you steer me in the right direction for getting to their configuration wizard? What do I click?

JWPurple 02-23-2008 08:53 PM

Open the CVS perspective: Window->Open Perspective->CVS Repository Exploring

Click on the CVS+ icon (Add CVS Repository)

Select Connection type: extssh and fill out the other info about your school CVS repository.

That should be all you'll need. Of course you'll need access to the school's server, etc.

gamelord12 02-24-2008 09:29 AM

Ah, but there's the problem. My error comes up when I try to open the perspective. I can't even get to it.

JWPurple 02-24-2008 08:51 PM

:) I just noticed that!

Well then, I think your installation is not complete. Have you tried un-installing the distribution's version and getting the Eclipse one? I did that on my OpenSuse 10.3 machine and it works like a charm. Plus you get the latest version of Eclipse.

gamelord12 02-25-2008 07:43 AM

It comes in a .tar.gz file, which I believe is source code that needs to be compiled (since I have no idea where the files go and there's no self-extractor). I've never done that before.

JWPurple 02-27-2008 09:23 PM

My experience is that it's a package of files including the eclipse executable. You just have to put it where you want it (maybe /opt/eclipse), and run /opt/eclipse/eclipse. DONE!

gamelord12 02-28-2008 07:53 AM

I haven't tested that yet, but how I can I know that in the future just by looking?

gamelord12 02-28-2008 08:36 PM

Okay, I've got Eclipse Europa all set up, but I still get the same problem, and I didn't even uninstall Eclipse 3.2's packages through Synaptic because I figured Europa may depend on those same packages as well. Perhaps there's another package or two I need to install?

JWPurple 02-28-2008 09:27 PM

You do have the cvs/rcs package installed, don't you? That might be the problem. It should be in the development package.

gamelord12 03-04-2008 04:24 PM

I installed the rcs package; the cvs package was already installed. I couldn't find a package called "development" in synaptic though. Also, Eclipse still has the same problem.

gamelord12 03-11-2008 08:59 PM

Am I getting closer at least?

All times are GMT -5. The time now is 06:28 PM.