LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-13-2004, 12:50 AM   #1
ccin1492
Member
 
Registered: Feb 2004
Location: SoCal
Distribution: openSUSE 10.3
Posts: 139

Rep: Reputation: 15
CUPS username and password


Hi,

If if pull up http://localhost:631 and go to admin it ask for a username and password. I've tried my user account and root, but it doesn't seem to like either. Which username and password is it looking for?

Thanks in advance,
TC
 
Old 03-13-2004, 01:01 AM   #2
tk31337
Member
 
Registered: Oct 2003
Location: Tucson, AZ
Distribution: Linux Mint
Posts: 194

Rep: Reputation: 32
Not a CUPS guru, but you might try looking in /etc/cups/cupsd.conf for some useful options.
 
Old 03-13-2004, 01:09 AM   #3
contrasutra
LQ Guru
 
Registered: Mar 2003
Location: New Jersey
Distribution: Arch Linux
Posts: 1,445

Rep: Reputation: 46
It's looking for your root password.

The username should be exactly "root" and the password should be your normal root password.
 
Old 03-13-2004, 12:28 PM   #4
ccin1492
Member
 
Registered: Feb 2004
Location: SoCal
Distribution: openSUSE 10.3
Posts: 139

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by contrasutra
It's looking for your root password.

The username should be exactly "root" and the password should be your normal root password.
That's what I thought as well. But it doesn't accept it!
 
Old 03-13-2004, 03:28 PM   #5
ccin1492
Member
 
Registered: Feb 2004
Location: SoCal
Distribution: openSUSE 10.3
Posts: 139

Original Poster
Rep: Reputation: 15
Ok, here's whar I found in /var/log/cups/error_log:

E [13/Mar/2004:10:58:11 -0800] Unable to open /etc/cups/passwd.md5 - No such file or directory
E [13/Mar/2004:10:58:11 -0800] IsAuthorized: No matching user:group for "root" in passwd.md5!
E [13/Mar/2004:10:58:42 -0800] Unable to open /etc/cups/passwd.md5 - No such file or directory
E [13/Mar/2004:10:58:42 -0800] IsAuthorized: No matching user:group for "root" in passwd.md5!

ok, why is looking for passwd.md5?
 
Old 03-13-2004, 04:08 PM   #6
Chris H
Member
 
Registered: Aug 2003
Location: Farnborough, UK
Distribution: Zenwalk
Posts: 288

Rep: Reputation: 30
ccin dunno if you're using Suse 9.0 but if you are then the CUPS password is an encrypted one. A search of their site will explain it all.
 
Old 03-13-2004, 04:12 PM   #7
ccin1492
Member
 
Registered: Feb 2004
Location: SoCal
Distribution: openSUSE 10.3
Posts: 139

Original Poster
Rep: Reputation: 15
Yes, I am using Suse 9.0. I'll check it out. Thanks!
 
Old 03-13-2004, 04:59 PM   #8
Chris H
Member
 
Registered: Aug 2003
Location: Farnborough, UK
Distribution: Zenwalk
Posts: 288

Rep: Reputation: 30
Here we go, link belwo shows you what to do.

http://portal.suse.com/sdb/en/2003/0...ichten-90.html
 
Old 03-14-2004, 12:27 AM   #9
ccin1492
Member
 
Registered: Feb 2004
Location: SoCal
Distribution: openSUSE 10.3
Posts: 139

Original Poster
Rep: Reputation: 15
After checking out that link, I discorvered I needed to run the following command:

lppasswd -g sys -a root

That did the trick. Thanks Chris!

TC
 
Old 08-29-2009, 02:58 AM   #10
senguttuvan
LQ Newbie
 
Registered: Feb 2009
Posts: 2

Rep: Reputation: 0
root password is enough

When i was facing the same problem,

I used my

Username = root user name
password = root password

and it is working fine now!
 
Old 12-18-2015, 03:48 PM   #11
Geremia
Member
 
Registered: Apr 2011
Distribution: slackware64-current
Posts: 399

Rep: Reputation: 41
Change some things in your /etc/cups/cupsd.conf file:

Change the authentication type to "None".
Remove any lines that have "@SYSTEM" in it.
Restart the CUPS daemon.
 
1 members found this post helpful.
Old 07-02-2018, 11:40 AM   #12
Felim_Doyle
LQ Newbie
 
Registered: Dec 2011
Location: Aylesbury, Buckinghamshire, UK
Posts: 4

Rep: Reputation: Disabled
Post CUPS username and password

Thanks Geremia!

Your solution still works with CUPS 2.1.3 on Linux Mint 18.3.

I changed the authentication type to "None" and selectively commented out "@SYSTEM" references so as not to completely compromise security (i.e. a job can still only be cancelled by the owner or root).
 
Old 02-03-2019, 02:26 PM   #13
BobKay
Member
 
Registered: Jul 2014
Posts: 37

Rep: Reputation: Disabled
I just enabled CUPS on my Slackware 14.2 system. I then connected via web browser to localhost:631. Under the "Administration" tab I clicked "Add printer", at which point it asked me for a username and password. I mistakenly entered my normal username & password instead of root's credentials. Of course it wouldn't let me perform any administrative tasks. The problem is that I can't figure out how to log out so I can log in properly as root. Does anyone know how to log out of CUPS?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
username and password no go bmd Linux - Newbie 7 04-06-2005 09:26 PM
CUPS: What URI to use when a username is needed without a password elluva Linux - Networking 0 02-26-2005 11:19 AM
username/password sailu_mvn Programming 5 12-21-2004 04:21 AM
CUPS: Username and password. aliiscool Linux - Software 6 07-15-2004 06:51 PM
Username and Password dance2die Arch 3 09-01-2003 04:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration