Latest LQ Deal: Latest LQ Deals
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 10-01-2015, 05:05 PM   #1
Registered: Sep 2010
Posts: 275

Rep: Reputation: 28
cups permission issue

okay, i have been rooting out a cups issue for a few hours now and figured out what is going on. now i just need help correcting the issue.

so i have a networked printer installed on my server. everything prints fine when i print from that computer. i installed said computer on another computer on the network. the installation seems to go well and all but when i go to print, nothing happens.

so, by basically back-tracing i found that the issue is a permission issue in /var/spool/cups. when i send a job through the file goes into there correctly however it gets the permission only 600 or the user can read and write but everyone else gets nothing while when i send a file locally it ends up with 640 permission or user can read/write and group can read. the owner of the directory is root and the user of course is lp.

i changed the directory to 777, then everything prints fine but when a new file is sent from my pc, it goes in there with a 600 permission and cannot print until i chmod the permissions again.

i am just not sure what i have to change to make the files i send go in there with the correct permissions so they can print. i appreciate any help.

by the way, this is related to errors, filter failed from cups so if you end up seeing that error, this is probably the issue.
Old 10-01-2015, 06:23 PM   #2
Registered: Sep 2015
Location: Tilburg, NL
Distribution: Slackware current
Posts: 31

Rep: Reputation: Disabled
you can set for each printer which users are allowed to print and which are not. you must be root to do this admin option. either allow all users, or deny none. that should do the trick.
just visit localhost:631, go to administration, manage printers, click on the printer, administration, allowed users
Old 10-01-2015, 08:01 PM   #3
Registered: Sep 2010
Posts: 275

Original Poster
Rep: Reputation: 28
yeah, i went into administration and set allowed all and still doesnt work....
Old 10-01-2015, 09:41 PM   #4
Registered: Sep 2010
Posts: 275

Original Poster
Rep: Reputation: 28
wow, what a horrible experience that was. i think i finally got it. the allow user thing i believe did nothing. i went into /etc/cups/cupsd.conf and in the section <Location /> i changed it from order deny,allow to order allow,deny and then added Allow from all and Allow from 192.168.0.* (the ip pool for my network) and then restarted cups.

i believe that i am going to remove allow from all because i believe that is too broad for security reasons hopefully it will work after that.

i believe this allowed the printer to finally be discoverable by the programs on my computer (not just adding a printer on my pc) and now do not have to add a printer on my pc any more. prior to this only my webbrowser could find the network printer and now it appears that all programs might be able to find it.
1 members found this post helpful.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cups authentication issue xsubira Linux - Software 7 06-28-2015 12:32 AM
[SOLVED] CUPS issue; error with network printer "/usr/lib/cups/backend/hp failed" floppy_stuttgart Linux - Newbie 1 06-22-2014 04:04 AM
7.10 cups permission denied error gothicbob Ubuntu 2 01-02-2008 10:03 AM
CUPS permission errors pwaring Linux - Software 0 08-09-2005 05:14 AM
Permission denied error when printing with CUPS Davidian1024 Linux - Software 3 07-18-2005 01:47 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:15 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration