-   Linux - Software (
-   -   CUPS issue with printing from Windows (

coreychch 10-19-2005 01:00 PM

CUPS issue with printing from Windows
Hi all,

I've just recently installed CUPS on FC3 to handle a Dell Photo Printer 720.

From a bit of research, I found that this Dell printer basically is a re-badged Lexmark Z600, and so I downloaded the driver file CJLZ600LE-CUPS-1.0-1.TAR.gz, extracted and installed the resulting rpms, and everything was good - I could print a *perfect* test page from the CUPS web printer admin screen.

Anyway - I then configured up samba to use CUPS for printing, and set up the [printers], [print$] sections of smb.conf. I also ran cupsaddsmb to set up auto-downloading of the drivers to the windows client (using the Microsoft Postscript drivers for Windows, as described in the cupsaddsmb man page). This all worked fine - managed to download and install the drivers from my Windows PC, and everything looked cool.

Only problem is, when I print from Windows, it goes completely through the motions of printing - but nothing prints at all!! Remember - the test page worked perfectly, so I don't think there's a problem with the CUPS setup.

I tracked what was being put into the cups error log (/var/log/cups/error_log), and it looked like it was trying to print the file ... but just not quite managing to do it:

d [20/Oct/2005:02:40:37 +1000] CloseClient: Removing fd 8 from InputSet and OutputSet...
D [20/Oct/2005:02:40:37 +1000] [Job 36] Printer using device file "/dev/usb/lp0"...
D [20/Oct/2005:02:40:37 +1000] [Job 36] LPGETSTATUS returned a port status of 18...
I [20/Oct/2005:02:40:37 +1000] [Job 36] Sending print file, 8192 bytes...
I [20/Oct/2005:02:40:37 +1000] [Job 36] Sending print file, 16384 bytes...
I [20/Oct/2005:02:40:37 +1000] [Job 36] Sending print file, 24576 bytes...
I [20/Oct/2005:02:40:37 +1000] [Job 36] Sending print file, 32197 bytes...
d [20/Oct/2005:02:40:37 +1000] PID 5566 exited with no errors.
D [20/Oct/2005:02:40:37 +1000] UpdateJob: job 36, file 0 is complete.
d [20/Oct/2005:02:40:37 +1000] UpdateJob: Removing fd 9 from InputSet...
D [20/Oct/2005:02:40:37 +1000] CancelJob: id = 36
D [20/Oct/2005:02:40:37 +1000] StopJob: id = 36, force = 0
D [20/Oct/2005:02:40:37 +1000] StopJob: printer state is 3
d [20/Oct/2005:02:40:37 +1000] StopJob: Freeing status buffer...
d [20/Oct/2005:02:40:37 +1000] SaveJob: Closing file 8...
d [20/Oct/2005:02:40:37 +1000] SaveJob: Closing file 8...

It seems to be going through the motions of printing - but not actually printing it. The line that interests me the most is the "LPGETSTATUS returned a port status of 18..." message. Browsing around on the web seems to indicate that CUPS thinks the printer is out of paper, but that isn't the case here - is there some sort of bug here which is stopping the printing from occurring? Nothing I saw really explained this very well, whether it is really a problem, and if so what to do about it.

Anyone have any suggestions as to what might be wrong or where to start looking for the problem here?

I'm using FC3 (kernel 2.6.12-1.1378_FC3), cups-1.1.22-0.rc1.8.7, and samba-3.0.10-1.fc3. Below are my cupsd.conf and smb.conf for reference if required:


LogFilePerm 0600
MaxLogSize 2000000000
LogLevel debug2
Printcap /etc/printcap
User lp
Group lp

<Location />
Order Deny,Allow
Deny From All
Allow From
Allow From All

Order Deny,Allow
Deny From All

<Location /admin>
AuthType Basic
AuthClass System
Order Deny,Allow
Deny From All
Allow From
Allow From All

<Location /printers/Dell720>
AuthType None
Order Deny,Allow
Deny From All
Allow From
Allow from All

Browsing On
BrowseProtocols cups
BrowseOrder Deny,Allow
BrowseAllow from @LOCAL
Listen *:631


workgroup = WORKGROUP
server string = File Server
hosts allow = 10.10.10. 127.
printcap name = cups
load printers = yes
printing = cups
cups options = raw
use client driver = no
log file = /var/log/samba/%m.log
max log size = 50
security = user
username map = /etc/samba/smbusers
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
dns proxy = no
template shell = /bin/false
winbind use default domain = no
comment = Home Directories
browseable = no
writable = yes
comment = All Printers
path = /var/spool/samba
browseable = no
guest ok = no
writable = no
printable = yes
comment = Printer Drivers
path = /etc/samba/drivers
browseable = yes
guest ok = no
read only = yes
write list = root

Thanks in advance to anyone who can help or point me in the right direction here.


foo_bar_foo 10-19-2005 04:59 PM

i can't really address you situation directly but what i always do is make an extra cue in cups to the printer and make it "raw" as in no driver
then just install the windows driver that comes with the printers windows disk.

All times are GMT -5. The time now is 06:24 AM.