-   Linux - Software (
-   -   CUPS and High CPU usage (

Malibyte 05-26-2003 02:07 PM

CUPS and High CPU usage
Have issues with CUPS running under Mandrake 8.2 on my office
box....this is a new thing (past couple of days). I usually use this printer to print output from an old DOS application (DataPerfect database app running under DOSEmu) pretty much exclusively.

Basically, what happens is this ... all's well until I send a print job.
Then the CUPS daemon immediately spikes CPU usage up to 97-100% and stays there, even after the job is done. The only way to solve it is to stop the daemon and restart it again later. Anyone else had this sort of issue with CUPS?

I'd really like to dump CUPS anyway and go back to LPRng, but if I do this I get this funky header on every page and it won't print high-order ASCII characters. As it is now, I have to use xpp to tell the printer to print "raw" output only to do this anyway, which is a PITA when I need to print graphics or dump a web page. I'm using an HP DeskJet 560c printer.

I don't have this sort of problem on my print server at home, which is running RedHat 7.3 and using LPRng (though with a couple of Epson printers).

<scratching head>

Thanks for any info....Bob

ccnpkid 08-26-2003 08:04 AM

Hi I am facing the same prob in a RH linux 9 box.
have u got any info ????? solution????????

dalek 08-26-2003 09:52 AM

Mine's pretty busy too
Mine gets a lot of CPU power too. Mine rig is pretty swift and it still takes a lot. On my old 400MHz it would grind almost to a halt. Would take hours to print 30 pages.
Don't know how to fix it but you are not alone.

:scratch: :scratch: :D :D

Agifem 08-26-2003 10:16 AM

It is normal that it takes the all CPU usage during the printing process, because the way LPT and printers work is obsolete and requires an active waiting. BUT it is not normal that it does not release the CPU once the job done. I Hope I helped.

Malibyte 08-26-2003 05:38 PM

I wound up solving the problem by upgrading the Mdk 8.2 box to 9.0...this solved a few other minor issues as well. I never did figure out WHY it was happening..sorry. :-|

-- Bob --

ccnpkid 08-27-2003 02:27 AM

Hi dalek

I got the solution for that.
Do the following ;
In cupsd.conf , check out these.

PreserveJobFiles Off
AutoPurgeJobs Yes

read explanation of the same in cups documentation and make changes.

Use top simulatneosly and fire prints to cups. u will see that %CPU usage goes high and coming down after job is spooled.

I thnk i helped u . pls rep[ly with results

Sarath Sivan

tuxave 08-30-2003 03:21 PM

I have noticed that CUPS constantly consumes about 25% of my CPU [AMD1.2] on my LInux box and 30% on my IMac [800]. While this doesn't affect me much on my Linux box, it does interfere with video editing on my IMac.

I am really curious why a passive daemon should be chewing my my CPU so much. Could this be related to broadcast notifications? Would still seem a bit high, though.

Tinkster 08-30-2003 05:03 PM

Must be specific to how CUPS is set-up
in MDK and RH then ... in my manual installs
on all Slack-boxes so far it never uses more
than 0.5% to 1.5% while waiting, and that
includes an old P166 :)


ccnpkid 09-03-2003 02:36 AM

CUPS page logging utilities.
Hi All

Normally in CUPS webadmin modu;e we get only details of the file name printer and username initiated the print. Anybody know whether there is any software or option available to list the no: pages also. However we can find it out from page_log file by comparing the job id. but it is not possible for a busy administrator. So if any program is available for showing the no: of pages in a user friendly way please reply.


Sarath Sivan

iainr 05-05-2004 02:20 PM

I've hit this problem for the first time ever. Cups worked fine in the past with Mandrake 9.1 & 9.2. With Mandrake 10 Community, after configuring a remote printer, cups ramps up to 99% of CPU after a few seconds and stays there. This is before I've submitted any print jobs. Cups isn't scanning for new printers as far as I know. Right now, starting CUPS to print is my workaround, but not great.

Any more ideas anyone? (I tried editing the conf file but no luck).

iainr 05-05-2004 03:47 PM

I've done a bit more checking on CUPS :
version 1.1.20-5mdk (1.1.20 is latest version as far as I can see - no updates for Mandrake Official)

The cupsd process runs on low CPU for about 20-30 secs after it's started. Then it climbs up to 99% very quickly and stays there. The only child process cupsd is calling is cups-polld, but that isn't using any significant CPU time.

CUPS only uses up the CPU if I have a printer configured (a remote one, I don't have a local printer to connect right now). As soon as I configure a remote print server and restart CUPS, it goes crazy. With no printers configured, CUPS behaves (but doesn't do anything useful, of course :mad: )

swiftnet 10-21-2004 10:56 AM

Anybody figure out the cups high CPU usage problem?
I have it happening to two separate clients, both have remote printers.

All times are GMT -5. The time now is 01:01 PM.