-   Linux - Software (
-   -   Crontab doesn't accept new entries (

Thakowbbery 08-18-2006 09:07 AM

Crontab doesn't accept new entries
Very strange

This is my crontab:

0 0 * * 7 /usr/local/squid/sbin/squid -k rotate
0-59 * * * * /etc/monitorasquid
0,15,30,45 * * * * /usr/local/squid/etc/inclui
5 0 * * 7 /usr/bin/sarg -n

The first line was recently changed, where I added the number 7, so it would be done on sundays.
The last line was addedd at the same time.
The thing is:

Both lines doesn't seen to work at all, while the other two work perfectly.
I already though it could be some problem with the scripts that were suposed to run, but both work if ran manually.
The logs just don't show nothing, like the lines were not recognised.

And also, running some tests, I added two simples commands:

X Y * * * /bin/echo "Test"
X Y * * * /sbin/ifconfig > /root/network
(Where X and Y are the minute and the hour I went on changing)

And those didn't work either.
I tried restarting crond, but I didn't work also.
I'm clueless about, please, can someone help me?

Thanks in advance

Tinkster 08-19-2006 02:39 AM

Which version of cron (vixie, dylans, ... )and which version number,
on which distro? How are you editing crontab?


Thakowbbery 08-21-2006 07:56 AM

Vixie Cron 3.0.1
Mandrake 9.0
Kernel 2.4.19
Using the old faithful Vi :P

Tinkster 08-21-2006 01:12 PM

I'd suggest that you try to find a newer rpm for cron for your
distro (you didn't mention which rpm version it was) but there
were TONS of fixes mentioned on a couple of pages I found looking
for 'vixie cron "3.0.1"" ...


camelrider 08-21-2006 01:56 PM

Have you tried editing crontab using the command:
crontab -e ?
This command opens a crontab-specific vi session. I'm not clear what the difference is but I think if your distro includes the command "crontab" then this is the standard way of editing the crontab files. To list what's already in a crontab file, use crontab -l .(That's a lower-case "L".

Let us know...

Thakowbbery 08-22-2006 01:49 PM

Well, I remembered one thing

I had installed Webmin in that server some time ago and never really used it.
Put it back to work and created the cronjobs there and guess what? It worked :P
Don't know what files does webmin changes, but it wasn't crontab.
Guess I'll take a look later on, but for now everything's working fine.

Thanks for the support everyone

All times are GMT -5. The time now is 03:35 AM.