LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Cron error: help with cron and changing system time (https://www.linuxquestions.org/questions/linux-software-2/cron-error-help-with-cron-and-changing-system-time-762173/)

hbbtstar 10-15-2009 02:15 PM

Cron error: help with cron and changing system time
 
Hi all!

I'm having a really weird problem that I can't seem to figure out. I have changed the system timezone from CST to EST, and now cron won't run, not even an hour early. If I do not specify an hour, they work; I.E. 15 * * * * works but 15 3 * * * does not work. I have seen some forum posts about unsetting $TZ, and I did, but it didn't work, and I've seen other posts that tell me to reboot the server. I'd really rather not reboot the server, if need be I could but I'd rather not suffer the downtime. Any ideas? Thanks!

EDIT: I realized I should probably provide a little more background info; it's been a long day, sorry. Cron was running fine, but I realized that jobs were running an hour early; not normally a big deal, but I thought I'd go ahead and change the timezone (which I did by symlinking the new timezone to /etc/localtime). I then noticed, however, that cron jobs that specified the hour simply failed to run. I checked cron.log, and nothing; it's as if it simply wasn't there in /etc/crontab. Other jobs in there that did not specify the hour, however, ran perfectly fine and were so noted by cron.log. I tried adding cron jobs in user crontabs, and nothing; the same error persists. I have restarted cron, with no luck; I don't know what else to do. Thanks in advance!

hbbtstar 10-15-2009 09:10 PM

After wrestling with it for quite a long time, I just notified users that there would be a momentary downtime and rebooted the server... it works fine now, but I have no idea what the problem was!


All times are GMT -5. The time now is 08:23 AM.