-   Linux - Software (
-   -   Creating partitions in Linux. (

RoaCh Of DisCor 07-17-2004 06:13 PM

Creating partitions in Linux.
Well, I'm starting to become low in disk space, on my linux partition, so I wanted to create another partition. I have lots of un partitioned space.

I was wondering how I would go about creating a fat32 *i want it to be seen in windows too*, partition, within linux.


zakaluka 07-17-2004 06:20 PM

Well, you would partition the drive (create a partition from unused space) using either fdisk or cfdisk.

When you create the partition, you can specify the file system type. Here, select FAT32.

Then, to format the partition as FAT32 (commonly called VFAT), use the command:

"mkfs -t vfat /dev/hdb1"

Replace /dev/hdb1 with your partition name/number. Take a look at for more information.

RoaCh Of DisCor 07-17-2004 06:25 PM

okay thanks, but the fdisk command seems to do nothing? :)

darin3200 07-17-2004 06:30 PM

Try following it with a drive, like /dev/hda or /dev/hdb and do it as root.
fdisk /dev/hda

RoaCh Of DisCor 07-17-2004 06:34 PM

I've tried...all I get is bash: fdisk: command not found

RoaCh Of DisCor 07-17-2004 06:43 PM

I cannot find it at it possible fdisk is not installed? Where can I get it?

RoaCh Of DisCor 07-17-2004 06:48 PM

doh, okay haha...I seem to have to execute /sbin/fdisk

That works.

Now I need to create a partition from unused space :|

I don't want to mess anything up..

heema 07-17-2004 06:49 PM

there is a program called qtparted which is just like partition magic

RoaCh Of DisCor 07-17-2004 07:20 PM

Okay, sweet. I resized my windows drive, to something way I now want to create a partition with the 15 gb of free space. I resized it with qtparted...worked great...but when I right click on the /dev/hda-1 which is free wont let me click on any of the options *like create*. I can only click on properties.

What do I do now?

All times are GMT -5. The time now is 06:19 AM.