LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-03-2015, 05:55 AM   #1
yanf81
LQ Newbie
 
Registered: Nov 2015
Posts: 10

Rep: Reputation: Disabled
CPU frequency governor configuration


Hi,
I would like to change the governor to "performance", but I don't even have the directory "cpufreq" under /sys/devices/system/cpu/cpuX/.

The only reason that made me believe that I work with "ondemand" governor is the fact that my kernel (4.1.6-200.fc22.x86_64) is configured with the below flag:
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y

Is there a way to change the governor type without recompiling the kernel?

Any suggestions will be highly appreciated.

Thanks
Yan

Last edited by yanf81; 11-03-2015 at 05:57 AM.
 
Old 11-03-2015, 06:15 AM   #2
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Location: Horgau, Germany
Distribution: Manjaro KDE, Win 10
Posts: 2,195

Rep: Reputation: 164Reputation: 164
Have a look here:

https://wiki.archlinux.org/index.php...quency_scaling
 
Old 11-03-2015, 08:14 AM   #3
yanf81
LQ Newbie
 
Registered: Nov 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
I already read this page, but unfortunately there is no explanation regarding what should be done if the cpufreq dir is missing.
 
Old 11-03-2015, 11:08 AM   #4
Keruskerfuerst
Senior Member
 
Registered: Oct 2005
Location: Horgau, Germany
Distribution: Manjaro KDE, Win 10
Posts: 2,195

Rep: Reputation: 164Reputation: 164
You have to install cpufreq utils.

What distro are you using?
 
Old 11-03-2015, 02:09 PM   #5
yanf81
LQ Newbie
 
Registered: Nov 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
I am using Fedora 22. Actually I already installed the cpu freq utills but the directory still didn't show up.
 
Old 11-04-2015, 09:55 AM   #6
yanf81
LQ Newbie
 
Registered: Nov 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Keruskerfuerst View Post
You have to install cpufreq utils.

What distro are you using?
hi,
could you please comment on my answer.
Thanks
 
Old 11-05-2015, 05:20 PM   #7
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu, Linux Mint
Posts: 1,714

Rep: Reputation: 400Reputation: 400Reputation: 400Reputation: 400Reputation: 400
Have you looked at this?
 
Old 11-06-2015, 12:12 AM   #8
yanf81
LQ Newbie
 
Registered: Nov 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Sure, it simply doesnt work. It prints CPU0 with empty info and thats all.
 
Old 11-06-2015, 04:50 PM   #9
RockDoctor
Senior Member
 
Registered: Nov 2003
Location: Minnesota, US
Distribution: Fedora, Ubuntu, Linux Mint
Posts: 1,714

Rep: Reputation: 400Reputation: 400Reputation: 400Reputation: 400Reputation: 400
Interesting. I'm running Rawhide (kernel 4.3.0-1.fc24.x86_64), and I get
Code:
~$ cpupower frequency-info --governors
analyzing CPU 0:
conservative userspace powersave ondemand performance
~$ cpupower frequency-set --governor ondemand
Subcommand frequency-set needs root privileges
~$ sudo cpupower frequency-set --governor ondemand
Setting cpu: 0
Setting cpu: 1
~$
However, I don't know if anything actually changed. I also get
Code:
~$ sudo cpupower info
System does not support Intel's performance bias setting
analyzing CPU 0:
~$
CPU is an AMD Athlon X2 5400+
 
Old 11-08-2015, 09:05 AM   #10
yanf81
LQ Newbie
 
Registered: Nov 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
So, perhaps its a Linux bug and looks like not in a single distro.
 
Old 11-08-2015, 01:18 PM   #11
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,982

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
Post more info about your system. Do you have any of the x86 CPU frequency scaling drivers in the kernel ?

I wrote a small howto here:
http://docs.slackware.com/howtos:har...quency_scaling

The directory won't show up unless you have the drivers that support your system.
 
Old 11-09-2015, 03:07 AM   #12
yanf81
LQ Newbie
 
Registered: Nov 2015
Posts: 10

Original Poster
Rep: Reputation: Disabled
Hi here is some more info. First, below I paste the kernel flags related to FREQ configuration.
Next, I show the related modules I have. BTW, when I tried loading any of the modules (using modprobe) I didn't get any errors but ! I didnt get any change either.

I really want to work with a standard kernel without any additional compilations etc...

Thanks in advance..

[root@magma14 ~]# cat /boot/config-4.1.6-200.fc22.x86_64 | grep FREQ
CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_GOV_COMMON=y
CONFIG_CPU_FREQ_STAT=m
CONFIG_CPU_FREQ_STAT_DETAILS=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_POWERSAVE is not set
# CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE is not set
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=y
CONFIG_CPU_FREQ_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=y
CONFIG_X86_PCC_CPUFREQ=m
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_ACPI_CPUFREQ_CPB=y
CONFIG_X86_AMD_FREQ_SENSITIVITY=m
CONFIG_PM_DEVFREQ=y
# DEVFREQ Governors
CONFIG_DEVFREQ_GOV_SIMPLE_ONDEMAND=m
# CONFIG_DEVFREQ_GOV_PERFORMANCE is not set
# CONFIG_DEVFREQ_GOV_POWERSAVE is not set
# CONFIG_DEVFREQ_GOV_USERSPACE is not set
# DEVFREQ Drivers
# CONFIG_PM_DEVFREQ_EVENT is not set



[root@magma14 ~]# /sbin/modinfo /lib/modules/$(uname -r)/kernel/drivers/cpufreq/* | grep "^[fd]"
filename: /lib/modules/4.1.6-200.fc22.x86_64/kernel/drivers/cpufreq/acpi-cpufreq.ko.xz
description: ACPI Processor P-States Driver
depends:
filename: /lib/modules/4.1.6-200.fc22.x86_64/kernel/drivers/cpufreq/amd_freq_sensitivity.ko.xz
description: AMD frequency sensitivity feedback powersave bias for the ondemand governor.
depends:
filename: /lib/modules/4.1.6-200.fc22.x86_64/kernel/drivers/cpufreq/cpufreq_stats.ko.xz
description: Export cpufreq stats via sysfs
depends:
filename: /lib/modules/4.1.6-200.fc22.x86_64/kernel/drivers/cpufreq/p4-clockmod.ko.xz
description: cpufreq driver for Pentium(TM) 4/Xeon(TM)
depends: speedstep-lib
filename: /lib/modules/4.1.6-200.fc22.x86_64/kernel/drivers/cpufreq/pcc-cpufreq.ko.xz
description: Processor Clocking Control interface driver
depends:
filename: /lib/modules/4.1.6-200.fc22.x86_64/kernel/drivers/cpufreq/powernow-k8.ko.xz
description: AMD Athlon 64 and Opteron processor frequency driver.
depends:
filename: /lib/modules/4.1.6-200.fc22.x86_64/kernel/drivers/cpufreq/speedstep-lib.ko.xz
description: Library for Intel SpeedStep 1 or 2 cpufreq drivers.
depends:
 
Old 11-15-2015, 01:03 PM   #13
metaschima
Senior Member
 
Registered: Dec 2013
Distribution: Slackware
Posts: 1,982

Rep: Reputation: 491Reputation: 491Reputation: 491Reputation: 491Reputation: 491
What about the 'X86_INTEL_PSTATE' driver ?

Also, what processor do you have Intel/AMD make, model ?

Also, check your UEFI/BIOS settings and make sure cpu frequency scaling is enabled.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] CPU governor problem Phorize Slackware 10 11-03-2015 07:07 AM
Is there any book about cpu governor? demonguy Linux - Kernel 2 08-24-2015 07:39 AM
LXer: Samsung Introduces "LAB" Linux Frequency Governor LXer Syndicated Linux News 0 04-10-2013 05:31 AM
CPU governor fails to set frequency on Atom 230 Weapon S Linux - Hardware 2 03-21-2013 03:55 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration