-   Linux - Software (
-   -   courier-imap - libssl & libcrypto deps (

mikeindo 05-28-2004 10:42 AM

courier-imap - libssl & libcrypto deps
i'm a newbie. just installed RH9 and ultimately trying to get squirrelmail running. i've set postfix (i think) and am to the point of installing my imap server (chose courier-imap). but installing with...

rpm -i courier-imap-3.0.4-1.7.3.i386.rpm

unfortunately produces...

failed dependencies is needed... is needed...

i first tried installing an older version of courier-imap but same error. also tried running with --nodeps but other errors appeared. did --whatprovides and eventually found in /lib that (???) is related to openssl-0.9.7a. all references online to refer to openssl-0.9.6b! how can downgrading openssl upgrade libssl? couldnt seem to find anywhere on my system, but of course, i may not be looking in the right place...

please help! thanks.

chrisan99 05-28-2004 11:14 AM

How about if you get a SRPM of courier and do a rebuild for your system ?


mikeindo 05-28-2004 11:24 AM

uh.. hehheh... you mean find a "courier-imap....src.rpm" somewhere, right? and customize it so it doesnt rely on and um, how do i do that?

chrisan99 05-28-2004 12:05 PM

uhh - ok - I've just compiled courier-imap-3.0.3.tar.bz2 from source code on Redhat 9 using
./configure <blah options>
make check

[root@candrew courier-imap-3.0.3]# rpm -qil courier-imap
Name : courier-imap Relocations: (not relocateable)
Version : 3.0.3 Vendor: (none)
Release : 1 Build Date: Fri 28 May 2004 18:01:13 BST
Install Date: Fri 28 May 2004 18:01:29 BST Build Host: candrew.oxspring.comGroup : Applications/System Source RPM: courier-imap-3.0.3-1.src.rpm
Size : 1192611 License: GPL
Signature : (none)
Packager : checkinstall-1.5.3
Summary : Package created with checkinstall 1.5.3
Description :
Package created with checkinstall 1.5.3


mikeindo 05-28-2004 03:37 PM

chris, thanks again for your reply. ok, i found courier-map-3.0.3.tar.bz2, and ran ./configure (had to get gcc first) but with no options, then make.

***No target specified and no makefile found

an 'ls' verified no "make", but and

tried finding an RPM of that version, found 3.0.3-1 instead and naturally failed dependencies. argh. if youre kind enough to post another reply, i'll meanwhile find an SRPMS of it to try...

thanks again for help!

chrisan99 05-28-2004 03:48 PM


It sounds like your configure didn't complete ? If it did, you should have a file called Makefile

Compiling from source is always more tricky than installing from RPM/SRPM. Thats why I initailly suggested SRPM. You have to remember that even though your initial RPM wanted, etc, when you compile from SRPM, you are effectively recompiling from source, and this process will generally utilise whatever binaries, object files, libraries are available on your unit.

Also, as you have found, there are some components missing - I always install the kernel source and kernel utils when installing Linux.

Just another thought, is there a particular reason why you need such a recent courier-imap. You might have better luck if you drop back a release or two?


mikeindo 05-28-2004 04:00 PM

yeah, i might start dropping back on versions!

is there a way to verify the configure finished successfully? looking thru each line as it ran, it seemed that everything looked good. no errors or "cant find this." at the end was a lot of text about using RPMs instead of going from source, each line preceeded with

configure: WARNING === use the
configure: WARNING === RPMs instead
configure: WARNING === of source
configure: error: ... in either case you better know what youre doing!

that last 'error' line doesnt mean anything, does it?

even SRPMS seems to have its own set of variables to F up!

again, much appreciation!

chrisan99 05-28-2004 04:12 PM


Yes your configure failed - and a lack of a Makefile confirms this.

One thing I did notice when compiling from source was a friendly warning along the lines of "why are you doing this, we have a full set of binaries (RPMS) available on our website". It might be worth looking at slightly later versions of either RPM or SRPM?


mikeindo 05-28-2004 04:17 PM

so a "" and "" are not what i'm looking for? i wonder why it failed...

yes, i'm definitely going to look for older versions...

All times are GMT -5. The time now is 05:14 PM.