-   Linux - Software (
-   -   copying from win partition (

Nechos 09-29-2003 10:26 AM

copying from win partition
i have mdk9.1 / , /home and swap partitions plus two windows98 partiton (c: & d:). as a user, when i explore d: partition (with konqueror) i se only the folder without free spaces in its name - is it possible that linux doesn't recognize win files/folders that have more than 1 word (eg. 'My Music' folder or 'New Doc.txt' file)? do i have to change all the filenames? it would be REALLY hard thing to do - i have 100,000 files (more or less) in my win partitions, of wich couple of thousand that i need...
i have cd's with the same naming - i won't be able to read them?!?
help needed...:cry:

Panzerfrost 09-29-2003 10:31 AM

Ahh all I can tell you is that it shouldn't be this way, I was able to see all my filenames. Unfortunately I'm too much a newbie to understand how to help you, but don't start renaming :)

coolamit78 09-29-2003 10:48 AM

ok.....see, in linux, you can easily switch to folders with spaces in their name:

lets assume, you have the folder Program Files in your windows C drive mounted as /mnt/windows

Now to access this folder, open a command prompt(terminal) and give the command:

$ cd /mnt/windows/Program\ Files OR

$ cd /mnt/Windows/My\ Documents/My\ Music (If this command does not work in one go, try the above command in 2 steps..)

1. $ cd /mnt/windows/My\ Documents
2. $ cd My\ Music

(Note the backspace '\' is used as an escape character to make the shell understand that 'Program Files' are not two words but one single directory)

similarly, you can switch to your CD-ROM by using the above method.

In GUI mode or X-Window system, you wont face any problem with the name of the folders including white spaces.

In case you are not able to access these folder names with white spaces in KDE/GNOME, then it may be possible that somewhere there is a setting to use 8.3 file naming convention( which is used in DOS).

Check Konqueror settings/preferences......and 'folder options' to find out if file names are set to 8.3 naming convention.

I hope this will help.

Nechos 09-29-2003 11:02 AM

thanx a lot:D
could i ask another question: how to create a sound device? i don't have it (and SHOULD have it...)

aaa 09-29-2003 11:04 AM

If filenames are truncated like they would look in dos, check the /etc/fstab file to make sure you are mounting your Windows drives as vfat, and not something like msdos.

All times are GMT -5. The time now is 10:26 PM.