-   Linux - Software (
-   -   copy flash from cisco 2950 router to another one that has no flash (

bladerunner12120 11-16-2006 12:45 PM

copy flash from cisco 2950 router to another one that has no flash
hi i need to copy the flash from one cisco 2950 router to another one that HAS NO FLASH! have been trying for days with a few others to no avail, any help would be greatly appreciated. i am using slack 11 with kernel and am accessing the router with minicom

farslayer 11-17-2006 07:28 AM

do you have a tftp server configured ? copy the flash image to the tftp server from the running Device, then boot the other device and retrieve the image from the tftp server. Isn't a 2950 a Switch ?

Upgrading Software Images on Catalyst 2950 and 2955 Series Switches using the Command Line Interface

Recovery from Missing or corrupt software on a Cisco 2900XL Series switch

Loading and Maintaining System Images and Microcode (IOS GUIDE)

copy flash tftp

copy tftp flash

bladerunner12120 11-21-2006 01:29 PM

ok ive got it copied to a hard disk but i cant copy it to the flashless switch because it keeps saying permission is denied.... any ideas?

farslayer 11-21-2006 10:25 PM

How are you trying to copy it to the switch with no image ? where are you when you receive that message ? are you using the procedure I linked to above ?

Recovery from Missing or corrupt software on a Cisco 2900XL Series switch

That would be the most likely (ok ONLY) method of getting a working image back on the switch if it's not currently running working software..

Pay particular attention to (Section B) Copy a New Software Image from ROM Monitor which explains step by step how to use the ROM image on the switch to load a new Software image into flash..

bladerunner12120 12-07-2006 01:45 PM

ok the only problem with that is that there is not only no flash but also no ther files on the switch the only file on the thing is env_vars and i dont have the eneable command or nothin... ive tried entering rom monitor mode by sending breaks on bootup which is so far as ive found the only way to enter rommon mode without the enable command. whenever i try useing xmodem to transfer files to it it says "this file is not an SGML document" and cancels the transfer.. thats when i try transfering the OS to it... when i try and transfer the other small files i need itr says that there cannot be an ! in the prolog and cancels the transfer yet again.... and the above texts dont say anything about this situation..... weve done an ascii transfer and it said it transfered but not the whole thing and we couldent find the part that it said it had transfered either... any ideas? cause im lost

farslayer 12-07-2006 03:25 PM

You should be transferring a single file with a bin extension according to that document..

I am not sure what you are trying to do, because I don't think you are following the directions provided by Cisco.. I have never transfered a bunch of individual files to a system, its a single image file something like c2955-i6q4l2-mz.121-13.EA1.bin and that's it.. and the software image would be a binary transfer if prompted not ascii.
You did follow the link to the detailed article on the topic right ?

Yes you must use the break sequence to enter rommon mode because that's the only way to get there.. Rommon mode is prior to the switch booting the software installed in flash memory(which your switch apparently doesn't contain anyway.. )

And Hyper Terminal is a big hunk of garbage, imho. Download a decent terminal application like Tera Term Pro.
So much easier to work with and configure than Hyperterminal.
Even as old as it is TeraTerm is way better than Hypertemial.

The switch shouldn't care about the file type it should just accept the transfer so I have no idea what is throwing that SGML error.

You could always call TAC if you need professional assistance.

bladerunner12120 12-08-2006 01:09 PM

we followed the directions on that page step by step as far as we could till we hit something that made it not work... wich was usualy a permission denied error. and for some other reason it will not enter rommon mode when we send a break either. the reason we tried sending smaller files was because.. well... heres what a normal router we have looks like in the flash directory

2 -rwx 2490607 Mar 01 1993 00:03:03 c2950-i6q4l2-mz.121-9.EA1.bin
3 -rwx 1838 Mar 01 1993 00:38:19 config.text
4 -rwx 2047 Mar 01 1993 00:12:27 start]
5 -rwx 269 Jan 01 1970 00:06:07 env_vars
6 -rwx 592 Mar 01 1993 00:00:20 vlan.dat
7 -rwx 108 Mar 01 1993 00:01:43 info
8 drwx 640 Mar 01 1993 00:03:53 html
19 -rwx 108 Mar 01 1993 00:03:53 info.ver
20 -rwx 153 Mar 01 1993 00:29:42 layout.text
21 -rwx 120 Mar 01 1993 23:11:10 layoutOption.txt
22 -rwx 2490607 Mar 01 1993 00:11:11 system
23 -rwx 1838 Mar 01 1993 00:39:08 switch-confg

now heres how it looks in the flash directory of the one that were working on

3 -rwx 8 <date> env_vars

7739904 bytes available (1536 bytes used)

and thats all. any suggestions on how to get the enable command to the one that doesnt work? or if theres a way to use the working switches flash_init and load_helper on it or to transfer theme... or is there any way to access the bad switch with the good one so that we can do transfers? if you wana give up on this one i dont blame ya cause were about 2 seconds away from dropping it ourselves. thanks for the help you have given us and any future input. were much abbliged

farslayer 12-08-2006 01:17 PM

Most of those other files look like configuration files and may be created automatically after the switch boots from the IOS image..

I would concentrate on getting the IOS image on the switch and see if you can get it to boot.

you can NOT get into enable mode until you have software on the switch until then you are stuck with the basic image that is in ROM.

so basically you cannot get this binary file c2950-i6q4l2-mz.121-9.EA1.bin onto the new switch ?

Complete error messages would be helpful in troubleshooting. Enable logging in TeraTermPro so you can cut and paste the errors as you attempt the procedure.

Saying it gives an error about permissions isn't helpful to either of us.. When does it give the error, what exactly were you doing.. What steps did you do before that ? that can all be logged with teraterm

Newtonx 12-08-2006 01:19 PM

have faith bro, with the help of this website we shall prevail, btw scotty you owe me 20 bucks

drgnlegend3 02-05-2007 09:57 AM

re: bladerunner
same problem here

drgnlegend3 02-05-2007 09:58 AM

hey bladerunner the am is having the same problem as the pm.

to anyone thats willing to help bladerunner heres a picture of the problem don't give up we need you.

bladerunner12120 04-02-2007 01:20 PM

we got it fixed all we had to do was reformat and do a fresh install. *bangs head on desk*

linuxnorth 09-09-2008 05:01 PM

Flash copy
I think the original poster meant to ask how to copy all the files and directories in flash, not only the IOS image.
I have a similar issue and I was wondering if there is a way to do this transfer using the command line.
Doing this from one flash card to another is easy using a card reader.
Going from a pluggable CF card to internal flash is the problem.

All times are GMT -5. The time now is 09:30 AM.