LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-23-2009, 11:11 PM   #1
jimbro727
LQ Newbie
 
Registered: Jul 2009
Posts: 6

Rep: Reputation: 0
Control key not working after installing KDE4


I just installed KDE4.3 on Gentoo. I was previously running XFCE. Ever since the install, my left and right control keys don't work, and I have no idea why. They still work in XFCE.

I don't get a keypress event in xev, this is what I get the first time I press left control after running xev:

Code:
FocusOut event, serial 34, synthetic NO, window 0xe00001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 34, synthetic NO, window 0xe00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 34, synthetic NO, window 0x0,
    keys:  4294967181 0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
And this is what I get every other time:

Code:
FocusOut event, serial 34, synthetic NO, window 0xe00001,
    mode NotifyGrab, detail NotifyAncestor

FocusIn event, serial 34, synthetic NO, window 0xe00001,
    mode NotifyUngrab, detail NotifyAncestor

KeymapNotify event, serial 34, synthetic NO, window 0x0,
    keys:  2   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
           0   0   0   0   0   0   0   0   0   0   0   0   0   0   0   0
(I've bolded the difference)

Can anyone shed some light on this? I've done a ton of searching and can't find anything relevant. I found a bug that appears to be related to gnome and the "find mouse pointer" setting, which produces the same results, but can't find a similar setting or bug in KDE.

Thanks! I'm dying to get KDE on my laptop, but having no control key is a deal breaker!!

-Jim
 
Old 09-24-2009, 02:07 PM   #2
jimbro727
LQ Newbie
 
Registered: Jul 2009
Posts: 6

Original Poster
Rep: Reputation: 0
UPDATE: The issue appears to be with compiz-fusion (which I already had installed). If I disable/enable some of its plugins, it randomly releases the control key. I haven't figure out what causes this yet. I don't have compizconfig-backend-kconfig installed, because it doesn't appear to be compatible with KDE4. I don't know if that's causing this issue or not..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware64-current, KDE4.2.3: Pipe key not working in Konsole gargamel Slackware 5 05-22-2009 07:11 AM
How to make Caps-lock key as additional Control key. snr8fl3 Linux - General 1 11-25-2008 05:49 PM
weird kde4 menu shortcut key behavior janhe Slackware 0 10-15-2008 02:40 PM
How can I map the control key to the caps lock key in Linux? tate1615 Linux - General 4 07-14-2008 01:20 PM
Control Key not working! pfeito Linux - General 2 04-06-2006 10:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 08:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration