LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-02-2005, 12:15 AM   #1
Tylerious
Member
 
Registered: Feb 2005
Location: USA
Distribution: Gentoo
Posts: 72

Rep: Reputation: 15
Connecting to Linux box from Windows with Samba


I'm using Slackware 10.2 and just downloaded/installed Samba. I've got it set so my Linux box (LINUXBOX), is in the same Workgroup (MSHOME) as my Windows box (THUMPER). I can mount THUMPER's shares onto LINUXBOX as a guest. But I can't access any LINUXBOX shares from THUMPER. When I try to browse LINUXBOX, I get a login screen and nothing works!

All I want is a simple public share on LINUXBOX that one doesn't need to log in to. But even if I could get logging in to work, I be happy. I've read some stuff saying your Windows usernames need to be the same as your Linux usernames.. is that really true or is there another way. That seems incredibly inconvenient; moreso than the idea of Samba in general.

My smb.conf file as listed by testparm:
Code:
[global]
  workgroup = MSHOME
  server string = Bedroom
  log file = /var/log/samba/samba.%m
  max log size = 50
  dns proxy = No

[homes]
  comment = Home
  read only = no
  create mask = 0750
  browsable = No

[public]
  path = /usr/public
  read only = No
  guest only = Yes
  guest ok = Yes

[printers]
  comment = All Printers
  path = /var/spool/samba
  printable = Yes
  browsable = No
/usr/public is chmoded to 777. But it still appears to be a problem with permissions/users.

Any suggestions on getting this thing working correctly?
 
Old 10-02-2005, 03:15 AM   #2
kamowa
Member
 
Registered: Sep 2004
Location: Eau Claire, WI
Distribution: Fedora Core 12
Posts: 91

Rep: Reputation: 15
well, first make sure you dont have a firewall on the linux box on, that could be the problem.


2nd, I'd try makeing the shared folder in the homes directory, and make it browsable

here is what I have my smb.conf set as:


[homes]
comment = Home Directories
browseable = yes
writeable = yes
guest ok = yes

[john]
comment = shared
path = /home/john
browseable = yes
writeable = yes
guest ok = yes

if you want you can view my entire smb.conf file

http://webzoom.freewebs.com/2ndrangersairsoft/smb.conf

For me I made a john account and made its home directory the shared folder.

of course the "john" folder is chmoded to 777.
 
Old 10-02-2005, 03:36 AM   #3
gkiagia
Member
 
Registered: Oct 2003
Location: Greece
Distribution: Debian sid
Posts: 248

Rep: Reputation: 30
Or maybe try to login as Administrator and give the root password.
I had the same problem. I don`t remember what I did in the config, but finally, I managed to login with that username.
 
Old 10-02-2005, 04:02 AM   #4
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
In the global section add or edit security so that it is set to shared. This setting is used to test SAMBA configuration, but you can use it for personal setups.

In the public section add:
force directory mode = 0777
force create mode = 0666

This will make directories have a permission of 777 or read, write, and execute. Also it will make files 666 or read and write.
 
Old 10-02-2005, 04:52 AM   #5
RSpendl
LQ Newbie
 
Registered: Oct 2005
Location: Slovenia
Posts: 11

Rep: Reputation: 0
Firewall (ports 137-139) is probably issue, besides you have to create samba users with 'smbpasswd -a username'. These usernames/passwords are the ones you have to use when connecting the network drive in windows. Usernames and passwords in Windows and Linux do NOT have to be the same (they can be, but not necessary).
 
Old 10-02-2005, 08:58 AM   #6
fotoguy
Senior Member
 
Registered: Mar 2003
Location: Brisbane Queensland Australia
Distribution: Custom Debian Live ISO's
Posts: 1,286

Rep: Reputation: 62

Just read your full smb.conf, so my suggestion is of no use

Last edited by fotoguy; 10-02-2005 at 09:05 AM.
 
Old 10-02-2005, 11:01 AM   #7
Tylerious
Member
 
Registered: Feb 2005
Location: USA
Distribution: Gentoo
Posts: 72

Original Poster
Rep: Reputation: 15
I didn't want the [homes] section, so I have it working with the following setup:

Code:
[global]
   workgroup = MSHOME
   server string = Bedroom
   security = share
   hosts allow = 192.168.1. 127.
   load printers = yes
   log file = /var/log/samba.%m
   max log size = 50
   socket options = TCP_NODELAY 
   dns proxy = no 
   guest ok = yes

[shared]
   comment = Linux Share
   path = /home/shared
   browsable = yes
   writable = yes

[printers]
   comment = All Printers
   path = /var/spool/samba
   browseable = no
   guest ok = yes
   writable = no
   printable = yes
I didn't even have to create a new user on the Linux box; just the /home/shared directory, chmoded to 777. I can even print to my Linux printer now, woo hoo! Thanks for helping me on this; it's very nice to share stuff between computers!
 
Old 10-04-2005, 09:28 AM   #8
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 234Reputation: 234Reputation: 234
And thanks for posting your solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Samba - one windows box cant see my Linux fileserver crm Linux - Networking 2 11-08-2004 03:37 PM
trouble connecting from windows xp to linux with samba magicked Linux - Networking 4 07-10-2004 10:06 PM
SAMBA problem - connecting to linux from windows jdklein1975 Linux - Newbie 13 05-23-2003 01:02 AM
Linux box - Windows box =Samba? hbidad Linux - Software 7 02-10-2003 11:00 PM
Can't see linux box running Samba from Windows machine RBLynch Linux - Newbie 2 03-21-2002 08:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:29 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration