LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-22-2014, 09:46 PM   #1
vockleya
Member
 
Registered: Aug 2009
Posts: 87

Rep: Reputation: 16
Conky startup issues


I'm having some issues with Conky not working correctly on login. I'm using a pretty standard install of Xubuntu 14.04. I see the window for a few seconds right after login, but when the desktop picture appears, conky disappears behind it. It's still running, but it is behind the desktop image. I have tried adding a sleep command to the startup script to force Conky to run later, but it just seems to make login in take longer.

I think it may be something to do with my graphics drivers. I have an Nvidia GTX 750 TI, so I can't use the drivers in the repositories. The most current driver in the repositories is 331, which doesn't support the 750 TI. I had to download the more recent 334 branch from Nvidia's website and install it using their supplied installer script.

Any thoughts?

Here is my .conkyrc config file.
Quote:
background no
update_interval 1
default_color darkgrey
draw_outline no
format_human_readable yes

own_window yes # create a separate XWindow over the one from Xfdesktop
own_window_colour white
own_window_type override # the window cannot be moved or resized
#own_window_argb_visual no # =NO : Important otherwise own_window yes don't work !!
#own_window_argb_value 0 # make the background semi-transparent
own_window_transparent yes
own_window_class Conky

double_buffer yes # avoid flickering

cpu_avg_samples 2
net_avg_samples 2

use_xft yes
xftfont Inconsolata:size=11

gap_x 15
gap_y 15
alignment top_right

default_bar_size 100 7

TEXT
${color c7c7c7}$nodename - $sysname $kernel on $machine
${color c7c7c7}$stippled_hr
${color}Uptime: $uptime - Load: $loadavg
${color}Core 1: ${platform coretemp.0 temp 2}C ${cpu cpu1}% ${alignr}${color #9030a0}${cpubar cpu1 7,160} ${color}${freq_g 1}GHz
${color}Core 2: ${platform coretemp.0 temp 3}C ${cpu cpu2}% ${alignr}${color #8030b0}${cpubar cpu2 7,160} ${color}${freq_g 2}GHz
${color}Core 3: ${platform coretemp.0 temp 4}C ${cpu cpu3}% ${alignr}${color #7030c0}${cpubar cpu3 7,160} ${color}${freq_g 3}GHz
${color}Core 4: ${platform coretemp.0 temp 5}C ${cpu cpu4}% ${alignr}${color #6030d0}${cpubar cpu4 7,160} ${color}${freq_g 4}GHz
${color}GPU:${color #5030e0} ${exec nvidia-smi -q -d temperature | grep Gpu | cut -c 39-40}C ${color}MB Temp:${color #3020e0} ${hwmon temp 2}C ${color darkgrey}Ambient Temp:${color #3020e0} ${hwmon temp 1}C
${color black}${cpugraph 000000 5000a0}
${color darkgrey}RAM Usage:$color $mem/$memmax ${alignr}$memperc% ${membar 7,100}
${color darkgrey}Swap Usage:$color $swap/$swapmax ${alignr}$swapperc% ${swapbar 7,100}
${color darkgrey}VRAM Usage:$color ${exec nvidia-smi -q -d memory | grep -m 1 Used | cut -c 39-42 | tr -d ' '}MiB/${exec nvidia-smi -q -d memory | grep -m 1 Total | cut -c 39-42}MiB\
${alignr}${exec used=`nvidia-smi -q -d memory | grep -m 1 Used | cut -c 39-42 | tr -d ' '` && total=`nvidia-smi -q -d memory | grep -m 1 Total | cut -c 39-42` && percent=`calc $used/$total*100 | cut -c 3-8` && printf "%.0f" "$percent"}% \
${execbar used=`nvidia-smi -q -d memory | grep -m 1 Used | cut -c 39-42 | tr -d ' '` && total=`nvidia-smi -q -d memory | grep -m 1 Total | cut -c 39-42` && percent=`calc $used/$total*100 | cut -c 3-8` && printf "%.0f" "$percent"}
${color c7c7c7}$stippled_hr
${color c7c7c7}Networking:
${color}Down:${color #8844ee} ${downspeed eth0}/s${color} ${offset 80}Up:${color #22ccff} ${upspeed eth0}/s
${color}${downspeedgraph eth0 32,150 ff0000 0000ff} $alignr${color}${upspeedgraph eth0 32,150 0000ff ff0000}
$color$stippled_hr
${color c7c7c7}File systems:
${color}/: ${fs_used /}/${fs_size /} ${alignr}${fs_bar /}
${color}/home: ${fs_used /home}/${fs_size /home} ${alignr}${fs_bar /home}
${color}Windows Boot: ${fs_used /media/aaron/Windows Boot}/${fs_size /media/aaron/Windows Boot} ${alignr}${fs_bar /media/aaron/Windows Boot}
${color}Windows 2: ${fs_used /media/aaron/Windows 2}/${fs_size /media/aaron/Windows 2} ${alignr}${fs_bar /media/aaron/Windows 2}
${color c7c7c7}$stippled_hr
${color}Processes:$color $processes Running: $running_processes
${color c7c7c7}Name PID CPU% MEM%
${color #ddaa00} ${top name 1} ${top pid 1} ${top cpu 1} ${top mem 1}
${color} ${top name 2} ${top pid 2} ${top cpu 2} ${top mem 2}
${color} ${top name 3} ${top pid 3} ${top cpu 3} ${top mem 3}
${color c7c7c7}Mem usage
${color #ddaa00} ${top_mem name 1} ${top_mem pid 1} ${top_mem cpu 1} ${top_mem mem 1}
${color} ${top_mem name 2} ${top_mem pid 2} ${top_mem cpu 2} ${top_mem mem 2}
${color} ${top_mem name 3} ${top_mem pid 3} ${top_mem cpu 3} ${top_mem mem 3}
 
Old 06-22-2014, 11:01 PM   #2
Randicus Draco Albus
Senior Member
 
Registered: May 2011
Location: Hiding somewhere on planet Earth.
Distribution: No distribution. OpenBSD operating system
Posts: 1,711
Blog Entries: 8

Rep: Reputation: 634Reputation: 634Reputation: 634Reputation: 634Reputation: 634Reputation: 634
Code:
own_window_type  override            # the window cannot be moved or resized
Do you need that line?
Quote:
#own_window_argb_visual no # =NO : Important otherwise own_window yes don't work !!
#own_window_argb_value 0 # make the background semi-transparent
This looks really suspect, unless Buntu has some really weird configurations (which of course is entirely possible). For example, this is the relevant portion from my conky.conf. Short and simple.
Code:
own_window yes
own_window_class Conky
own_window_type desktop
own_window_argb_visual yes
own_window_argb_value 0
 
Old 06-22-2014, 11:34 PM   #3
rokytnji
LQ Veteran
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 19
Posts: 6,292
Blog Entries: 21

Rep: Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152Reputation: 3152
Mine in xfce is a horizontal transparent . Like R.A.D. Debian instead of Ubuntu

Before text mine says

Code:
xftfont Bitstream Vera Sans:size=7
xftalpha 0.8
update_interval 2
own_window no
double_buffer yes
draw_shades no
draw_outline yes
stippled_borders no
border_width 1
default_color white
default_shade_color black
alignment top_right
minimum_size 1262
gap_x 9
gap_y 9
use_spacer none
no_buffers yes
uppercase yes
It Auto starts just fine and looks like

http://postmyimage.com/img2/572_Scre...11_31_44_P.png

Edit to suit your needs I guess.
 
Old 06-23-2014, 01:27 PM   #4
vockleya
Member
 
Registered: Aug 2009
Posts: 87

Original Poster
Rep: Reputation: 16
I've done a bit of testing with different config options, and nothing seems to fix my issue. Setting own_window to anything other than override results in either conky or my desktop icons disappearing randomly, and also when clicking on the desktop. The original issue of conky disappearing when the desktop image appears is still there. Trying to make conky load after the desktop by adding a sleep command to the startup script actually results in conky not starting at all. When there is no sleep command, conky starts, and then gets hidden by the desktop image, but is still running behind it.

Here is the relevant part of my new .conkyrc file.
Quote:
use_xft yes
xftfont Inconsolata:size=11

own_window yes
double_buffer yes
own_window_class Conky
own_window_type override
own_windows_transparent yes

gap_x 15
gap_y 15
alignment top_right

update_interval 1

default_bar_size 100 7
default_color darkgrey
cpu_avg_samples 2
net_avg_samples 2

Last edited by vockleya; 06-23-2014 at 08:55 PM.
 
Old 06-23-2014, 01:51 PM   #5
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
I've always used
Code:
own_window_type desktop			
own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager
Never an issue on Xfce4.x

Just saying.

What happens if you run conky -c /path/to/your/conkyrc in a terminal?

Is it any different?
 
Old 06-23-2014, 09:16 PM   #6
vockleya
Member
 
Registered: Aug 2009
Posts: 87

Original Poster
Rep: Reputation: 16
Using the "own_window desktop" or "own_window_type desktop" directives cause the desktop icons to disappear. The icons are still there, as clicking on where they should be makes them show up again, but when conky refreshes, they disappear again. There's also the minor annoyance of the drag-to-select box causing any part of the conky window it covers to disappear until the next update. I'm pretty sure I have the settings correct, as conky works perfectly once started from the terminal. It's just the autostart part that doesn't work. It shows up correctly for a few seconds and then disappears when the desktop image loads.

Something I just thought of. I have a 3-monitor setup. On the login screen, all the monitors display the left monitor's image. Once I log in, it takes a few seconds for it to load in the correct images for the middle and right screens. It's when this happens that conky, running on the right screen, disappears. Might there something weird about multi-monitor setups and the desktop background stuff?
 
Old 06-24-2014, 10:02 AM   #7
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by vockleya View Post
Might there something weird about multi-monitor setups and the desktop background stuff?
Aaron is it?:
It certainly appears that this may be the issue.

I have never tried on a 3 monitor setup, I have a dual display on a DVI-0 and DVI-1 outputs.

Tell us more about this 3 monitor setup if you can.
 
Old 06-24-2014, 12:53 PM   #8
vockleya
Member
 
Registered: Aug 2009
Posts: 87

Original Poster
Rep: Reputation: 16
Starting from the leftmost monitor, here is my setup:

plug on graphics card, resolution/refresh rate, identifier in nvidia-settings
1: DVI-D 0, 1920x1080 @ 60Hz, DFP-3
2: HDMI 1, 1920x1080 @ 60Hz, DFP-2
3: DVI-I 1, 1680x1050 @ 60Hz, DFP-0

3 is the default display as selected by the graphics card. It is the one that the BIOS and GRUB appear on.
I believe that 1 is the default display according to X, although I'm not sure how to tell. I just seem to remember setting it as that when I first set up my system.
Displays 2 and 3 are positioned as absolute shifts to the right of display 1, +1920+0, and +3840+0 respectively.

An interesting note, the nvidia-settings control panel correctly detects which display is which, but if I click "Identify Displays" in the Xfce display control panel, the names show up on the wrong displays, but the resolution is correct on every display.

Here is my xorg.conf, as generated by nvidia-settings. Although it seems to only have information about the whole X screen, not the individual physical displays.
Quote:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 331.20 (buildd@roseapple) Mon Feb 3 15:07:22 UTC 2014


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"

# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "JRY DIGITAL"
HorizSync 31.5 - 80.0
VertRefresh 59.9 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GTX 750 Ti"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "Stereo" "0"
Option "metamodes" "DVI-I-1: nvidia-auto-select +3840+15, HDMI-1: nvidia-auto-select +1920+0, DVI-D-0: nvidia-auto-select +0+0"
Option "SLI" "Off"
Option "MultiGPU" "Off"
Option "BaseMosaic" "off"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Last edited by vockleya; 06-24-2014 at 01:02 PM.
 
Old 06-24-2014, 01:06 PM   #9
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,585

Rep: Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351
I'm watching with interest as I never got my conky to appear on startup on my dual monitor NVIDIA setup. When I start it I start it on the monitor I want it to run on (monitor 0) using run. Mine also hides desktop icons but is in front of the picture -- I don't use desktop icons anyhow so that doesn't bother me too much. Anyhow, I seem to be using default values for a few things, the relevant bits of my .conkyrc being
Code:
alignment top_left
background no
own_window_argb_visual yes
own_window_argb_value 100
#own_window yes
#own_window_class conky
#own_window_type override
own_window_transparent yes
 
Old 06-24-2014, 01:48 PM   #10
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by vockleya View Post
if I click "Identify Displays" in the Xfce display control panel, the names show up on the wrong displays, but the resolution is correct on every display.
You're luckier than I on that feature. Mine has never worked. It doesn't error, but it doesn't identify them either.

I'm using the TwinView feature on Nvidia Driver 319.22

as far as placement goes, middle-middle or mm on conkry puts is right smack in the middle of both displays. where the right side of Monitor0 meets the left side of Monitor1 as shown in the attachment.

Here's my .nvidia-settings-rc for shits and giggles
Code:
# Configuration file for nvidia-settings - the NVIDIA X Server Settings utility
# Generated on Tue Jun 24 14:42:01 2014
#

# ConfigProperties:

RcFileLocale = C
ToolTips = Yes
DisplayStatusBar = Yes
SliderTextEntries = Yes
IncludeDisplayNameInConfigFile = No
ShowQuitDialog = No
UpdateRulesOnProfileNameChange = Yes
Timer = Memory_Used_(GPU_0),Yes,3000
Timer = Thermal_Monitor_(GPU_0),Yes,1000
Timer = PowerMizer_Monitor_(GPU_0),Yes,1000

# Attributes:

0/SyncToVBlank=1
0/LogAniso=0
0/FSAA=0
0/TextureSharpen=0
0/TextureClamping=1
0/FXAA=0
0/AllowFlipping=1
0/FSAAAppControlled=0
0/LogAnisoAppControlled=1
0/OpenGLImageSettings=1
0/FSAAAppEnhanced=1
0/DigitalVibrance[DFP-0]=0
0/DigitalVibrance[DFP-3]=0
0/ColorSpace[DFP-0]=0
0/ColorSpace[DFP-3]=0
0/ColorRange[DFP-0]=0
0/ColorRange[DFP-3]=0
0/XVideoSyncToDisplay=65536
my-kungfu:0[dpy:1]/RedBrightness=0.000000
my-kungfu:0[dpy:1]/GreenBrightness=0.000000
my-kungfu:0[dpy:1]/BlueBrightness=0.000000
my-kungfu:0[dpy:1]/RedContrast=0.000000
my-kungfu:0[dpy:1]/GreenContrast=0.000000
my-kungfu:0[dpy:1]/BlueContrast=0.000000
my-kungfu:0[dpy:1]/RedGamma=1.000000
my-kungfu:0[dpy:1]/GreenGamma=1.000000
my-kungfu:0[dpy:1]/BlueGamma=1.000000
my-kungfu:0[dpy:4]/RedBrightness=0.000000
my-kungfu:0[dpy:4]/GreenBrightness=0.000000
my-kungfu:0[dpy:4]/BlueBrightness=0.000000
my-kungfu:0[dpy:4]/RedContrast=0.000000
my-kungfu:0[dpy:4]/GreenContrast=0.000000
my-kungfu:0[dpy:4]/BlueContrast=0.000000
my-kungfu:0[dpy:4]/RedGamma=1.000000
my-kungfu:0[dpy:4]/GreenGamma=1.000000
my-kungfu:0[dpy:4]/BlueGamma=1.000000

Last edited by Habitual; 06-26-2015 at 05:47 PM.
 
Old 06-24-2014, 02:36 PM   #11
vockleya
Member
 
Registered: Aug 2009
Posts: 87

Original Poster
Rep: Reputation: 16
After a bit more testing, I can pretty much conclusively say that something in the combination of conky, Xfce 4, and Nvidia 334.21 doesn't quite work for multi-monitor setups. If I disable all but 1 monitor, everything works perfectly. My best guess is that something about the way that Xfce loads desktop images is causing a conflict. I guess this should have been obvious since the login screen backgrounds are completely wrong. It shows the main screen's wallpaper on the second and 3rd screens, and stretched to fill each. It only loads the correct wallpapers for screens 2 and 3 after login has completed. I guess I'll just have to stick to loading conky manually until multi-monitor support is fixed. Thanks for all the help anyway.
 
Old 06-24-2014, 03:08 PM   #12
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Quote:
Originally Posted by vockleya View Post
I have tried adding a sleep command to the startup script to force Conky to run later,
have you tried a startup script using
Code:
conky -p <seconds> -c /path/to/conkyrc
to pause for a duration of <seconds> instead of sleep?

Maybe the desktop just needs more time to do it's thing (before conky starts)?
 
4 members found this post helpful.
Old 06-24-2014, 08:30 PM   #13
vockleya
Member
 
Registered: Aug 2009
Posts: 87

Original Poster
Rep: Reputation: 16
It works!!!

I thought that would have done the same thing as sleep, but I guess it does something slightly different. Shows me for not at least trying it.

Thanks!
 
Old 06-25-2014, 05:42 AM   #14
Habitual
LQ Veteran
 
Registered: Jan 2011
Location: Abingdon, VA
Distribution: Catalina
Posts: 9,374
Blog Entries: 37

Rep: Reputation: Disabled
Well, that's Great News!

What's left then, anything?
 
Old 06-25-2014, 12:41 PM   #15
273
LQ Addict
 
Registered: Dec 2011
Location: UK
Distribution: Debian Sid AMD64, Raspbian Wheezy, various VMs
Posts: 7,585

Rep: Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351Reputation: 2351
Many thanks, Habitual, I had given up on conky myself after messing with sleep scripts nad the like but never realised it had its own sleep parameter -- now I have a conky autostarting too!
 
  


Reply

Tags
conky, xubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Conky not loading on startup debian 7 gnome Tadaen Linux - Software 5 07-09-2013 06:16 PM
[SOLVED] Start conky and add module at system startup. How can I do this? MarcosPauloBR Slackware 2 07-25-2011 01:01 PM
How to set conky to load at startup? gunzzz5930 Slackware 11 11-10-2010 11:13 PM
[SOLVED] Conky on Startup CincinnatiKid Slackware 3 07-25-2010 12:30 PM
conky display isssue on Gnome desktop when initiated at startup sd|| Linux - Software 3 11-06-2009 05:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration