-   Linux - Software (
-   -   Conky + lua (

flyinggeorge 03-03-2012 10:10 PM

Conky + lua
Hello, all. I was recently trying to spice up my fluxbox a bit. I downloaded some themes and came across this web page about using widgets with conky.

So I downloaded the .conkyrc file and replaced my old one, the .conkyrc works fine, but the widgets do not load. Conky returns:


Conky: llua_do_call: function conky_widgets execution failed: attempt to call a nil value
So I tried to google the error but I didn't get a clear solution. Some posts led me to believe that I might not have lua enabled in conky. But conky -v returns:


bash-4.1$ conky -v
Conky 1.8.1 compiled Wed Nov  9 12:34:01 EST 2011 for Linux (i686)

Compiled in features:

System config file: /usr/local/etc/conky/conky.conf
Package library path: /usr/local/lib/conky

  * Xdamage extension
  * XDBE (double buffer extension)
  * Xft
  * ARGB visual

 Music detection:
  * MPD
  * MOC

  * math
  * hddtemp
  * portmon
  * config-output
  * apcupsd
  * iostats
  * ncurses
  * Lua

  Lua bindings:

I assume that having "Lua" listed under general means that the bindings are enabled, but the Lua bindings section is blank. I currently have all the *.lua files copied into my home directory as well as /usr/local/lib/conky

Is there something I am missing? Thanks in advance for any help.

flyinggeorge 03-04-2012 12:01 AM

I tried to re-build conky with the variable LUA=yes enabled. I installed scons and tolua++ but when trying to build conky (From slackbuilds) it returns with errors


/usr/lib/ could not read symbols: File in wrong format
collect2: ld returned 1 exit status
make[2]: *** [conky] Error 1
make[2]: Leaving directory `/tmp/SBo/conky-1.8.1/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/tmp/SBo/conky-1.8.1/src'
make: *** [all-recursive] Error 1

Any ideas?

*edit* I downloaded and installed libcurl and conky built, but I am still getting the same error and no widgets.

Daedra 03-04-2012 02:00 PM

Did you install all the required packages from Install these packages in this order

tolua ++

Also curl is installed already in the default slackware installation. did you do a full install when you installed slackware? Also you dont copy the lua files into you home directory use the lua slackbuild from

flyinggeorge 03-04-2012 06:28 PM

Not sure if I have imlib2. I will build it and let you know. Thanks for you help.

flyinggeorge 03-04-2012 07:17 PM

Okay. So I built all of the packages you mentioned above in that order. And I am still getting the same error. When I said I was putting the *.lua files in my home directory, I meant only the "conky_widgets.lua" script. Which contains the script for the clock and rings. Unfortunately even after all of this I am still getting the same error.

Daedra 03-05-2012 02:08 PM

Your still getting the curl error when you try to compile conky?

flyinggeorge 03-05-2012 08:47 PM

No, I managed to build conky.

All times are GMT -5. The time now is 11:24 AM.