Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 07-24-2004, 12:35 PM   #1
LQ Newbie
Registered: Jul 2004
Posts: 2

Rep: Reputation: 0
Configuring PHP5 in Redhat 9


I have configured and compiled httpd-2.0.50 and mysql-4.0.20 , but I am having hard time to configure php-5.0.0 with Red Hat Linux 9 (and hours of google search are in vain)

Here is the conigure script and the error I am getting

[root@aisha php-5.0.0]# ./configure –prefix=/usr/local/php5 –with-apxs=/usr/local/apache2/bin/apxs –with-mysql=/usr/local/mysql

*configure: warning:* –prefix=/usr/local/php5: invalid host type
*configure: warning: *–with-apxs=/usr/local/apache2/bin/apxs: invalid host type
*configure: error:* can only configure for one host and one target at a time

but running config.guess returns a host type
[root@aisha php-5.0.0]# bash ./config.guess

Hint: If I run the conifig script with either mysql or apache support but not both i don't get the above error. but down to Configuring extensions i do get the follwoing error (libxml2 is there )

checking whether to enable LIBXML support... yes
checking libxml2 install dir... no
configure: error: libxml2 version 2.5.10 or greater required.

but libxml2 version 2.5.10 is installed as you can see from rpm query.

[root@aisha php-5.0.0]# rpm -qa | grep -i libxml2
[root@aisha php-5.0.0]#

I would be very much appreciate if anyone could help me with this.



configure: error:* configure: error:* configure: error:
Old 07-24-2004, 12:42 PM   #2
LQ Newbie
Registered: Jul 2004
Location: Richardson, TX
Distribution: Gentoo Linux
Posts: 14

Rep: Reputation: 0
Doesn't the configure script require double-hyphenated parameters, such as --with-apxs instead of -with-apxs?
Old 07-24-2004, 08:32 PM   #3
LQ Newbie
Registered: Jul 2004
Posts: 2

Original Poster
Rep: Reputation: 0
You are right , but strangly enough when i use "double-hyphenated parameters" with the --prefix option i get the following error(without the prefix option, double-hyphenated parameters work )

[root@aisha php-5.0.0]# ./configure -–prefix=/usr/local/php5 -–with-apxs=/usr/local/apache2/bin/apxs –-with-mysql=/usr/local/mysql
configure: error: -–prefix=/usr/local/php5: invalid option; use --help to show usage

Old 07-24-2004, 09:29 PM   #4
LQ Newbie
Registered: Jul 2004
Location: Richardson, TX
Distribution: Gentoo Linux
Posts: 14

Rep: Reputation: 0
If you remove the --prefix parameter, do you get the same error about other directives?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Configuring Nis In Redhat 9.0 sudeendra Linux - Networking 1 08-12-2005 03:18 AM
configuring the internet on redhat 9 crimsonflame123 Linux - Networking 3 07-30-2005 11:37 PM
Problems configuring apache for php5 Besnell Mandriva 3 12-28-2004 09:01 AM
Configuring Router on redhat 9 purikk Linux - Networking 2 10-11-2004 05:42 PM
Configuring sound in Redhat 8.0 jambeck Linux - Hardware 14 11-05-2002 02:00 PM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:04 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration