-   Linux - Software (
-   -   configure script not detecting my Gtk+ libraries (

phenyloxime 05-07-2011 08:34 PM

configure script not detecting my Gtk+ libraries
I'm trying to build and install snd (downloaded from planetCCRMA)from source.
It requires Gtk+ so I installed the appropriate libraries (I think ?) using apt-get.

Then I ran ldcofnig.

When I run the configure script I get the following error message:

checking for GTK+ - version >= 2.12.0... no
configure: WARNING: trouble with gtk (we need version 2.12.0 or later) -- will try to make Snd without any GUI

But I am pretty sure that I have the appropriate libraries installed:

adam@debian:/usr/local/src/snd-12$ dpkg -l libgtk[0-9]* | grep ^i
ii  libgtk1.2                                1.2.10-18.1                        The GIMP Toolkit set of widgets for X
ii  libgtk1.2-common                          1.2.10-18.1                        Common files for the GTK+ library
ii  libgtk2-perl                              1:1.190-1                          Perl interface to the 2.x series of the Gimp
ii  libgtk2.0-0                              2.12.12-1~lenny2                  The GTK+ graphical user interface library
ii  libgtk2.0-bin                            2.12.12-1~lenny2                  The programs for the GTK+ graphical user int
ii  libgtk2.0-common                          2.12.12-1~lenny2                  Common files for the GTK+ graphical user int

I tried to look inside the configure script itself, to see if I could figure out where it was looking for Gtk. Unfortunately, I know very little about shell scripts, so I was utterly lost. I'll appreciate any suggestions.


corp769 05-07-2011 08:50 PM


You may need to install gtk2-devel onto your system. I use fedora, so I don't know what it is called exactly for your package manager. Try using wildcards and such:

apt-get install libgtk2* gtk2-devel
It should be somewhere along those lines, but I am pretty sure it is the devel files that you need. If no go, let me know.



phenyloxime 05-07-2011 09:00 PM

Thanks for the reply, looks like that was what I needed to do:


apt-get install libgtk2.0-dev
did the trick. However; when I installed this library it also install 29 MB of other, seemingly unrelated libraries and I don't know why. se la vie . . .


Note I am watching snd compile, and I can see as it goes, that it is linking against all of the other stuff that I thought was unrelated.

phenyloxime 05-07-2011 09:14 PM

So the configure worked, but the build fails about halfway-ish through.

snd-draw.o: In function `g_make_cairo':
/usr/local/src/snd-12/snd-draw.c:1198: undefined reference to `gtk_widget_get_window'
collect2: ld returned 1 exit status
make: *** [snd] Error 1

Could this be a problem with my instalation of Gtk? or is it more likely a bug in the code that I downloaded.
I'm gonna start by trying to build an earlier version. . . .

. . . . . Didn't work; fails with the same error, trying to find another Gtk application to test. . . . .

All times are GMT -5. The time now is 02:57 AM.