LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-17-2003, 10:18 PM   #1
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Rep: Reputation: 46
./configure not finding QT...


Hey all, in trying to install the IceWM Control panel or menu editor, ./configure cannot find the QT libraries...

I'm sure I have them as I have several programs which use them...

Code:
checking for X... libraries /usr/X11R6/lib, headers
 /usr/X11R6/include checking for IceConnectionNumber in -lICE...
 yes checking for libXext... yes checking for Xinerama... no
 checking for libpng... -lpng -lz -lm checking for libjpeg6b... no
 checking for libjpeg... -ljpeg checking for Qt... configure: error: Qt
 (>= Qt 2.2.2) (headers and libraries) not found. Please check
 your installation! For more details about this problem, look at the
 end of config.log.

So how do I fix this and allow it to configure?

-Shade

Last edited by Shade; 06-17-2003 at 10:19 PM.
 
Old 06-18-2003, 10:02 PM   #2
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Original Poster
Rep: Reputation: 46
Bump... And to add, config.log doesn't seem to show any help, i used

tail config.log

to see what was going on, but it really didn't help me... Kind of gibberish to me.

What can I do to point configure towards the QT libs?

-Shade
 
Old 06-18-2003, 10:13 PM   #3
contrasutra
LQ Guru
 
Registered: Mar 2003
Location: New Jersey
Distribution: Arch Linux
Posts: 1,445

Rep: Reputation: 46
install the qt-devel package.
 
Old 06-18-2003, 10:19 PM   #4
Shade
Senior Member
 
Registered: Mar 2003
Location: Burke, VA
Distribution: RHEL, Slackware, Ubuntu, Fedora
Posts: 1,418
Blog Entries: 1

Original Poster
Rep: Reputation: 46
Thanks, I will try that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
./configure not finding KDE libraries MadCowDzz SUSE / openSUSE 3 11-21-2005 06:49 AM
Issues finding ld from configure RazorKnight Linux - Software 1 04-13-2005 04:47 AM
Configure dhcpd (Configure DHCP Server) hanserver2004 General 1 08-16-2004 01:39 PM
configure: error: when trying to install / configure new software ? met tomfer007 Linux - Software 1 07-25-2004 03:52 PM
./configure not finding header files mikeyt_333 Linux - Software 5 06-30-2004 06:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration