LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-23-2003, 11:40 AM   #1
Jefklak
LQ Newbie
 
Registered: Oct 2003
Distribution: Currently Fedora B3, Will try Gentoo 1.4
Posts: 26

Rep: Reputation: 15
./configure -- never glib-2 found!! Help plz


Hello again,

As I would like to compile some sources (this time, XFCE4), running ./configure first is needed. Then, the config thing checks for everything if it is correctly installed. I get this error:

Quote:
checking for glib-2.0 >= 2.0.0 gtk+-2.0 >= 2.0.0... Package glib-2.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `glib-2.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'glib-2.0' found
What the hell, glib is installed correctly!! (Im running Fedora beta 3, with latest updates and stuff) Well anyway, I installed the newest glib I found on the internet with TAR and RPM. When searching for it (using "locate glib") or (using rpm -qa | grep glib) I can see my glib and it IS installed.
MOD: in my dir /usr/local/lib/pkgconfig is a file glib-2.0.pc wich is a part of the glib I installed. There's also a glib-2.0 dir inside /usr/local/lib (only 1 file in the subdir include) and there's a lot of sh*t inside /usr/local/include/glib-2.0 so what the heck it is definitly installed.

But this is not XFCE, when I try to install something else wich depends on glib it gives that error too... (Most oblivious, but heck)


Could someone help me?
Did I configure something wrong or so?
What's up with that PKG_CONFIG_PATH?
Thanks a lot guys!!

Last edited by Jefklak; 10-23-2003 at 11:46 AM.
 
Old 10-23-2003, 10:16 PM   #2
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 47
You might want to try installing glib-devel
Do a search for glib on
http://rpm.pbone.net
go to advanced search and only Red Hat 9 should be checked
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
new glib not found logosys Linux - Software 3 09-27-2005 04:39 PM
glib not found...???? HELP! PLEASE! TheCowboy Linux - Software 1 03-01-2005 01:09 AM
glib error on ./configure speel Mandriva 2 08-28-2004 04:28 PM
Can't even configure glib-2.3.2 now! davemar Linux From Scratch 7 04-20-2004 05:32 AM
glib-2.0 never is found FirebirdV0273 Linux - Software 3 07-28-2003 12:12 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration