LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-14-2014, 07:32 AM   #1
sriram_ec
LQ Newbie
 
Registered: Mar 2006
Posts: 11

Rep: Reputation: 0
Question Configure for gtk-2.20 for arm architecture is failing


Hi,

I am trying to cross compile gtk+2.0-2.20.1 for arm, for that purpose i did ./configure as follows,

" ./configure --host=arm-none-linux-gnueabi --build=x86_64-pc-linux-gnu --target=arm-none-linux-gnueabi --prefix=/root/linux/local/ --cache-file=config.cache --without-libtiff --without-libpng --without-libjpeg "

But the above command fails with the error as,

checking Pango flags... -pthread -I/root/linux/local/include/pango-1.0 -I/root/linux/local/include/glib-2.0 -I/root/linux/local/lib/glib-2.0/include -I/root/linux/local/include/cairo -I/root/linux/local/include/pixman-1 -I/root/linux/local/include/freetype2 -I/root/linux/local/include -I/root/linux/local/include/libpng12 -pthread -L/root/linux/local/lib -lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lrt -lglib-2.0
configure: error:
*** Can't link to Pango. Pango is required to build
*** GTK+. For more information see http://www.pango.org


but config.log reads as below,

/home/nscuser/CodeSourcery/Sourcery_G++_Lite/bin/../lib/gcc/arm-none-linux-gnueabi/4.5.2/../../../../arm-none-linux-gnueabi/bin/ld: warning: libpixman-1.so.0, needed by /root/linux/local/lib/libpangocairo-1.0.so, not found (try using -rpath or -rpath-link)
/home/nscuser/CodeSourcery/Sourcery_G++_Lite/bin/../lib/gcc/arm-none-linux-gnueabi/4.5.2/../../../../arm-none-linux-gnueabi/bin/ld: warning: libpng12.so.0, needed by /root/linux/local/lib/libpangocairo-1.0.so, not found (try using -rpath or -rpath-link)

and soon for few more libraries and finally fails with
*** Can't link to Pango. Pango is required to build
*** GTK+. For more information see http://www.pango.org

Any help in this regard is appreciated.

Regards,
Sriram.
 
Old 03-15-2014, 03:23 PM   #2
gengisdave
Member
 
Registered: Dec 2013
Location: Turin, Italy
Distribution: slackware
Posts: 327

Rep: Reputation: 73
you have pango, but you haven't libpixman and libpng required by pango, configure can't find them and suggests passing -rpath with the dir containing the libraries
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
where to find stable iptables for arm architecture. pradiptart Linux - Software 1 06-04-2013 11:35 AM
Hrtimer Source on ARM architecture using SMP gaurav87 Linux - Embedded & Single-board computer 0 11-09-2012 03:19 AM
LXer: Introducing the ARM 64-bit Architecture LXer Syndicated Linux News 0 07-09-2012 11:50 PM
The size of struct thread_info in the ARM architecture? corone Linux - Kernel 3 10-21-2011 09:04 AM
ARM a8 architecture corbis_demon Programming 0 10-16-2005 08:31 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:01 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration