-   Linux - Software (
-   -   configure (

hammam12 06-19-2006 09:35 AM

Hi all,
when I am using ./configure in run mode I got this error at end

checking for KDE... configure: error:
in the prefix, you've chosen, are no KDE headers installed. This will fail.
So, check this please and use another prefix!

Could someone pls tell me how to resolve it my distro is linux opensuse 10.1
... thanx
Mohammed Hammam

reddazz 06-19-2006 09:55 AM

Install kdelibs3-devel.

binary_y2k2 06-19-2006 09:58 AM

You'll want to install the kde-devel and maybe kde-devel-extras packages.

hammam12 06-19-2006 10:35 AM

Where are they. I looked in yast + software management Could you pls tell me the path. another thing disk usage are nearly full 96% inspite of tehre a lot of spaces in /windows/c /home /windows/d ....etc. how could I free the roor / or add spacs I have in my machine.

hammam12 06-26-2006 07:37 PM

... thanx
Mohammed Hammam

neoexodus 07-26-2006 08:04 AM

Hey, How did you resolve this issue? I am pretty new to Linux and am having the same issue when trying to configure a screensaver in Gentoo 2.6.12. I have been playing with this issue for the past 2 days and have seen a lot of posts that say I need dev or devel packages, but I cannot find any that fit the names given, even when I use "emerge --search kde" which returns all packages with kde in their name. I re-emerged kde-base/kdelibs, but that still does not seem to fix the problem... anybody have some helpful hints for me to try?

ADD: I just went back through emerge and the closest ebuild I see would be "dev-util/kdevelop" but I don't think that's it... Help!

neoexodus 07-26-2006 09:21 AM

NM all, I figured out what it was that I was doing wrong. I had seen that I needed to tell configure exactly where my headers are (for me: /usr/kde/3.5/include/kapplication.h ) and so it was not working as it seems that it wanted a more general directory. I tried /usr/kde/3.5/include, which failed, but /usr/kde/3.5 worked... finally.

hammam12 07-27-2006 10:10 AM

you can download dev or devel packages from
YaST + software management
I am linux opensuse 10.1

All times are GMT -5. The time now is 05:08 AM.