-   Linux - Software (
-   -   Configuration error (

Ice Dragon 12-24-2004 04:59 PM

Configuration error
Hey all, I'm having a bit of difficulty whilst trying to configure and compile gtkmm. When I run configure, it tells me that a dependency hasn't been met, libgtkhtml-2.0.pc can't be found with pkg-config. So I compile and install the latest libgtkhtml and I still get this message. I can find the file in the directory that libgtkhtml is in, but pkg-config can't find it in its search path. This is a general problem I've had with other files in the past and I hope that there is someone here that can help me out a bit.

Mega Man X 12-24-2004 05:09 PM

Hi Ice Dragon!

Usually, when a dependency is met, the package required ends with -devel. For example, if you are asked about XFree package when installing something, most likely, xfree86xxx-devel is the package you need to install.

However, you will not have much luck compiling things in Redhat/Fedora. It's just best to use rpm's for those distributions.

A wise way to install things in Redhat/Fedora is by either yum or apt-get. I've never used yum, but apt-get was great. Let's say you wish to install mplayer.... All you gonna do is to type, on the terminal, as root:

apt-get update
apt-get install mplayer

That's it!. Apt will connect to a server, download all packages and dependencies and install it for you. That simple :).

Here is a FAQ for Fedora that might help you:

Good luck!

Ice Dragon 12-24-2004 05:12 PM

I'd use apt or yum, however I can't connect to the internet from Linux (wireless network driver issues). I've had luck installing other things by compiling, but this just seems to be a stubborn program.

All times are GMT -5. The time now is 01:59 PM.