-   Linux - Software (
-   -   Config Error: Error accessing config file: /etc/yum.conf (

dr_zayus69 01-16-2006 03:53 AM

Config Error: Error accessing config file: /etc/yum.conf
hi. Im trying to add some repositories yum and now i get this error when trying to use yum.

Config Error: Error accessing config file: /etc/yum.conf

at first i added the required lines at the bottom of yum.conf and got that error. So i tried putting them in their own repository files but i still get the same error.

these are the file permissions:

-rw-r--r-- 1 root root 255 Jan 16 04:33 yum.conf

here is the file.



# PUT YOUR REPOS HERE OR IN separate files named file.repo
# in /etc/yum.repos.d

when i put the repo info in i put it after the two comments on the bottom. i used gedit to edit yum.conf so i did ps -e | grep gedit to see if maybe i still had it opened. That is all i could think of that it couldn't get accessed was wrong file permissions or it was already open. Can anyone help me figure this out? I can post the repo info i tried adding if necessary. Thanks for any replies in advance.

b0uncer 01-17-2006 12:55 PM

hmm..sounds odd indeed. maybe you should try to give the file -rwxrwxrwx permissions for a while, try out, and if it won't help then reverse them back to normal. if it then works, you know you need some extra permission for it (possibly x?). then, you could try removing the lines you added and try if it works - probably not, though. then you could use the command <umm can't remember it's name> that lists open files (I'm sure there is such a command..I've tried it even) and see if yours is one of them. that's all I can think of, google, google.

I hope you get the problem solved.

dr_zayus69 01-17-2006 05:20 PM

thanks. yeah i should mention that i did try chmod +x to it and tried it with no luck but i'll try giving it full permissions to see if that will do anything. i tried lsof | grep yum.conf (lsof is the program to list open files) But i'll try it again grepping the full path. thanks for the reply.

All times are GMT -5. The time now is 12:47 AM.