-   Linux - Software (
-   -   Complete shutdowns while compiling (

Russb 12-08-2007 10:39 AM

Complete shutdowns while compiling
Hello guys!

I am having a difficult problem as of late and cannot seem to pinpoint exactly what is going on. First I will provide the basics:

I have an HP L2000SE, the Live Strong one, that sports the AMD Turion™ 64 Processor ML-34 with PowerNow! and one gig of RAM. I have installed the most current stable Gentoo release and have the 2.6.23-r3 kernel that I have compiled myself. My make.conf looks like this:


# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /etc/make.conf.example for a more detailed example.
CFLAGS="-march=k8 -O2 -pipe -fomit-frame-pointer"
CXXFLAGS="${CFLAGS} -fvisibility-inlines-hidden"
# This should not be changed unless you know exactly what you are doing.  You
# should probably be using a different stage, instead.
USE="gtk gnome -qt4 -qt3 -kde -arts -oss -esd 3dnow 3dnowext acpi mmx mmxext multilib nptl nptlonly sse sse2 X dbus gtk gnome hal avahi dvd alsa cdr truetype"
FEATURES="parallel-fetch ccache"
EMERGE_DEFAULT_OPTS="--with-bdeps y"

I have been trying to compile various pieces of software (mainly OpenOffice, Firefox, and Thunderbird) and during the compile process there comes a specific point each time that the computer shutsdown unexpectedly (now expectedly). I am not trying to use the -bin files but rather compile the sources. I know some people say to just use the -bins but if something is wrong with my Linux I want to fix it, not work around it. I spent the past day on Google, in here, and on the Gentoo forums but I couldn't find anything. I take that back, I did find one thread suggesting to recompile GCC, and that worked for the other guy. I tried that and sure enough my computer killed itself.

I can't attached an error message because there are none! It hangs for a second and then just turns off! I checked the battery, RAM, fan, processor, opened the case and looked at the power jack, replaced RAM with other RAM I have stored up... Everything is fine. I am thinking that this must be software issue, regardless of distro, and not hardware since I double checked EVERYTHING.

Any thoughts are appreciated, and I will post any additional info someone might need. Thanks!

matthewg42 12-08-2007 10:47 AM

Maybe the CPU cooling is not working well. Compiling is very CPU intensive, and if your cooling is not working efficiently, you will hit halt temperature sooner or later. If the conditions are very much the same each time, it might even at about the same time each time you compile a certain thing.

Make sure the fans are working, and that the heatsync is clear from dust and so on. Note that some machine require that the machine case is on for the CPU to be cooled properly (as the base acts like a duct to guile cold air to the heatsync).

paulsm4 12-08-2007 10:55 AM

Identify your mobo and use an on-line memory advisor tool
I once had a similar problem, and it ultimately turned out to be RAM.
Many motherboards are *extremely* picky. Please do this:

1. Identify your exact motherboard ("mobo") vendor and model#

2. Look up *exact* matches on the web.
Accept no substitutes - don't buy and install a RAM chip unless it's *explicitly* approved for your motherboard.

Here are a couple of links:

Good luck!

PTrenholme 12-08-2007 11:02 AM

Another possibility - also cooling - is an overheated hard drive. My box was shutting down (after "clicking" sounds from the drive repeatedly seeking) before I removed the enclosure from the computer to improve air flow.

Note that the box I'm using has an intake and two exhaust fans, and each of the hard drives has an attached pair of cooling fans. But the drives were still overheating!

Russb 12-08-2007 11:11 AM

Wow! That was fast replying there! And if this was a Microsoft problem I'd still be paying to wait on the line! ;)

I was thinking about using the same RAM as the laptop was stocked with. I actually had some still packaged and tried them. Still no dice... Thanks for the suggestion though! Unfortunately laptops don't have the flexibility as their desktop cousins, so it made sense.

As far as the heating, I didn't think about that! It does run hot, and with the hard drive right under where you'd rest your left hand you can feel it starting to get worse. It may be the CPU too, since that also heats up pretty quick. Now to figure out how to rig this bad boy up with the case open, compiling, and seeing if it works. I'll try anything right now...

DeusExLinux 12-08-2007 11:20 AM

I had an issue with that, many moons ago, when I ran Gentoo. I moved my lappy to an area that didn't have good air flow, and she was compiling X (a long process, we all know) and it died on me. If it's doing it around the same time, it's gotta be a heat issue.

PTrenholme 12-08-2007 03:06 PM

Sorry, I didn't realize it was a laptop you were using.

I've seen a few "Laptop Cooling Pads" offered in the $20-$30 range. One of those might help.

Russb 12-09-2007 12:07 AM

Thanks for the help everyone! I emerged a CPU temp monitor and when my system is idle it is at 51C/133F! I will be conducting some tests compiling small then large packages to see what exactly is going on. I believe though that the heat is my suspect. Thanks again!

Russb 12-09-2007 05:12 AM

Yes! That was it! I put my laptop outside where it was 4C and was able to completely compile OpenOffice. The CPU temp started to reach 90C so I put it out there and the temps went down to about 72C and never shut off. Thanks guys for the support!

Now to figure our why all the text in the program is wingdings... :(

General Failure 12-09-2007 05:45 AM


Originally Posted by Russb (Post 2984772)
The CPU temp started to reach 90C so I put it out there and the temps went down to about 72C

Uh! I'd say you should really have a talk with the person that sold you this machine.

matthewg42 12-09-2007 06:29 AM

One of the nice things about my Dell Inspiron laptop is that the CPU fan unit is easy to detach and clean.

Undoing two screws the fan unit comes away and I can get in there with a brush or something, or just vacuum out the crud. I have do this about once every 6 months - a year else I get the same problems you describe.

Russb 12-09-2007 07:42 AM

Yeah, the HP L2000SEs have a lot of issues with them. I cleaned it out at the start of the year and it seemed to work better. It had a crapload of dust in it, especially the fan. I think I'll go ahead and do that now.

DeusExLinux 12-09-2007 07:56 PM

I had an issue with some of the fonts in OpenOffice (the menus looked like the mind of a crazy person). I don't think I ever did figure out what happened with that; I believe it was a problem with the font OOo was looking for, but I'm not sure.

All times are GMT -5. The time now is 05:15 AM.