LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Compiz-fusion causes whilte blank screen on Fedora 9 (https://www.linuxquestions.org/questions/linux-software-2/compiz-fusion-causes-whilte-blank-screen-on-fedora-9-a-689697/)

centguy 12-10-2008 07:23 PM

Compiz-fusion causes whilte blank screen on Fedora 9
 
Hi. I followed the instructions at http://www.my-guides.net/en/content/view/103/26/
to install compiz-fusion on my updated Fedora 9 box.
Basically I did

yum install compiz-fusion compiz-fusion-gnome compiz-fusion-extras compiz-fusion-extras-gnome compiz-manager gnome-compiz-manager ccsm fusion-icon fusion-icon-gtk emerald emerald-themes

and finally enable compiz-fusion at login by
System -> Preferences -> Personal -> Sessions and click Add, and type
in Name: Fusion icon, Command : fusion-icon and Comment: Compiz Fusion panel
applet.

Upon logout and login again, I get a WHITE BLANK SCREEN.
I would really like to undo the step to auto-start compiz-fusion so that I can at
least login as usual without compiz-fusion.

Which files should I remove using root account ?

Thanks!

Some details that may be helpful:

[ckgan1@fc9 ~]$ rpm -qva | grep compiz
compiz-fusion-0.7.6-1.fc9.x86_64
compiz-fusion-extras-0.7.6-1.fc9.x86_64
compiz-fusion-extras-gnome-0.7.6-1.fc9.x86_64
compizconfig-python-0.7.6-1.fc9.x86_64
compiz-fusion-gnome-0.7.6-1.fc9.x86_64
libcompizconfig-0.7.6-1.fc9.x86_64
compiz-manager-0.6.0-7.fc9.noarch
gnome-compiz-manager-0.10.4-4.fc9.x86_64
compiz-0.7.6-3.fc9.1.x86_64

r1d3r 12-10-2008 09:31 PM

Do you use nVidia graphic card?

The official compiz fusion troubleshooting page says that must be your nvidia drivers fault (its not enabled).

http://wiki.opencompositing.org/Troubleshooting

centguy 12-10-2008 10:37 PM

I have an Intel Mobile GM 965 Chipset with GMA (i.e., no dedicated graphic card).

When I tried to run "compiz-manager",

the error message is

Checking for Xgl: not present.
Blacklisted PCIID '8086:2a02' found
aborting and using fallback: /usr/bin/metacity

Why is Xgl not installed when Xorg is working perfectly??
Time to figure out what Xgl is in relation to Xorg.

Back to my question:
I removed .gnome, but the screen is still blank when I login.
Looks like I have to remove all suspicious directories and see which is is responsible for starting compiz-fusion when I login..

The site you point to may solve the compiz-fusion problem.
Will try out the solution :
LIBGL_ALWAYS_INDIRECT=1 INTEL_BATCH=1 compiz --replace --indirect-rendering --sm-disable ccp &

Junior Hacker 12-11-2008 02:48 AM

I did a simple google search with these key words: How to remove compiz-fusion from Gnome autostart
It appears the first link has the answer.

peeths003 12-11-2008 03:14 AM

I also had the same problem when i was using the Intel Card .

Start compiz fusion using the below command

Quote:

$ LIBGL_ALWAYS_INDIRECT=1 INTEL_BATCH=1 compiz --replace --sm-disable --ignore-desktop-hints ccp &
The reason being

It forces compiz to use indirect rendering, which is necessary for the GLX_EXT_texture_from_pixmap extension. Unfortunately, fedora 9 shipped with broken intel drivers that claim to support GLX_EXT_texture_from_pixmap via direct rendering, but that's not actually the case.

You could try using fusion-icon and adding that to your session. Just make sure that fusion-icon is setup to launch compiz with indirect rendering

Thanks to Adam for telling me these ... The post is here
http://forum.compiz-fusion.org/showt...?t=8561&page=5

Thanks
Peeths

centguy 12-11-2008 04:25 AM

Thanks. I avoided the blank screen problem.

But I am hit with this problem:

[ckgan@fc9 ~]$ LIBGL_ALWAYS_INDIRECT=1 INTEL_BATCH=1 compiz --replace --sm-disable --ignore-desktop-hints ccp &
[2] 3856
[ckgan@fc9 ~]$ libccs: dlopen: /usr/lib64/compizconfig/backends/libgconf.so: cannot open shared object file: No such file or directory

Now, I can't move the windows..

peeths003 12-11-2008 04:47 AM

I think the windows decorator getting vanished ....


after the above command ( LIBGL_ALWAYS_INDIRECT=1 INTEL_BATCH=1 compiz --replace --sm-disable --ignore-desktop-hints ccp & ) try giving the below command
Quote:

gtk-window-decorator --replace
Now you should be all set ...

let me know .....

centguy 12-11-2008 05:07 AM

nope.. gtk-window-decorator command not found. Even it works the fan seems to be working rather hard to cool the system. Could be related to the "indirect" way of running opengl...

libgconf.so problem does not appear though. But I still can't move the windows.


I am thinking of using beryl (I know it is a downgrade), but I have luck with it on an old/weaker Intel Graphic chipset/driver that works rather fine on a CentOS5.2 desktop.

Does Fedora 9 still bother with beryl these days?

It is strange that Fedora 9 hasn't fixed the Intel GM965 driver completely. I tolerate it's "older" brother CentOS5.2 has done a poor job where a simple glxgears crashed the xorg.

Does Fedora 10 fixes the Intel driver (at least GM 965 Chipset) completely ? Something that keeps me wondering. If anyone has tried that please let me know.

Thanks for all the help.

peeths003 12-11-2008 05:37 AM

are you able to see the windows decorators ?

Which desktop you use .. KDE ,gnome xfce ?

is the windows decorator is enabled in ccsm ?

if these dosent work , i think you might need to install the windows decorators ... ( i am not sure of these ) but can try your luck ......


Thanks
Peeths

peeths003 12-11-2008 05:38 AM

also search for the gtk windows decorator in you machine , this command should be there in your machine

centguy 12-11-2008 05:45 AM

My one and only choice : gnome.

Okay. You might want to tell me the exact path for that, if it is install correctly. Thanks!

peeths003 12-11-2008 06:40 AM

i think you are missing some packages .... install the window decorator packages .

if it is installed it should be accessible from anywhere in the prompt

Junior Hacker 12-11-2008 07:08 AM

Quote:

Originally Posted by peeths003 (Post 3371543)
i think

This is indicative of the caliber of advice given.

peeths003 12-11-2008 07:19 AM

Quote:

Originally Posted by Junior Hacker (Post 3371559)
This is indicative of the caliber of advice given.

I know , but i dont want him to do only what i say .. he can also do some R&D on that ...

My appolagise

centguy 12-11-2008 08:40 AM

I think I can live without compiz stuff for now. I don't fancy ad-hoc fixes just to run compiz-fusion. May be Fedora 10 fixes that already.
Cheers!


All times are GMT -5. The time now is 01:35 AM.