LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-09-2008, 09:59 PM   #16
MexDeath
Member
 
Registered: Nov 2008
Location: Dallas
Distribution: Linux Mint, Mandriva, Gentoo.
Posts: 65

Rep: Reputation: 16
Wink


Quote:
Originally Posted by Pazau View Post
I have installed Emerald Theme Manager together with Compiz Icon. It works, but Emerald doesn't start when Ubuntu starts. How do I remedy this?
Ok, last night I gave a "not-so-precise" guide of what you can try to do to solve your Emerald problem. Now that I am logged on in Linux, I can tell you, properly, what to do!

I hope it helps...

I think I have a way you can fix that little problem, here is what you can do:

1. Go to the CompizConfig Settings Manager (CCSM), or wherever it is that you set up your configurations to tell Compiz what you want it to do. You know, the desktop cube and so on...
2. Once in there, look for the Window Decorations button, or icon, and click it. It should be under the "Effects" section of the
3. Once in there, look for the "Command" field, in there you will find something like this:
Code:
/usr/bin/compiz-decorator
4. Edit that text so that it looks like this:
Code:
/usr/bin/emerald --replace
5. Properly, get out of the CCSM. You wont see any "Apply" buttons or anything on it. Also, you will not see any immediate effects, at least not until you re-boot.
5. Reboot, and it should do it.
6. Once you have re-booted, try playing with your Emerald Window Decorations, now you will see immediate effects.

I think that should do it, if it does not, let us know.

Last edited by MexDeath; 12-10-2008 at 10:53 AM.
 
Old 12-10-2008, 05:19 PM   #17
Pazau
Member
 
Registered: Nov 2008
Location: Copenhagen, Denmark
Distribution: Ubuntu and Xubuntu 8.10
Posts: 98

Original Poster
Rep: Reputation: 15
I got i to work yesterday...

It was under System -> Preferences -> Appearance. There was no dot, so I chose the bottom option (the full effects), and restarted. So it works

Emerald was already set as the default windows manager.

But thanks for your post. Maybe i could use it if I get problems with Compiz.
 
Old 12-12-2008, 05:05 PM   #18
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 480Reputation: 480Reputation: 480Reputation: 480Reputation: 480
geforce 200
Been trouble shooting this for a week Ubuntu up grade has cause a problem for us 32 bit cpu people. with the nvidia cards. I run compiz-fusion on slackware distros. Ubuntu after many hours of trouble shooting the hardy kernel. seems that the xgl not present is a has nothing to do with your card drivers. the white list or compiz start up script. if you notice all the att cards are working now but not the nvidia. after ripping in to the scripts I find the broken link is there do to a upgrade of the new kernel and scripts that allow the 32 bit drivers to be loaded.
If you load the xgl server it will disable nvidia's xgl then nvidia not present. if you run it like your supposed with out the xgl server so it reads nvidia's xgl you can do all the preloading of the xgl for nvidia's 32 bit xgl's all you want but it will not able to load the 64 bit xgl.(it is looking for that)
xorg knows about this Ubuntu Knows about this. Ubuntu will be fixing the problem do not for get whom they are writing there scripts and drivers for. They keep up buy building a stable Linux for the new Dell computers. Please do not spend like I did two weeks working on this it is not worth the frustration. It has nothing to do with the the amount of video ram.

If you want to sit back re-write the scripts to load this be my guest that is the wonderful thing about Linux. You can build your own drivers it does not help you can use there non-free drivers it still will not help . we will have to wait for the UBUNTU gods to keep it simple but with putting out new system every six months good luck. I do not want us old cpu people to be discouraged by this keep the good old stuff running and some times it better to stick with what works.
Last but not least the scripts do link to your xgl but it is nable to load them. sorry.
 
Old 12-21-2008, 09:33 PM   #19
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 3,716
Blog Entries: 3

Rep: Reputation: 480Reputation: 480Reputation: 480Reputation: 480Reputation: 480
As you can see I have helped many people to get compiz-fusion going. I am wondering if any one with a nvida 32 bit has got GOS 3 google gadgets based on the hardy heron to work.
before you tell me how to configure down load it and all that. Don't I understand it well and I understand the broken links that plagued Ubuntu. I just need to know if some one has got it to work. please do not go into details on the xgl server and nvidia. using ubuntu ccsm scripts and compis fusion plugins and extra has got it to work with a nvidia 32 bit.
the problem is
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
this has been a broken link problem for a long time it was fixed. but not on GOS 3
i have done this with ubuntu,s drivers evy drivers and nvidias and there patches etc. even there bleeding edge betas.
I have got this to work on all the distros I use except GOS 3 this distro wbar is written in LXD I think. I had some small issues with wbar and compiz but nothing that stopped the system from using nvidia XGL even after updating the symlinks
# For Xgl LD_PRELOAD
LIBGL_NVIDIA="/usr/lib/nvidia/libGL.so.1.2.xlibmesa"
that was a bug that was a ghost link.
If you got it to work just post a copy of your sudo gedit /usr/bin/compiz and
a copy of your gedit /home/your_place/.config/compiz/compizconfig/config
and your sudo gedit /etc/X11/xorg.conf
this would be a great help.
 
  


Reply

Tags
gos, compiz fusion


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Skydome background doesn't work with compiz/gnome unless I use the compiz fusion icon The_Trooper Linux - Software 1 07-21-2008 02:08 PM
Compiz crashed and won't work anymore. Genestealer Linux - Newbie 3 02-16-2008 02:57 AM
What DMs can work with compiz-fusion? fjodork Linux - Desktop 3 12-19-2007 02:56 PM
xgl / compiz - How does it work? scuffell Linux - Desktop 0 08-29-2006 06:04 PM
CP command doesn't work properly? itz2000 Linux - Newbie 1 08-02-2005 02:14 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 10:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration