LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-10-2009, 08:49 PM   #1
atomn
LQ Newbie
 
Registered: Jan 2009
Posts: 15

Rep: Reputation: 0
Compiz and now my mouse is jacked


Hi, I'm very new to linux. I just installed ubuntu on an HP dv9000 notebook. Everything went great, I love it. But, I installed the compiz manager and was playing around with settings (the "scale" feature) and all of the sudden my mouse stopped working normally. My mouse will only grab windows, it wont do anything else within a window. It doesn't matter where I my mouse is within a window, the only thing I can do with it is drag the window. So, that means I cannot click on anything. I can't scroll down, make selections, highlight text, click OK. All my mouse will do in any windows is grab it. This is true for both my external USB mouse and my laptop mouse.

I restarted my notebook, then went into compiz using keyboard shortcuts and disabled most of the features, and it didn't make any difference. I have no idea what I did. I also tried using my mouse on different desktops, and my mouse still failed to work normally on all of them.

I've been trying to fix the problem for about an hour. Can someone help a linux noob who doesn't want to reinstall ubuntu (unless I have to).

Thanks

Last edited by atomn; 01-10-2009 at 08:56 PM.
 
Old 01-11-2009, 09:32 PM   #2
atomn
LQ Newbie
 
Registered: Jan 2009
Posts: 15

Original Poster
Rep: Reputation: 0
I already tried changing all of the compiz settings back to default. I read every other related mouse issue on this forum that I could find. Still haven't been able to fix my problem. This is my last request for help before I reinstall.
 
Old 01-12-2009, 10:39 PM   #3
atomn
LQ Newbie
 
Registered: Jan 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by atomn View Post
I already tried changing all of the compiz settings back to default. I read every other related mouse issue on this forum that I could find. Still haven't been able to fix my problem. This is my last request for help before I reinstall.
I had to delete my xwindows config file in order to fix this problem. I got help from a guy at work who's been running Linux for years. He knew exactly what to do even though he had never come across the problem before.

Last edited by atomn; 01-13-2009 at 12:29 AM.
 
Old 01-12-2009, 10:42 PM   #4
SqdnGuns
Senior Member
 
Registered: Aug 2005
Location: Pensacola, FL
Distribution: Slackware64 Current & Arch
Posts: 1,092

Rep: Reputation: 174Reputation: 174
Quote:
Originally Posted by atomn View Post
I had to delete my xwindows config file in order to fix this problem. I got help from a guy at work who's been running Linus for years. He knew exactly what to do even though he had never come across the problem before.
Thanks for posting your solution, most n00bs just do a "hit 'n run."

Good luck with your new OS.
 
Old 01-13-2009, 12:31 AM   #5
atomn
LQ Newbie
 
Registered: Jan 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by SqdnGuns View Post
Thanks for posting your solution, most n00bs just do a "hit 'n run."

Good luck with your new OS.
No problem. I don't do hit and runs. Thanks for noticing.
 
Old 01-13-2009, 09:20 PM   #6
atomn
LQ Newbie
 
Registered: Jan 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Correction:

Although I fixed the problem I have been unable to edit, or access the xconfig file ( I'm sure it has something to do with permissions. I guess I was supposed to use a sudo login or something), and my compiz isn't working. So I just reinstalled ubuntu.
 
Old 01-13-2009, 09:27 PM   #7
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682
Something like "sudo vim /etc/X11/xorg.conf" will work. You can use your favorite text editor, maybe nano. A graphical text editor such as "gnomesu <editorname> /etc/X11/xorg.conf" should work as well. ( Sorry, I don't use gnome and don't know a kate equivalent in gnome. ) Make sure you use a text editor, and not a word processing editor.
 
Old 01-13-2009, 09:31 PM   #8
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,618

Rep: Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651
for gnome it would be gedit ( if you have a working GUI ) or nano or vi / vim for the CLI
 
Old 01-14-2009, 12:30 AM   #9
atomn
LQ Newbie
 
Registered: Jan 2009
Posts: 15

Original Poster
Rep: Reputation: 0
I just changed the permissions on my fonts directory to 666 after not being able to import a font folder to the directory even though I was logged in as root. As soon as I did every bit of text on my system turned into a square. It's just funny at this point that Linux claims to be more stable than windows. I've been running window on my new PC for two months without a single error, yet I've had nothing be big problems with Linux after running it for literally 2 days. How stable is an OS (Ubuntu/debian) that has to lock up it's font directory otherwise the fonts go crazy and get corrupted immediately after changing the permissions.
 
Old 01-14-2009, 12:50 AM   #10
SqdnGuns
Senior Member
 
Registered: Aug 2005
Location: Pensacola, FL
Distribution: Slackware64 Current & Arch
Posts: 1,092

Rep: Reputation: 174Reputation: 174
Quote:
Originally Posted by atomn View Post
I just changed the permissions on my fonts directory to 666 after not being able to import a font folder to the directory even though I was logged in as root. As soon as I did every bit of text on my system turned into a square. It's just funny at this point that Linux claims to be more stable than windows. I've been running window on my new PC for two months without a single error, yet I've had nothing be big problems with Linux after running it for literally 2 days. How stable is an OS (Ubuntu/debian) that has to lock up it's font directory otherwise the fonts go crazy and get corrupted immediately after changing the permissions.
Sorry to hear about your bad experience, reminds me of my first time.

All I can really say is to try some of the other distros until you find one you're comfortable with. Back up any configs that you have edited so you may use some of it if needed.

Good luck and don't give up..............
 
Old 01-14-2009, 02:02 AM   #11
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,618

Rep: Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651
hi atomn compiz and compiz-fusion don't run to well an a HP dv9000 notebook , or any notebook . because it runs on the graphics card GPU and not the system cpu with a notebook most of the work ends up being done by the system cpu and it will REALLY slow things down a bit .
But Ubuntu is a good distro for the new person switching over from windows .It is very stable but there is a learning curve just like the one you had learning windows ( 98,me,xp, now vista).
So give it some time and soon it will be second nature .
Also use the Ubuntu package manager for all the software installs ( if possible ) , it will keep things strait for you so you don't kill the operating system . But even if you do then is is VERY easy to reinstall .
I reinstalled fedora 4 and 5 then 6 quite a few times after I messed up the system( FUBAR 'ed it )
 
Old 01-14-2009, 10:53 AM   #12
atomn
LQ Newbie
 
Registered: Jan 2009
Posts: 15

Original Poster
Rep: Reputation: 0
My laptop is a media laptop with a pretty good nvidia graphics card. Compiz works really well on it...it's super fast. Running compiz hasn't been a problem. The problem that I had eariler seemed to have been related to the settings in compiz, not it performance.

My real problem now is that after I changed the permissions on my font folder all of my system fonts changed to square symbols and so I can't read anything on my system. I'm going to show it to a friend today and see if he can't use a command line (the only place where fonts aren't messed up) to fix the fonts.

I don't mind reinstalling, it's just that after a while it gets old.
 
Old 01-14-2009, 01:32 PM   #13
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,618

Rep: Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651Reputation: 2651
because "666" is not the correct setting
files in /,/etc,/bin/usr/bin,/usr/share ( and so on) should not be changed
from ls -l in /usr/share
drwxr-xr-x 29 root root 4096 2008-12-12 15:29 fonts
try this
Code:
sudo( or su)
cd /usr/share
chown -R root:root fonts
chmod -R 755 fonts
chmod +x fonts
logout and log backin
 
Old 01-15-2009, 05:32 AM   #14
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682Reputation: 682
Quote:
I just changed the permissions on my fonts directory to 666 after not being able to import a font folder to the directory even though I was logged in as root.
Where is this directory. A directory needs the 'x' bit set to be able to enter the directory. The system can't read the font files inside the directory. If you mean the .fonts directory in your own home directory, creating files as root can cause problems, due to the file being owned by root.

Are you logged in as root in the gui? That isn't a good idea. Sudo exists so you can perform some commands as root.
 
Old 01-15-2009, 11:32 AM   #15
atomn
LQ Newbie
 
Registered: Jan 2009
Posts: 15

Original Poster
Rep: Reputation: 0
used chmod to change the permissions to 777, and it fixed all of my fonts automatically. I used sudo /fontsdirectory/ and then chmod 777 /fontsdirectory/ or something like that. Anyway, It fixed it. I have no idea why, but it did.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Compiz - setting mouse focus... nbcohen Linux - Desktop 2 08-23-2023 11:55 AM
Mouse failure after starting compiz Rhodie Ubuntu 3 12-09-2008 06:25 AM
Gnome, Compiz, Mouse Button 1 problems linchat Linux - Desktop 0 07-28-2007 11:05 AM
Compiz OpenSuse Mouse Mapping linchat Linux - Desktop 0 07-24-2007 12:02 PM
jacked up glibc rdanda Slackware 6 04-10-2003 11:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 04:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration