LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-02-2006, 09:25 AM   #1
gr0sshirn
LQ Newbie
 
Registered: Aug 2006
Location: Germany
Distribution: Gentoo [2.6.17-gentoo-r7]
Posts: 8

Rep: Reputation: 0
compiling problem


i often get this error while trying to install different packages:

configure: error:
you need to install kdelibs first.

If you did install kdelibs, then the Qt version that is picked up by
this configure is not the same version you used to compile kdelibs.
The Qt Plugin installed by kdelibs is *ONLY* loadable if it is the
_same Qt version_, compiled with the _same compiler_ and the same Qt
configuration settings.


!!! Please attach the following file when filing a report to bugs.gento
!!! /var/tmp/portage/k3b-0.12.17/work/k3b-0.12.17/config.log

!!! ERROR: app-cdr/k3b-0.12.17 failed.
Call stack:
ebuild.sh, line 1543: Called dyn_compile
ebuild.sh, line 938: Called src_compile
k3b-0.12.17.ebuild, line 95: Called kde_src_compile
kde.eclass, line 166: Called kde_src_compile 'all'
kde.eclass, line 325: Called kde_src_compile 'myconf' 'configure' '
kde.eclass, line 307: Called econf '--enable-libsuffix=' '--with-ex
bsamplerate' '--without-resmgr' '--without-k3bsetup' '--without-hal' '-
e' '--with-ffmpeg' '--with-flac' '--with-oggvorbis' '--without-sndfile'
libmad' '--without-musepack' '--without-musicbrainz' '--with-alsa' '--w
-enable-mitshm' '--without-xinerama' '--with-qt-dir=/usr/qt/3' '--enabl
with-qt-libraries=/usr/qt/3/lib' '--disable-dependency-tracking' '--dis
g' '--without-debug' '--with-arts' '--with-extra-includes=/usr/kde/3.5/
'--with-extra-libs=/usr/kde/3.5/lib'
ebuild.sh, line 539: Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call sta
evant.


---
the actual versions of kdelibs and qt are installed (with the same compiler (gcc 4.1) )

any idea to fix that?
 
Old 09-02-2006, 09:39 AM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 58
Try revdep-rebuild
It is in gentoolkit
emerge gentoolkit
revdep-rebuild
emerge k3b
what happens
 
Old 09-02-2006, 10:04 AM   #3
gr0sshirn
LQ Newbie
 
Registered: Aug 2006
Location: Germany
Distribution: Gentoo [2.6.17-gentoo-r7]
Posts: 8

Original Poster
Rep: Reputation: 0
allready tried... revdeprebuild can't find any problems... i have remerged qt and kdelibs (with different compiler versions, too) ...doesn't worx

!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/k3b-0.12.17/work/k3b-0.12.17/config.log

--> the logfile (latest lines):

kdeinitdir=''
libdir='${exec_prefix}/lib'
libexecdir='${exec_prefix}/libexec'
localstatedir='/var/lib'
mandir='/usr/share/man'
oldincludedir='/usr/include'
prefix='/usr'
program_transform_name='s,x,x,'
qt_includes='/usr/qt/3/include'
qt_libraries='/usr/qt/3/lib'
sbindir='${exec_prefix}/sbin'
sharedstatedir='${prefix}/com'
sysconfdir='/etc'
taglib_includes=''
taglib_libs=''
target='i686-pc-linux-gnu'
target_alias=''
target_cpu='i686'
target_os='linux-gnu'
target_vendor='pc'
unsermake_enable_pch_FALSE=''
unsermake_enable_pch_TRUE='#'
with_k3bsetup1_FALSE=''
with_k3bsetup1_TRUE=''
x_includes='.'
x_libraries='/usr/lib'
xdg_appsdir=''
xdg_directorydir=''
xdg_menudir=''

## ----------- ##
## confdefs.h. ##
## ----------- ##

#define HAVE_CRYPT 1
#define HAVE_DLFCN_H 1
#define HAVE_INTTYPES_H 1
#define HAVE_LIBJPEG 1
#define HAVE_LIBPNG 1
#define HAVE_LIBPTHREAD 1
#define HAVE_LIBZ 1
#define HAVE_MEMORY_H 1
#define HAVE_RES_INIT 1
#define HAVE_RES_INIT 1
#define HAVE_RES_INIT_PROTO 1
#define HAVE_SGI_STL 1
#define HAVE_SNPRINTF 1
#define HAVE_STDINT_H 1
#define HAVE_STDINT_H 1
#define HAVE_STDLIB_H 1
#define HAVE_STRINGS_H 1
#define HAVE_STRING_H 1
#define HAVE_SYS_BITYPES_H 1
#define HAVE_SYS_STAT_H 1
#define HAVE_SYS_TYPES_H 1
#define HAVE_SYS_TYPES_H 1
#define HAVE_UNISTD_H 1
#define HAVE_VSNPRINTF 1
#define KDELIBSUFF ""
#define PACKAGE "k3b-0.12.17"
#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define SIZEOF_CHAR_P 4
#define SIZEOF_INT 4
#define SIZEOF_LONG 4
#define SIZEOF_SHORT 2
#define SIZEOF_SIZE_T 4
#define SIZEOF_UNSIGNED_LONG 4
#define HAVE_DLFCN_H 1
#define HAVE_INTTYPES_H 1
#define HAVE_LIBJPEG 1
#define HAVE_LIBPNG 1
#define HAVE_LIBPTHREAD 1
#define HAVE_LIBZ 1
#define HAVE_MEMORY_H 1
#define HAVE_RES_INIT 1
#define HAVE_RES_INIT 1
#define HAVE_RES_INIT_PROTO 1
#define HAVE_SGI_STL 1
#define HAVE_SNPRINTF 1
#define HAVE_STDINT_H 1
#define HAVE_STDINT_H 1
#define HAVE_STDLIB_H 1
#define HAVE_STRINGS_H 1
#define HAVE_STRING_H 1
#define HAVE_SYS_BITYPES_H 1
#define HAVE_SYS_STAT_H 1
#define HAVE_SYS_TYPES_H 1
#define HAVE_SYS_TYPES_H 1
#define HAVE_UNISTD_H 1
#define HAVE_VSNPRINTF 1
#define KDELIBSUFF ""
#define PACKAGE "k3b-0.12.17"
#define PACKAGE_BUGREPORT ""
#define PACKAGE_NAME ""
#define PACKAGE_STRING ""
#define PACKAGE_TARNAME ""
#define PACKAGE_VERSION ""
#define SIZEOF_CHAR_P 4
#define SIZEOF_INT 4
#define SIZEOF_LONG 4
#define SIZEOF_SHORT 2
#define SIZEOF_SIZE_T 4
#define SIZEOF_UNSIGNED_LONG 4
#define STDC_HEADERS 1
#define VERSION "3.4.3"
#define kde_socklen_t socklen_t
#define ksize_t socklen_t
#endif
#ifdef __cplusplus
extern "C" void std::exit (int) throw (); using std::exit;

configure: exit 1

------------

eventually a ebuild mistacke?
--
nice homepage comprookie2000! =)

Last edited by gr0sshirn; 09-02-2006 at 10:06 AM.
 
Old 09-02-2006, 10:11 AM   #4
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 58
Thanks,
look through
http://bugs.gentoo.org/
I will look around, I'm not doing anything. I searched the gentoo forums and couldn't really find
anything.
later
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
compiling problem? kalleanka Programming 7 08-26-2006 07:45 AM
problem compiling :( celeron2002 Linux - Software 1 02-22-2004 07:19 PM
Compiling Problem... ThE_DeaD Linux - Newbie 10 12-14-2003 03:14 PM
Compiling problem.... pyrocrickett Linux - Software 2 09-11-2003 02:19 PM
compiling problem with RH 9 tucdual Linux - Distributions 4 08-26-2003 07:03 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration