-   Linux - Software (
-   -   compiling or installing gtkpod-aac (

Steel3 11-12-2005 07:22 PM

compiling or installing gtkpod-aac
I apologize if this has been posted before. I'm running on Ubuntu Breezy.

I'd like to use gtkpod-aac to organize a bunch of files that one of my roommates on a mac loaned me, but I haven't found a package for it in universe, backports, and such and I haven't been able to install it from any debs that I've come across. I downloaded the source and satisfied all of the dependencies, but when i run configure I still don't have mp4v2 available or whatever so it says I can't compile it with aac support. I have the libmp4v2-dev package installed. Here's the output:

Configuration for gtkpod 0.94.0 :

Host System Type .....: i686-pc-linux-gnu
Install path .........: /usr/local
Preprocessor .........: gcc
Compiler .............: gcc -g -O2 -Wall -pthread -I/usr/include/gtk-2.0 -I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libglade-2.0 -I/usr/include/libxml2
Linker ...............: gcc -lmp4v2 -lid3tag -pthread -Wl,--export-dynamic -lgthread-2.0 -lglade-2.0 -lgtk-x11-2.0 -lxml2 -lz -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 -lm -lpangocairo-1.0 -lfontconfig -lXinerama -lXi -lXrandr -lXext -lXcursor -lXfixes -lpango-1.0 -lcairo -lXrender -lX11 -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
GTK2 version .........: 2.8.6
GLib2/GThread version : 2.8.3
id3tag lib ...........: yes
mp4v2 ................: *** no -- will build without aac support
NLS/gettext ..........: yes

Now type 'make' to build gtkpod 0.94.0,
and then 'make install' for installation.

Any suggestions?

gazurtoids 11-16-2005 07:15 AM

Hi Steel3,

I've just this second managed to get gtkpod compiled with AAC support. Here's what to do:

1. In your gtkpod source directory, edit src/mp4file.c and change the include line for mp4 to look in the standard include directory.
#include "mp4.h"
#include <mp4.h>

2. Edit the config.h file and find the line looking like /* #undef HAVE_LIBMP4V2 */ - it should be line 35. Below it, add:
#define HAVE_LIBMP4V2 1
This will enable the AAC support distabled by ./configure

3. I then came up across a problem in /usr/include/systems.h, line 248 . To solve it, I commented out a section referring to C++. gtkpod is written in C so doesn't need this section but you probably want to uncomment it when done. To do this, comment out the section between lines 246 and 252 like so:
#ifdef __cplusplus
extern "C" {
char *strsep(char **strp, const char *delim);
#ifdef __cplusplus

As a further tip, "checkinstall" is a very useful tool for installing programs compiled from source under ubuntu. Worth using if you don't already know about it.

Enjoy your AAC files!

cedeo 02-10-2006 08:39 AM

Still no mp4 support
I made the changes suggested by Gazurtoids above and still got no joy. I did a "make distclean" (I believe that removes any config done by ./configure, right?), but still get no mp4 support when I run ./configure.

Any ideas? I'm running ubuntu 5.10.

All times are GMT -5. The time now is 11:43 PM.