LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-25-2017, 02:29 AM   #1
R03L
Member
 
Registered: Feb 2008
Location: Emmer-compascuum
Distribution: redhat* debian* arch* slack*
Posts: 216

Rep: Reputation: 31
Post Compiling GMFSK for hamradio modes Failed afther running Make


i installed all missing dependency's for GMFSK and tried to compiled it with
Code:
./configure
as i did it once with
Code:
./autogen.sh
to but it still failed afther running
Code:
Make
afther
Code:
./autogen.sh
Code:
Now type `make' to compile.
Code:
make  all-recursive
make[1]: Map '/home/r03l/Downloads/gmfsk-0.6' wordt binnengegaan
Making all in m4
make[2]: Map '/home/r03l/Downloads/gmfsk-0.6/m4' wordt binnengegaan
make[2]: Er hoeft niets gedaan te worden voor 'all'.
make[2]: Map '/home/r03l/Downloads/gmfsk-0.6/m4' wordt verlaten
Making all in src
make[2]: Map '/home/r03l/Downloads/gmfsk-0.6/src' wordt binnengegaan
Making all in misc
make[3]: Map '/home/r03l/Downloads/gmfsk-0.6/src/misc' wordt binnengegaan
gcc -DHAVE_CONFIG_H -I. -I../.. -DPACKAGE_DATA_DIR=\""/usr/local/share"\" -DPACKAGE_LOCALE_DIR=\""/usr/local/share/locale"\" -D_REENTRANT -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/gnome-keyring-1 -I/usr/include/libbonoboui-2.0 -I/usr/include/libxml2 -I/usr/include/libgnome-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/orbit-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gail-1.0 -I/usr/include/libart-2.0 -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/include -I/usr/include/gconf/2 -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include    -g -O2 -MT cmplx.o -MD -MP -MF .deps/cmplx.Tpo -c -o cmplx.o cmplx.c
mv -f .deps/cmplx.Tpo .deps/cmplx.Po
gcc -DHAVE_CONFIG_H -I. -I../.. -DPACKAGE_DATA_DIR=\""/usr/local/share"\" -DPACKAGE_LOCALE_DIR=\""/usr/local/share/locale"\" -D_REENTRANT -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0 -I/usr/include/gnome-keyring-1 -I/usr/include/libbonoboui-2.0 -I/usr/include/libxml2 -I/usr/include/libgnome-2.0 -I/usr/include/libbonobo-2.0 -I/usr/include/bonobo-activation-2.0 -I/usr/include/orbit-2.0 -I/usr/include/libgnomecanvas-2.0 -I/usr/include/gail-1.0 -I/usr/include/libart-2.0 -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/gio-unix-2.0/ -I/usr/include/cairo -I/usr/include/pango-1.0 -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/libpng16 -I/usr/include/pango-1.0 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/freetype2 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libpng16 -I/usr/include/gnome-vfs-2.0 -I/usr/lib/x86_64-linux-gnu/gnome-vfs-2.0/include -I/usr/include/gconf/2 -I/usr/include/dbus-1.0 -I/usr/lib/x86_64-linux-gnu/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include    -g -O2 -MT misc.o -MD -MP -MF .deps/misc.Tpo -c -o misc.o misc.c
In file included from misc.c:25:0:
misc.h:109:19: error: conflicting types for ‘log2’
 extern inline int log2(unsigned int x)
                   ^~~~
In file included from /usr/include/features.h:364:0,
                 from /usr/include/math.h:26,
                 from misc.h:28,
                 from misc.c:25:
/usr/include/x86_64-linux-gnu/bits/mathcalls.h:144:1: note: previous declaration of ‘log2’ was here
 __MATHCALL (log2,, (_Mdouble_ __x));
 ^
Makefile:381: recept voor doel 'misc.o' is mislukt
make[3]: *** [misc.o] Fout 1
make[3]: Map '/home/r03l/Downloads/gmfsk-0.6/src/misc' wordt verlaten
Makefile:512: recept voor doel 'all-recursive' is mislukt
make[2]: *** [all-recursive] Fout 1
make[2]: Map '/home/r03l/Downloads/gmfsk-0.6/src' wordt verlaten
Makefile:455: recept voor doel 'all-recursive' is mislukt
make[1]: *** [all-recursive] Fout 1
make[1]: Map '/home/r03l/Downloads/gmfsk-0.6' wordt verlaten
Makefile:373: recept voor doel 'all' is mislukt
make: *** [all] Fout 2
Thanks in advanced
Attached Thumbnails
Click image for larger version

Name:	gMFSK.png
Views:	10
Size:	128.3 KB
ID:	25104  
 
Old 05-25-2017, 04:44 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,430

Rep: Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623
Example 1. In /home/[name]/rpms/
$ cd SPECS/
$ rpmbuild -bb gmfsk.spec
.
Wrote: /home/knudfl/rpms/RPMS/x86_64/gmfsk-0.7-0.5.pre1.x86_64.rpm
.

Example 2. In /home/[name]/tmp/
$ cd gmfsk-0.7pre1/
$ patch -p1 < gmfsk-0.7pre1-gcc.patch
patching file src/olivia/mfsk.h
.... I.e. patch the old gmfsk to use gcc-4.1.2
$ ./configure && make : No errors.

Example 3. # apt-get install gmfsk https://packages.debian.org/jessie/hamradio/gmfsk
The source and the 4 Debian patches: gmfsk_0.6+0.7pre1.orig.tar.gz , gmfsk_0.6+0.7pre1-2.3.debian.tar.gz → 12-gcc43-fixes.patch, etc.


-

Last edited by knudfl; 05-25-2017 at 04:47 AM.
 
Old 05-27-2017, 01:05 AM   #3
R03L
Member
 
Registered: Feb 2008
Location: Emmer-compascuum
Distribution: redhat* debian* arch* slack*
Posts: 216

Original Poster
Rep: Reputation: 31
well its on ubuntu 17.04 but they removed gmfsk somewhy from already 16.10 i notice and they also removed gmfsk from the ubuntu ham's repository it is just not there anymore.
so a centos/redhat patch witch concluded is already in the sources as the patch did not apply to the source becouse of this.

im still running against this compilation error.
 
Old 05-27-2017, 03:13 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2021 CentOS7.9 + 50+ other Linux OS, for test only.
Posts: 17,430

Rep: Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623Reputation: 3623
Re #4.

Ubuntu any version, gmfsk is the same package, really no changes since 2008.
The available Debian or Ubuntu package can be used. Trusty :

https://packages.ubuntu.com/trusty/gmfsk
→ → http://nl.archive.ubuntu.com/ubuntu/...-2.3_amd64.deb

Install the package ...
cd Downloads/
sudo gdebi gmfsk_0.6+0.7pre1-2.3_amd64.deb

-
 
1 members found this post helpful.
  


Reply

Tags
compilation, failed, gmfsk, hamlibs


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error when running make config as I'm busy compiling my kernel on Slackware 12.1.0 Linux Duke Slackware 11 02-09-2012 08:49 AM
[SOLVED] src2pkg Running make install has failed with error: 1 matters Slackware 14 03-13-2010 03:27 PM
gMFSK problems SteveON Linux - Software 1 01-17-2006 11:44 AM
gMFSK and ALSA charliew Linux - General 0 01-17-2005 04:21 PM
Games that switch video modes make display into bars TCv1 Linux - Software 0 03-26-2004 03:55 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration