-   Linux - Software (
-   -   Compiling Emacs - ./configure can't find tput (

hellomynameisphil 06-29-2013 09:55 PM

Compiling Emacs - ./configure can't find tput
Hi all,

CRUX user here. Trying to install emacs via a custom port, but ./configure can't find tput:


checking for library containing tputs... no
configure: error: The required function `tputs' was not found in any library.
The following libraries were tried (in order):
  libtinfo, libncurses, libterminfo, libtermcap, libcurses
Please try installing whichever of these libraries is most appropriate
for your system, together with its header files.
For example, a libncurses-dev(el) or similar package.
=======> ERROR: Building '/home/phil/ports/emacs/emacs#24.3-1.pkg.tar.gz' failed.

I have ncurses installed (it's part of core). There is no dev package to install, as CRUX is source-based; the headers all seem to be in /usr/include.

This same package used to build fine, but after a recent update, I have been having issues with libraries not being found. I had some issues using and upgrading roxterm, firefox and chromium because it was looking for the wrong version of libicule. I solved this by re-compiling pango, gtk and vte (in that order). I have emacs installed, but when I try to run it, I get:


emacs: error while loading shared libraries: cannot open shared object file: No such file or directory
which is why I am trying to re-install it.

Can I please get some help figuring out why all this doesn't work?

rtmistler 07-01-2013 12:47 PM

This seems to be discussing your problem

All times are GMT -5. The time now is 12:42 AM.