-   Linux - Software (
-   -   Compiling aview with aalib (

Exeis 01-05-2007 07:58 PM

Compiling aview with aalib
I've tried to compile 'aview-1.3.0rc1'. I've previously installed aalib 1.4 (latest as of Dec. 2006). When i ran "./configure" I got this error:
checking for AALIB - version >= 1.4.0... no
*** Could not run AALIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means AALIB was incorrectly installed
*** or that you have moved AALIB since it was installed. In the latter case, you
*** may want to edit the aalib-config script: /usr/bin/aalib-config
configure: error: *** AALIB >= 1.4.0 not installed - please install first ***

I've looked at the 'config.log'. I think I'm missing 'lslang'. This is why:

configure:3161: checking for aalib-config
configure:3179: found /usr/bin/aalib-config
configure:3192: result: /usr/bin/aalib-config
configure:3200: checking for AALIB - version >= 1.4.0
configure:3290: gcc -o conftest -g -O2 -I/usr/include conftest.c -L/usr/lib -Wl,-rpath,/usr/lib -la
a -lm -L/usr/X11R6/lib -lX11 -lgpm -lslang >&5
/usr/lib/gcc/i486-slackware-linux/3.4.6/../../../../i486-slackware-linux/bin/ld: cannot find -lslang
collect2: ld returned 1 exit status

So, my question is, what does the error mean in the './configure' script output and the error in the 'config.log', and where can I get 'lslang'? I have the slackware 10.2 Disc set, so is there a pkg (*.tgz) that has 'slang'?

P.S. This was done in Slackware 10.2, Kernel 2.4.31

weibullguy 01-05-2007 08:27 PM

That first letter is a lowercase L. It is looking for libslang. You would need slang installed. According to this place, slang is available for Slackware 10.2.

The error in the aview configure just means that's what the aview developers figure the most likely reason is.

All times are GMT -5. The time now is 05:39 AM.