LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-26-2004, 03:51 AM   #1
5KIDMA
Member
 
Registered: Sep 2004
Location: Bundaberg, Qld, Australia
Distribution: Mandrake
Posts: 32

Rep: Reputation: 15
Compiled kernel, can't play cd's


Hi all i have just finished compiling a kernel which i did to get my ATI drivers working (which work now btw but now when i got to use KsCD or any other prog that plays cd's they won't play or even recongnise the cd's, also the eject button no longer works in the gui. but when i mount a cd with data on it it works no problems. The thing i don't understand is I used my original config file and only changed a few options, i turned Direct rendering off, and built the agpgart drivers for my mobo into the kernel i changed NOTHING else.

Asus A7N8X Deluxe
Athlon 2600
512Mb DDR
Ati 9200
MDK10
Kernel 2.6.3-7
 
Old 10-26-2004, 04:20 AM   #2
Hammett
Senior Member
 
Registered: Aug 2003
Location: Barcelona, Catalunya
Distribution: Gentoo
Posts: 1,074

Rep: Reputation: 59
Did you get the same vanilla kernel version? Or did you upgrade??

Also, in my experience, recompiling kernel with mandrake has always been a pain in the back hurting as hell for 1000 years (actually I never achieved it to recompile under mdk).
If you did upgrade kernel, try to get the same version mdk has (2.6.3 in your case), recompile again and see.

If you're using digital reading, may you try xmms 1.2.10
 
Old 10-26-2004, 04:45 AM   #3
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Audio CDs can not be mounted. Use XMMS. In XMMS select the add directory. Then select /mnt/cdrom or /dev/cdrom. Make sure either the audio cable from the CD-ROM drive is connected to the sound card. Also make sure the mixer of the CD-ROM is unmuted and the volume for the CD-ROM is set properly. XMMS has digital extraction. If you do not have the audio cable connected from the CD-ROM drive, you can turn on digital extraction through XMMS plugin.

Edit the fstab file to not include supermount because it can get in the way of Audio CDs. Also it kinda helps to set the /dev/cdrom symbolic link to the devfsd path instead of the normal /dev/hdc or whatever device.

You do not need to re-compile the kernel to get ATI modules (drivers) working. You just need to compile them as modules. Then add a few lines in modules.conf or similar file.

Compiling Mandrake can be done very easily. You just need to copy the config file located in /boot to to the linux kernel source directory and name the file as ".config". Then do either "make xconfig" or "make menuconfig" to select other options for the kernel. I used the intructions from http://www.justlinux.com/nhf/Compili...mpilation.html in the past.

Never apply patches to Linux Distribution kernels. Only apply patches to vanilla, straight from kernel.org oven, kernels.
 
Old 10-26-2004, 05:02 AM   #4
5KIDMA
Member
 
Registered: Sep 2004
Location: Bundaberg, Qld, Australia
Distribution: Mandrake
Posts: 32

Original Poster
Rep: Reputation: 15
Yes the cd audio cable is on the drive, yes i did use the same config as i wrote in my first post, yes i used the source code that came on the mdk cd for that distro. no the drive is not supermounted. the mixer settings are fine KsCD used to work before i recompiled the kernel, and in the guide i read i did need to recompile the kernel as i have an Nforce2 chipset and i also had to diable direct rendering (thats what the guide said to do and it worked ). How do i setup the symlink to use dev/cdrom instead of dev/hdc ????

thanks fo all the help so far

Edit: also i have applied NO patches to the kernel
 
Old 10-26-2004, 09:24 PM   #5
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
As root type "ln -sf /dev/hdc /dev/cdrom". As I said before if you are using devfsd, probably you are, it is better to set /dev/cdrom to the devfsd path instead of /dev/hdc. Read the man pages for ln.

The devfsd path will be something like /dev/ide/host0/bus1/target0/lun0/generic for /dev/hdc.

It is strange that /dev/cdrom was deleted in the process of re-compiling the kernel.
 
Old 10-26-2004, 09:28 PM   #6
haimeltjnfg
Member
 
Registered: May 2004
Distribution: debian
Posts: 235

Rep: Reputation: 30
#lsmod | grep cd

you should have the ide-cd and cdrom modules ....
 
Old 10-27-2004, 02:27 AM   #7
5KIDMA
Member
 
Registered: Sep 2004
Location: Bundaberg, Qld, Australia
Distribution: Mandrake
Posts: 32

Original Poster
Rep: Reputation: 15
Here is the output of the command you just gave me doesn't say anything about ide cd in there.

Code:
[root@qld ben]# lsmod | grep cd
ehci-hcd               22852  0
ohci-hcd               16964  0
usbcore                90844  5 hid,ehci-hcd,ohci-hcd
[root@qld ben]#
also putting that symlink in there did nothing either
 
Old 10-27-2004, 04:27 AM   #8
5KIDMA
Member
 
Registered: Sep 2004
Location: Bundaberg, Qld, Australia
Distribution: Mandrake
Posts: 32

Original Poster
Rep: Reputation: 15
Problem Solved

Thanks for all the advice guys, i just recompiled a later version of the kernel, removed a lot of unnecessary stuff from my original config file, it's working fine now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
how to play video cd's mili Linux - Newbie 3 04-29-2005 12:39 AM
Can't play CD's Valhalla Linux - Software 2 03-06-2005 12:20 PM
how come i cant play my cd's???? blind958 Mandriva 3 07-16-2004 02:34 PM
Why can't I play Music CD's sgtbob Linux - Newbie 12 01-30-2004 06:28 PM
help me play cd's dynamo593 Linux - General 0 12-23-2001 01:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration