LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   compile new kernel (https://www.linuxquestions.org/questions/linux-software-2/compile-new-kernel-17395/)

Pieter 03-31-2002 04:38 AM

compile new kernel
 
I'm currently working with Red Hat 7.2 and the 2.4.17 kernel.
But in my current configuration I have no ntfs support. SO I wanted to recompile my kernel and make it one one version higher (2.4.18) at the same time.
The case is, that I succeeded in recompiling my kernel, but when I try to reboot it says it does not support ext3-fs, but I did say yes to everything evening just mentioning this filesystem, but still it doesn't work. Now I can't get the new kernel to a graphical login (text-based does work; and I can still use my old kernel).
My question is: how can I get the new kernel to support ext3-fs ?

Another thing is, when I boot the new kernel it says it will remove my mouse driver and I can choose 3 options:
1. remove configuration
2. keep it
3. do nothing
What does this mean ?
By the way, it is a blue screen somewhat like a MS-DOS editor.

I hope someone can help me, I'm still very new to this. :study:

greenhornet 03-31-2002 09:55 AM

Not sure about the ntfs problem, tackling that one myself currently.

You might try this website though.
http://www.getlinuxonline.com/omp/di...at/ompntfs.txt

When you log in as root, type runlevel you will see two numbers after that, the second number is the current runlevel.
In a nutshell;
runlevel 3 = text
runlevel 5 = graphical

You need to edit the file /etc/inittab to tell red hat which runlevel to boot up in. Look for the line;
id:3:initdefault:

and change that 3 (or whatever) to a 5, reboot and it will start with a graphical login.

Note : this does assume X is setup properly to start with. It may be that X isnt working when it tries to enter runlevel 5 and crashes. In that case you'll need to re-run Xconfigurator or something to configure X properly.

The blue screen program you mention is Kudzu, redhats hardware instalation program. If you see this for some reason RH thinks it has found new hardware. Probably select to configure the device for this one, if you see it again on subsequent reboots you might have a problem.

You can inspect /etc/sysconfig/hwconf and /proc/pci to see what devices RH has detected and what drivers its using for them.

Hope this helps.
GH

Pieter 03-31-2002 10:54 AM

I think you didn't understand what I mean. The kernel has no ext3-fs support, but my Linux partition is formatted with ext3-fs. Now when I boot it says it doesn't support ext3-fs, then it tries to boot the graphical login but can't (probably because it can't read the files in ext3-fs format). My question is how I can get my new kernel to support ext3-fs.
Another question is: when confguring a new kernel (e.g. with xconfig), will the current settings automatically be selected or not ? So maybe it is better te recompile my old kernel and not use an entirely new one ?

Thx for the help on kudzu. I suspected as much.

mikek147 03-31-2002 11:01 AM

A neat trick you might employ is to copy the .config file from the source 2.4.17 tree to the source 2.4.18 tree. This will insure that you have the same basic setup you had. Once you've done that, then you can 'make xconfig' in the 2.4.18 tree and add any new configurations you'd like to try out. -mk

Aussie 03-31-2002 11:15 AM

If you've compiled ext3 support as a module you'll get this error, the problem is the drive is being mounted before the module is loaded, check your config, you may need to recompile the kernel with ext3 built in.

Pieter 04-01-2002 09:32 AM

Where can I find that .config file? I found a defconfig in the arch directory of my old kernel, but compiling with that file did not help.

mikek147 04-01-2002 02:12 PM

If you haven't done a kernel build before, there won't be one available. If you built kernel-source 2.4.17, then there is one available /usr/src/kernel-source-2.4.17/.config -mk


All times are GMT -5. The time now is 04:39 AM.