LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-17-2008, 04:43 PM   #1
versaulis
Member
 
Registered: Sep 2003
Posts: 139

Rep: Reputation: 15
Compile from source as limited user - how do I tell configure where dependencies are?


I'm trying to compile and install cairo-1.6.4 under Suse Linux Enterprise Desktop. cairo-1.6.4 depends on pixman >= 0.10.0

pixman gave me no problems.
./configure --prefix=/programs/pixman-0.12.0
make
make install

cairo complains about pixman when I run
./configure --prefix=/programs/cairo-1.6.4 --with-pixman=/programs/pixman-0.12.0


I am running as a limited user and I am assuming that --with-pixman is correct based on some googleing. Obviously, I've got something wrong here. So, how do I specify where I have installed pixman, so that cairo configures and makes correctly?

Other notes:
I am also assuming that, by using --prefix, I am installing all the files into the specified folder. Nothing is being distributed elsewhere, especially since I'm not root and am not getting any other errors.

Last edited by versaulis; 09-17-2008 at 04:44 PM.
 
Old 09-17-2008, 05:12 PM   #2
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,841

Rep: Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868
Quote:
cairo complains about pixman when I run
./configure --prefix=/programs/cairo-1.6.4 --with-pixman=/programs/pixman-0.12.0

I am running as a limited user and I am assuming that --with-pixman is correct based on some googleing.
There is no such option --with-pixman at least for cairo-1.6.4:
Code:
./configure --help |grep -i pixman
  pixman_CFLAGS
              C compiler flags for pixman, overriding pkg-config
  pixman_LIBS linker flags for pixman, overriding pkg-config
So I guess you can set pixman_LIBS=/programs/pixman-0.12.0/lib, or extend PKG_CONFIG_PATH prior running ./configure for cairo:
Code:
export PKG_CONFIG_PATH=/programs/pixman-0.12.0/lib/pkgconfig:$PKG_CONFIG_PATH

Last edited by bathory; 09-18-2008 at 09:06 AM.
 
Old 09-17-2008, 05:18 PM   #3
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,520

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
first a question WHY are you installing them in there OWN folder ???
if you do this ALL bin,include,lib,share,... in EVERY folder will need to be added to the system path

PS. THIS is not windows so don't do things the MS ( messed up )way
the standard is --prefix=/usr
or --prefix=/home/( user name)/MyBuilds
------
/home/( user name)/MyBuilds will then have in it
/home/( user name)/MyBuilds/bin
/home/( user name)/MyBuilds/lib
/home/( user name)/MyBuilds/include
/home/( user name)/MyBuilds/share
build your programs for this tree
Then all you need to do is add 1 ( one) entry to the system path
 
Old 09-18-2008, 08:40 AM   #4
versaulis
Member
 
Registered: Sep 2003
Posts: 139

Original Poster
Rep: Reputation: 15
Thanks Bathory, that's what I needed to know. I'm sure I'll figure it out from here on out.

I'm doing it this way, because I would like to create a directory structure that contains all of the programs that my team needs, while keeping the custom builds away from the package system's files. From time to time, we may login to each other's boxes, so we want the programs in a central location. The name of the folder shouldn't really matter. If you're going to let the name "programs" ruin your day, then you need to learn to pick your battles, Johnny.
 
Old 09-18-2008, 08:47 AM   #5
versaulis
Member
 
Registered: Sep 2003
Posts: 139

Original Poster
Rep: Reputation: 15
Thumbs up

Quote:
Originally Posted by bathory View Post
There is no such option --with-pixman at least for cairo-1.6.4:
Code:
./configure --help |grep -i pixman
  pixman_CFLAGS
              C compiler flags for pixman, overriding pkg-config
  pixman_LIBS linker flags for pixman, overriding pkg-config
So I guess you can set pixman_LIBS=/programs/pixman-0.12.0/lib, or extend PKG_CONFIG_PATH prior running ./configure for cairo:
Code:
export PKG_CONFIG_PATH=/programs/pixman-0.12.0/lib:$PKG_CONFIG_PATH
Just a quick note, for future readers, about a typo. It should be (at least under Suse):

export PKG_CONFIG_PATH=/programs/pixman-0.12.0/lib/pkgconfig:$PKG_CONFIG_PATH
 
Old 09-18-2008, 09:06 AM   #6
bathory
LQ Guru
 
Registered: Jun 2004
Location: Piraeus
Distribution: Slackware
Posts: 12,841

Rep: Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868Reputation: 1868
Quote:
Originally Posted by versaulis View Post
Just a quick note, for future readers, about a typo. It should be (at least under Suse):

export PKG_CONFIG_PATH=/programs/pixman-0.12.0/lib/pkgconfig:$PKG_CONFIG_PATH
You're right, that was my fault (already corrected in the above post) and it's true for all distros not only Suse. Whenever you install some sw under /prefix, then the libraries go to /prefix/lib and the pkg-config files under /prefix/lib/pkgconfig.

Glad to see I've helped you on this.

Regards
 
Old 09-18-2008, 11:56 AM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,520

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
first is is not Johnny
Quote:
If you're going to let the name "programs" ruin your day, then you need to learn to pick your battles, Johnny.
" "programs"" dose not matter
the reason for doing a tree is all the programs are in a normal file tree
/home/( user name)/programs/lib
/home/( user name)/programs/lib/( all cairo and pixman lib's )
--------------
the way your doing it is this
/home/( user name)/programs/cairo
/home/( user name)/programs/cairo/lib
/home/( user name)/programs/cairo/lib/( the lib's)
-- and --
/home/( user name)/programs/pixman
/home/( user name)/programs/pixman/lib
/home/( user name)/programs/pixman/lib/( the lib's)

but is is your system do what ever you want. But after a few in there own folders you will be passing 10,20,40 PKG_CONFIG_PATH , LD_CONFIG, and so on. to build instead of one set

Last edited by John VV; 09-18-2008 at 12:00 PM.
 
Old 09-18-2008, 01:02 PM   #8
versaulis
Member
 
Registered: Sep 2003
Posts: 139

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by John VV View Post
first is is not Johnny

" "programs"" dose not matter
the reason for doing a tree is all the programs are in a normal file tree
/home/( user name)/programs/lib
/home/( user name)/programs/lib/( all cairo and pixman lib's )
--------------
the way your doing it is this
/home/( user name)/programs/cairo
/home/( user name)/programs/cairo/lib
/home/( user name)/programs/cairo/lib/( the lib's)
-- and --
/home/( user name)/programs/pixman
/home/( user name)/programs/pixman/lib
/home/( user name)/programs/pixman/lib/( the lib's)

but is is your system do what ever you want. But after a few in there own folders you will be passing 10,20,40 PKG_CONFIG_PATH , LD_CONFIG, and so on. to build instead of one set
Then why does this work:
/home/( user name)/programs/cairo

but not this?
/programs/cairo

Is the system generally configured to look for software in the folder
/home/( user name)/programs

or is there a way to tell it to look in that folder, without specifying each PKG_CONFIG_PATH? And if so, could you then tell it to look in /programs ?
 
Old 09-18-2008, 04:03 PM   #9
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,520

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
it dose not matter where you put it BUT /home/user( you) is owned by you
/programs will need rot to give you ownership of /programs

I tend to build a lot of cod from svn , it normally requires newer programs than what is installed in fedora .Gimp for one .An example : Gimp_svn
when fedora 8 came out all of the prerequisites needed newer versions to build the svn build
so i built and installed them in /opt/Gimp_svn/build
/opt/Gimp_svn/build
/opt/Gimp_svn/build/bin
/opt/Gimp_svn/build/lib
/opt/Gimp_svn/build/lib/pkgconfig
/opt/Gimp_svn/build/include
then told the compiler( autotools) where to find the new pkgconfig is to use
very easy and simple to do it this way
---------
with every single program in it's own folder you would need to pass ALL ( 5,10,or 15) folders to the compiler
/programs/cairo/lib/pkgconfig
/programs/pango/lib/pkgconfig
/programs/gtk/lib/pkgconfig
/programs/atk/lib/pkgconfig
/programs/png/lib/pkgconfig
/programs/zlib/lib/pkgconfig
/programs/libart2/lib/pkgconfig
/programs/libpoppler/lib/pkgconfig
-- you get the idea ---
would be the same for all of the includes ( header files -- *.h )
 
Old 09-15-2009, 10:32 AM   #10
dap263
LQ Newbie
 
Registered: Sep 2009
Posts: 3

Rep: Reputation: 0
Quote:
Originally Posted by bathory View Post
There is no such option --with-pixman at least for cairo-1.6.4:
Code:
./configure --help |grep -i pixman
  pixman_CFLAGS
              C compiler flags for pixman, overriding pkg-config
  pixman_LIBS linker flags for pixman, overriding pkg-config
So I guess you can set pixman_LIBS=/programs/pixman-0.12.0/lib, or extend PKG_CONFIG_PATH prior running ./configure for cairo:
Code:
export PKG_CONFIG_PATH=/programs/pixman-0.12.0/lib/pkgconfig:$PKG_CONFIG_PATH
Thanks -- i was having an issue with installing cairo from source. When I installed pixman it installed into /usr/local/lib/pkgconfig/pixman-1.pc by default, and for some reason pkg-config could not find it.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Don't know how to configure & compile software from source Rissy Red Hat 2 05-17-2008 02:22 PM
Limited User Access Jakeh2k1 Red Hat 1 06-07-2005 07:03 AM
Limited permission on FTP user stefane321 Linux - Security 3 03-04-2005 07:21 PM
Create Limited User Accounts epihammer Mandriva 3 05-18-2004 02:52 PM
limited user yuniarti Linux - General 1 01-01-2001 01:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 12:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration