LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   commercial dvd's do not play after cloning. Irrelevant libdvdcss warning [SOLVED] (https://www.linuxquestions.org/questions/linux-software-2/commercial-dvds-do-not-play-after-cloning-irrelevant-libdvdcss-warning-%5Bsolved%5D-715017/)

wabbalee 03-27-2009 11:53 PM

commercial dvd's do not play after cloning. Irrelevant libdvdcss warning [SOLVED]
 
Hello, after checking google, reading endless threads, trying out all sorts of files and methods, I am getting nowhere.

description of the problem: I can and I can't play commercial dvd's.

I can play them in windows and when I leave the disc in the drive while booting into Linux I can play the dvd in Linux (Kubuntu Hardy). As soon as I take out the dvd disc and put either the same one or another one in I get a message:

This DVD Video is encrypted. To be able to watch it you will need to install libdvdcss by runing from a console:
sudo /usr/share/doc/kaffeine/install-css.sh
In some countries it is illegal to install the decryption software without permission from the copyright holder "ok"button


I already had libdvdcss-1.2.9 installed and this command will downgrade libdvdcss to version 1.2.5 ubuntu's version. Done that but no improvement.
Also, with the program 'regionset' I have checked and set the correct region (4 in my case), again no change.

I have tried various players but they give similar results

not sure where to go from here, also not sure which outputs of certain commands are needed to give more insight

Simon Bridge 03-28-2009 12:04 AM

You don't have everything installed that you need. You also need the dvd tools ... check out the instructions on http://www.hbclinux.net.nz/ubuntu804.html#resmul.

Most people I know use a xine-based player. Totem/xine is fine, VLC is usually overkill but you can choose not to watch those copyright notices and obnoxious segments trying to make out that a major film failed due to video piracy.

wabbalee 03-28-2009 12:55 AM

I have done before I placed this thread that but it did not make a difference.

Simon Bridge 03-28-2009 01:22 AM

"have done" what? I suggested several things.

wabbalee 03-28-2009 05:55 PM

Sorry Simon for being on the short side I had to go to work, but all of the suggested on your website I have done before i placed this post (googled into exactly the same on another website). Right now I am preparing for work again but I wrote something off line yesterday and I will get back at the following after work which will be on Tuesday:

turns out to be a problem in the xine engine parameters;
this time I used Gxine to play a dvd and the message that popped up was not like the previous one mentioned from Kaffeine player.
the message Gxine came up with was more in the likes of (I will try to reproduce the problem later for the proper message):
"/dev/dvd is unreadable, something, something. (due to wrong parameters or restrictions(?))"
it was the '/dev/dvd'-part that made me check the xine engine parameters. at some earlier stage (before this post) I checked the meta info on the drive by doing an alternate click on the icon that appears on Kubuntu desktop whenever a disc is inserted and choose the 'meta-info' tab.
these parameters showed: 'Device Node: /dev/scd0'

this made me change '/dev/dvd' to '/dev/scd0' in the xine engine parameters under the tab 'Media' -> 'Device used for DVD playback:'
Tried 4 or 5 different DVD titles and they all played ok.
not quiet sure what exactly happens here because on various other machines with the same software packages installed that never had any problems playing DVD's, this parameter still is '/dev/dvd' while at the same time under meta-info these drives still show 'Device Node: /dev/scd0'.

quickly tried a few dvd's this morning and they play ok so it looks like it can be considered solved.

although I never had the medibuntu repo's added on the various other machines that always played dvd's fine, I do think I will keep it as it does have a few other interesting pieces of software on it, thanks for that anyway, Simon.

Simon Bridge 03-28-2009 10:50 PM

Quote:

Originally Posted by wabbalee (Post 3491004)
turns out to be a problem in the xine engine parameters;
[snip]
change '/dev/dvd' to '/dev/scd0' in the xine engine parameters under the tab 'Media' -> 'Device used for DVD playback:

OK - solved then. Well spotted.

I have noticed that some players automatically assume css-not-installed when it cannot make sense of the file. Perhaps this could be considered a bug in the error messages?

Another approach to your problem is to check the device node:

$ ls -l /dev/dvd
lrwxrwxrwx 1 root root 4 2009-02-12 15:20 /dev/dvd -> scd0

... see? It's supposed to be a link to the actual device. If this node is absent or not created it will probably be helpful to experiment with how this may have happened and submit a bug report against the offending application.

If you have the time - users who make this sort of effort quickly become Hero Workers to developers. However, I think the error message thing would be the most useful.

wabbalee 03-29-2009 07:42 AM

found some time now to reproduce the problem: changed the "Device used for DVD playback" parameter in the xine engine back to what it initially was: "/dev/dvd" and tried playing a DVD. The following messages (two at once) came up in xine:

ERROR: The source can't be read. Maybe you don't have enough rights for this, or the source doesn't contain data (e.g: not disc in drive). (/dev/dvd)

and the other message:

ERROR: -xine engine error- There is no input plugin available to handle 'dvd:/'. Maybe MRL syntax is wrong or file/stream source doesn't exist.

It is a different message and imo more accurate than the message Kaffeine pops up.


then when I issue command "ls -l /dev/dvd" on the problem machine I get:
ls: cannot access /dev/dvd: No such file or directory

when I alter this command to "ls -l /dev/scd0" on the problem machine I get:
brw-rw----+1 root cdrom 11, 0 2009-03-30 07:27 /dev/scd0

when I issue the command "ls -l /dev/dvd" on this machine (my laptop, not the problem machine) I get:
lrwxrwxrwx 1 root root 4 2009-03-29 21:32 /dev/dvd -> scd0
same as you, Simon. I must say that the problem machine has a slightly newer kernel (at this stage) than this laptop I am on now but that may have nothing to do with the problem. running Ubuntu 8.04.2, kernel 2.6.24-23-generic.

the specs of the problem machine: Dell Precision 370 Desktop, P4, 3Ghz, 1gb ram, 250gb hd, new Optiarc DVD DL burner, ati firegl3100 pcie graphics 128mb. nothing out of the ordinary. running Ubuntu 8.04 kernel 2.6.24-24-generic.

not sure how to file a bug (or if it is one at all?) but I would say the offending application could be Kaffeine as its message lead me to do things that were already done and in place. but if the problem lies deeper under the bonnet I would not have a clue on how to give an accurate bug description other than a link to this thread.

tredegar 03-29-2009 08:36 AM

Quote:

when I alter this command to "ls -l /dev/scd0" on the problem machine I get:
brw-rw----+1 root cdrom 11, 0 2009-03-30 07:27 /dev/scd0
You need to be root or a member of the group cdrom to be able to read/write the dvd
Check your groups membership with the command groups
you should see cdrom listed.

Simon Bridge 03-29-2009 11:34 PM

Quote:

then when I issue command "ls -l /dev/dvd" on the problem machine I get:
ls: cannot access /dev/dvd: No such file or directory

when I alter this command to "ls -l /dev/scd0" on the problem machine I get:
brw-rw----+1 root cdrom 11, 0 2009-03-30 07:27 /dev/scd0
It's what I thought - for some reason the link /dev/dvd did not get created - or was erased by installing another application. AFAIK: the link is a routine part of many default installs. It certainly is for Ubuntu.

You can fix your install by creating the link and making sure it has rwx everywhere permissions. That way, anything else relying on that link will also work.

For your education: try the commands on the non-problem machine. Spot the difference.

It is not this exact failure which needs the bug report. If some procedure has resulted in /dev/dvd being removed or failing to be added then that would be worth a bug report. Trying ta narrow this down would involve starting with a clean install, then reproducing your steps to get a DVD player going - checking for /dev/dvd between each step.

How and where the report is filed depends on which step /dev/dvd vanished at.

Probably a package you installed or removed sometime since the dvd player last worked has been a little too keen on tidying up. This kind of thing can go unnoticed for a long time. Personally, I wouldn't bother

wabbalee 03-30-2009 07:08 PM

To Tredegar: I checked the output of the 'groups' command and 'cdrom' was in it.
I would say that the output of 'ls -l /dev/dvd'
which was: 'brw-rw----+1 root cdrom 11, 0 2009-03-30 07:27 /dev/scd0' on the problem machine
made you think that I could not burn discs, so I tried to burn a data cd and that completed successfully.
I find it hard to interpret outputs of many commands, could you briefly explain the meaning of the differences?
between this one:brw-rw----+1 root cdrom 11, 0 2009-03-30 07:27 /dev/scd0
and this one:lrwxrwxrwx 1 root root 4 2009-03-29 21:32 /dev/dvd -> scd0 (not the problem machine)

To Simon: I can see the difference between the two outputs but don't know how to fix my install, as you put it:
Quote:

You can fix your install by creating the link and making sure it has rwx everywhere permissions. That way, anything else relying on that link will also work.
here's how I install a new system:
first I install Kubuntu.
then I copy all previously saved *.deb files from other Hardy installs into the /var/cache/apt/archives/ directory (that's to save on downloads and gain time in the overall process)
I open the repositories in Adept and install Synaptic package manager.
then I start Synaptic (after closing Adept) and let it run the update on the clean install of Kubuntu.
reboot (new kernel)
then I install (if necessary) proprietary vga drivers (nvidia or ati) and check 3D functionality. Usually everything else that is supposed to work at this stage works out of the box.
Then the next and final step to installing a system, apart from configuring the system a bit here and there, I let Synaptic read a file that has the info of the complete markings (I call it 'savestate') that I created on an already fully functional and up to date system with Synaptic. Hope this is a clear description of this process as I do not know what to call that file.
Before I hit the 'apply' button I quickly go through the list of newly selected packages (using Synaptic's filter) and uncheck the ones that were specific for the source machine (like its proprietary drivers and perhaps some old kernels still installed) and then I sit back and watch it all happen, the only thing it ever asks me is quiet early in this piece and that is to accept Sun's Java agreement. When this is finished I have everything installed that I want on it and everything works (well, up till now it used to).

in short, for me it is very hard to determine what piece of software (if it is any) that causes the havoc I was experiencing. but I will give it a try, I will make a clone image of the system the way it is now with this fantastic program named 'Clonezilla' and start a fresh install of Kubuntu on it and I will purely focus on getting DVD playback to work and see how I go and report my findings here.

Simon Bridge 03-31-2009 12:50 AM

How to figure out a solution from some hackers glib response ;)

You need a link called /dev/dvd which points to your dvd device file.
To do that, you need to know the command for creating a link - find out with "apropos link"

This gives you lots of reading - you want the one which creates links between files. There are several, reading their man pages narrows that to: ln (1) (man ln for details - it only has one page.)

sudo ln /dev/scd0 /dev/dvd

This solves the issue you had in a general context where changing the dvd device in the application solves it for that specific app.

It will be interesting to see if /dev/dvd exists in the default install of kubuntu.

wabbalee 03-31-2009 05:39 AM

another eye opener: when I issued sudo ln /dev/scd0 /dev/dvd on my laptop I got:
Quote:

ln: creating hard link '/dev/scd0': File exists
then when I issue this on the problem machine I get this:
Quote:

ln: accessing '/dev/dvd': No such file or directory
then I checked the /dev directory on the problem machine to look for /dev/dvd and yes it was not there, but there was a link named /dev/dvd1. on my laptop the file was there without the number 1 and so was /dev/dvdrw and /dev/cdrom and /dev/cdrw. these files all had a number 1 at the end of their name on the problem machine, I renamed them all without the number 1 in it. I then went back to the xine engine parameters and changed what I previously did for device for dvd playback from /dev/scd0 back to what it originally was into /dev/dvd.

issued command sudo ln /dev/scd0 /dev/dvd on the problem machine again and I got:
Quote:

ln: creating hard link '/dev/scd0': File exists
then I played a dvd and it magically worked!

now, I don't know if I have upset any other settings or links (or more..) by renaming these 4 links in the /dev directory, I am burning another cd as I am writing this. (completed successfully)

also when I issue the command ls -l /dev/dvd now on the problem machine, which does not seem to have a problem anymore, I get:
Quote:

lrwxrwxrwx 1 root root 4 2009-03-31 16:26 /dev/dvd -> scd0
which is the same as on my laptop.

then Simon says:
Quote:

It will be interesting to see if /dev/dvd exists in the default install of kubuntu.
Yes, it exists and when I issued the previous commands in a freshly installed Kubuntu (I have two identical Dell Precision 370 pc's) that I only just now installed I get all the proper outputs from them without any modification done. after installing the usual packages to get dvd playback support it played dvd's without problems. also after updating with no extra software installed, dvd playback was still ok.

Simon, you have been most helpful, thank you very much!

wabbalee 03-31-2009 06:51 AM

cheered a bit too early, after reboot the links in the /dev directory all 4 had a number 1 at the end of their names again. I changed the xine parameters from '/dev/dvd' to '/dev/dvd1' and dvd playback works again.

wabbalee 03-31-2009 10:10 PM

For clarity: I installed Kubuntu on one of the two Dell systems and that one works good, including all software installed.

I altered the fstab file where Ubuntu places device uuid's, I changed that to say '/dev/sda2', because I have learned that if I don't do that in case I am using this installation as an original for a clone, the clone machine will not boot because drive uuid's don't match.

Then I made a clone with Clonezilla and wrote the clone on the other identical machine.
when this clone boots everything seems ok until I want to play a dvd or audio cd (learned that en passant), it then has problems with the device links.

maybe I should place a new thread with regards to this kind of problems that occur with clones.

Simon Bridge 03-31-2009 11:11 PM

Quote:

issued command sudo ln /dev/scd0 /dev/dvd on the problem machine again and I got:
Code:

ln: creating hard link '/dev/scd0': File exists

Hmm ... maybe I got that the wrong way around. Lets see - man ln says:

ln [OPTION]... [-T] TARGET LINK_NAME (1st form)
In the 1st form, create a link to TARGET with the name LINK_NAME.

... which is what we want.

The -T option means:

-T, --no-target-directory
treat LINK_NAME as a normal file

... so we don't need it.

sudo ln /dev/scd0 /dev/test

where /dev/test does not previously exist, works fine on my (Ubuntu) system.

If I repeat it:
~$ sudo ln /dev/scd0 /dev/test
ln: creating hard link `/dev/test': File exists

This suggests that you have accidentally typed your's the wrong way around.
i.e. it is telling you that link /dev/scd0 already exists and that the target /dev/dvd does not. This is correct. But you want the target to be /dev/scd0 and the link to be /dev/dvd. See?
Double-check.

Your DVD suddenly worked - suggesting that one of your attempts actually created the link. It stopped working as something like udev overrode your alterations - do you have more than one playback device in the machine?

Maybe, as you say, this is a problem with cloning ... perhaps udev in the clone has noticed that it is seeing different hardware (from what it was cloned from). udev associates persistent filenames - so the new hardware gets called /dev/dvd1 etc. If you physically exchange dvd drives, you may find /dev/dvd comes back.


Quote:

I altered the fstab file where Ubuntu places device uuid's, I changed that to say '/dev/sda2', because I have learned that if I don't do that in case I am using this installation as an original for a clone, the clone machine will not boot because drive uuid's don't match.
... the uuids are assigned to the device by the OS - they are not a property of the device. You should be able to clone OK without changing to dev notation. I think some programs in Ubuntu may be expecting uuid notation - to assign devide names for eg.

However, I've only done a clone of Ubuntu and only for one computer (acer aspire 4315). I did not change anything on fstab and the clone seems to move between different machines OK.

Have you tried doing the clone without otherwise changing anything?


All times are GMT -5. The time now is 09:36 AM.