-   Linux - Software (
-   -   Command Prompt Screen (

Raevyn 11-14-2010 12:03 PM

Command Prompt Screen

Okay I am curious if anyone knows how to get this screen? I remember having it a while ago before I had to go to windows, and now that I am going back to Linux I would LOVE to have this screen back! I enclosed a screen shot picture. I think its way better than just a blinking cursor.

AlucardZero 11-14-2010 12:24 PM

press ctrl+alt+f1?

Raevyn 11-14-2010 12:42 PM

That is to switch between the various command shells and KDE (or GNOME or whatever I think X windows you are using) right? That doesnt seem to work for me but I can get to the command screen by shutting down the graphics login. What I get a black screen with some lines but no fun graphics or anything like what is in my picture. Here I will screen shot it for you from VMware as to what i get now. Hopefully that helps?

catkin 11-14-2010 12:53 PM

Normally ctrl+alt+F1, F2 etc. switch from the graphical screen to a virtual terminal as you want. The virtual terminals are started by /etc/inittab so if it doesn't work for you they may not be enabled there. Please post the contents of your /etc/inittab.

Raevyn 11-14-2010 01:38 PM

okay.. here it is. Will this help get that customized command boot screen back as well?

# inittab This file describes how the INIT process should set up
# the system in a certain run-level.
# Author: Miquel van Smoorenburg, <>
# Modified for RHS Linux by Marc Ewing and Donnie Barnes

# Default runlevel. The runlevels used by Mandriva Linux are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)

# System initialization.

l0:0:wait:/etc/rc.d/rc 0
l1:1:wait:/etc/rc.d/rc 1
l2:2:wait:/etc/rc.d/rc 2
l3:3:wait:/etc/rc.d/rc 3
l4:4:wait:/etc/rc.d/rc 4
l5:5:wait:/etc/rc.d/rc 5
l6:6:wait:/etc/rc.d/rc 6

ca::ctrlaltdel:/sbin/shutdown -t3 -r now

# When our UPS tells us power has failed, assume we have a few minutes
# of power left. Schedule a shutdown for 2 minutes from now.
# This does, of course, assume you have powerd installed and your
# UPS connected and working correctly.
pf::powerfail:/sbin/shutdown -f -h +2 "Power Failure; System Shutting Down"

# If power was restored before the shutdown kicked in, cancel it.
pr:12345:powerokwait:/sbin/shutdown -c "Power Restored; Shutdown Cancelled"

# Run gettys in standard runlevels
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3
4:2345:respawn:/sbin/mingetty tty4
5:2345:respawn:/sbin/mingetty tty5
6:2345:respawn:/sbin/mingetty tty6

# Single user mode

AlucardZero 11-14-2010 02:27 PM

So you're looking for the penguin logo?

Looks like someone just made a fancy /etc/issue which is then displayed on your virtual terminals.

Raevyn 11-14-2010 07:42 PM

<nods> mhm I would like that same start screen. It used to be on one of the distributions I tried a while back but I dont remember which one. But "catkin" was also saying that something in my file might be the cause of my inability to switch between the various screens too?

grim76 11-14-2010 07:46 PM

The screenshot has Mandrake in the name on the line that gives the kernel version.

Not sure if Mandrake still does that or not. Have never tried their distribution.

Raevyn 11-14-2010 07:51 PM

realy? I cant see anything like that...

Raevyn 11-14-2010 07:53 PM

oh but that helped! I did a search and found it called Linux Logo which is like.. really? I should have guessed that! SO I will see if it is still available.

Oh if anyone cares its webpage is:

catkin 11-14-2010 07:58 PM

Unfortunately those "# Run gettys in standard runlevels" lines look OK. I was hoping there might be a fixable problem there. You could check whether they are effective with ps -ef | grep mingetty. If that shows them running then you could start a new thread to ask about alt+shift+F1 etc not working.

AlucardZero 11-14-2010 08:27 PM

@catkin from his second screenshot, he is able to get to VTYs. He just wants the pretty ascii colored penguin.

All times are GMT -5. The time now is 08:07 AM.