-   Linux - Software (
-   -   Command "mail" returns "panic: temporary file seek" (

kenneho 12-22-2008 07:43 AM

Command "mail" returns "panic: temporary file seek"
Hello all.

One of our RHEL 4.2 servers is behaving very strange. Consider this:


[root@server1 /tmp]# mail
Mail version 8.1 6/6/93.  Type ? for help.
"/var/spool/mail/root": 446711 messages 276778 new 446711 unread
fseek: Invalid argument
panic: temporary file seek
Avbrutt (SIGABRT)

I run a simple command such as "mail", and it returns a fseek error. It's running on Vmware ESX, and I have no indicating that there is a hardware failure. Does anyone know where to even start debugging this thing?


repo 12-22-2008 07:52 AM

AFAIK it has to do with large mailboxes.
Try mutt to see if you can access the mailbox

kenneho 12-23-2008 02:30 AM

Mutt worked just fine. Seems like all of the mails are just debug stuff. Can I simply remove the file /var/spool/mail/root to get rid of the mails? Or do I have to re-create an empty version the file.

repo 12-23-2008 02:35 AM

you can do
cat /dev/null > /var/spool/mail/root

kenneho 12-23-2008 03:03 AM

Thanks, I'll give it a try as soon as I get the chance. And I'll report back here the results.

kenneho 12-23-2008 03:27 AM

I worked like a charm. Thank you for your help.

I was worried that the fseek error would imply something seriously wrong with the file system or hardware, so I'm happy it was just this small thing.

All times are GMT -5. The time now is 11:03 AM.