LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   Command line install issues, regarding missing libs. (https://www.linuxquestions.org/questions/linux-software-2/command-line-install-issues-regarding-missing-libs-834605/)

rohanvr_21 09-26-2010 02:14 PM

Command line install issues, regarding missing libs.
 
Hey, I'm new here... correct me if I missed out on some rules...

I had been trying to convert a video from .avi to .mpg using the ffmpeg command, when I encountered an error regarding some filters that could not be loaded.A bit of search on Google told me I'd need a complete mplayer setup. Well the real problem starts after this:
I tried yum update mplayer, but this gave me a dependency error regarding missing vlc core libs, so I tried updating vlc but got the same error...
I removed both vlc and mplayer thinking a reinstall of both might help, but got the same missing lib error on trying to install either of them again... I thought of updating gnome using the yum update @gnome-desktop command but still got the same error, so basically anything I try to update or install from the terminal gives me this error:

Quote:

[Rohan@Rohan ~]$ su
Password:
[root@Rohan Rohan]# yum install vlc
Loaded plugins: fastestmirror, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
* fedora: fedoramirror.hnsdc.com
* livna: wftp.tu-chemnitz.de
* rpmfusion-free: mirrors.163.com
* rpmfusion-free-rawhide: mirrors.163.com
* rpmfusion-free-updates: mirrors.163.com
* rpmfusion-nonfree: mirrors.163.com
* rpmfusion-nonfree-updates: mirrors.163.com
* updates: ftp.jaist.ac.jp
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package vlc.x86_64 0:1.1.4-2.fc14 set to be installed
--> Processing Dependency: vlc-core(x86-64) = 1.1.4-2.fc14 for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: qt4(x86-64) >= 4.7.0 for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libz.so.1(ZLIB_1.2.3.3)(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcxcore.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libprojectM.so.2.0.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcv.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libhighgui.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libml.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcvaux.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libvlccore.so.4()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Running transaction check
---> Package libprojectM.x86_64 0:2.0.1-7.fc13 set to be installed
--> Processing Dependency: bitstream-vera-sans-fonts for package: libprojectM-2.0.1-7.fc13.x86_64
--> Processing Dependency: bitstream-vera-sans-mono-fonts for package: libprojectM-2.0.1-7.fc13.x86_64
--> Processing Dependency: libftgl.so.2()(64bit) for package: libprojectM-2.0.1-7.fc13.x86_64
---> Package vlc.x86_64 0:1.1.4-2.fc14 set to be installed
--> Processing Dependency: qt4(x86-64) >= 4.7.0 for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libz.so.1(ZLIB_1.2.3.3)(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcxcore.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcv.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libhighgui.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libml.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcvaux.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
---> Package vlc-core.x86_64 0:1.1.4-2.fc14 set to be updated
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libz.so.1(ZLIB_1.2.0.2)(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libmatroska.so.2()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libmodplug.so.1()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libproxy.so.1()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libebml.so.2()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libx264.so.102()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Running transaction check
---> Package bitstream-vera-sans-fonts.noarch 0:1.10-18.fc12 set to be installed
--> Processing Dependency: bitstream-vera-fonts-common = 1.10-18.fc12 for package: bitstream-vera-sans-fonts-1.10-18.fc12.noarch
---> Package bitstream-vera-sans-mono-fonts.noarch 0:1.10-18.fc12 set to be installed
---> Package ftgl.x86_64 0:2.1.3-0.3.rc5.fc13 set to be installed
---> Package vlc.x86_64 0:1.1.4-2.fc14 set to be installed
--> Processing Dependency: qt4(x86-64) >= 4.7.0 for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libz.so.1(ZLIB_1.2.3.3)(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcxcore.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcv.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libhighgui.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libml.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcvaux.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
---> Package vlc-core.x86_64 0:1.1.4-2.fc14 set to be updated
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libz.so.1(ZLIB_1.2.0.2)(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libmatroska.so.2()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libmodplug.so.1()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libproxy.so.1()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libebml.so.2()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libx264.so.83()(64bit) for package: gstreamer-plugins-ugly-0.10.15-1.fc13.x86_64
--> Processing Dependency: libx264.so.83()(64bit) for package: mencoder-1.0-0.117.20100703svn.fc13.x86_64
--> Processing Dependency: libx264.so.83()(64bit) for package: ffmpeg-libs-0.6-2.fc13.x86_64
---> Package x264-libs.x86_64 0:0.0.0-0.28.20100706gitd058f37.fc14 set to be updated
--> Running transaction check
---> Package bitstream-vera-fonts-common.noarch 0:1.10-18.fc12 set to be installed
---> Package ffmpeg-libs.x86_64 0:0.6-4.20100704svn.fc14 set to be updated
--> Processing Dependency: librtmp.so.0()(64bit) for package: ffmpeg-libs-0.6-4.20100704svn.fc14.x86_64
--> Processing Dependency: libva-0.31.1.1.so.1()(64bit) for package: ffmpeg-libs-0.6-4.20100704svn.fc14.x86_64
---> Package gstreamer-plugins-ugly.x86_64 0:0.10.16-1.fc14 set to be updated
---> Package mencoder.x86_64 0:1.0-0.119.20100703svn.fc14 set to be updated
--> Processing Dependency: mplayer-common = 1.0-0.119.20100703svn.fc14 for package: mencoder-1.0-0.119.20100703svn.fc14.x86_64
---> Package vlc.x86_64 0:1.1.4-2.fc14 set to be installed
--> Processing Dependency: qt4(x86-64) >= 4.7.0 for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libz.so.1(ZLIB_1.2.3.3)(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcxcore.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcv.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libhighgui.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libml.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcvaux.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
---> Package vlc-core.x86_64 0:1.1.4-2.fc14 set to be updated
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libz.so.1(ZLIB_1.2.0.2)(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libmatroska.so.2()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libmodplug.so.1()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libproxy.so.1()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libebml.so.2()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Running transaction check
---> Package librtmp.x86_64 0:2.3-2.fc14 set to be installed
---> Package libva-freeworld.x86_64 0:0.31.1-1.sds4.fc14 set to be installed
---> Package mplayer-common.x86_64 0:1.0-0.119.20100703svn.fc14 set to be updated
---> Package vlc.x86_64 0:1.1.4-2.fc14 set to be installed
--> Processing Dependency: qt4(x86-64) >= 4.7.0 for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libz.so.1(ZLIB_1.2.3.3)(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcxcore.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcv.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libhighgui.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libml.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
--> Processing Dependency: libcvaux.so.2.1()(64bit) for package: vlc-1.1.4-2.fc14.x86_64
---> Package vlc-core.x86_64 0:1.1.4-2.fc14 set to be updated
--> Processing Dependency: libstdc++.so.6(GLIBCXX_3.4.14)(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libz.so.1(ZLIB_1.2.0.2)(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libmatroska.so.2()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libmodplug.so.1()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libproxy.so.1()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Processing Dependency: libebml.so.2()(64bit) for package: vlc-core-1.1.4-2.fc14.x86_64
--> Finished Dependency Resolution
Error: Package: vlc-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libml.so.2.1()(64bit)
Error: Package: vlc-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libcvaux.so.2.1()(64bit)
Error: Package: vlc-core-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libz.so.1(ZLIB_1.2.0.2)(64bit)
Error: Package: vlc-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libhighgui.so.2.1()(64bit)
Error: Package: vlc-core-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libproxy.so.1()(64bit)
Error: Package: vlc-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libcxcore.so.2.1()(64bit)
Error: Package: vlc-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: qt4(x86-64) >= 4.7.0
Installed: 1:qt-4.6.3-8.fc13.x86_64 (@updates)
qt4(x86-64) = 4.6.3-8.fc13
Available: 1:qt-4.6.2-16.fc13.x86_64 (fedora)
qt4(x86-64) = 4.6.2-16.fc13
Error: Package: vlc-core-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libstdc++.so.6(GLIBCXX_3.4.14)(64bit)
Error: Package: vlc-core-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libmodplug.so.1()(64bit)
Error: Package: vlc-core-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libebml.so.2()(64bit)
Error: Package: vlc-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libcv.so.2.1()(64bit)
Error: Package: vlc-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libz.so.1(ZLIB_1.2.3.3)(64bit)
Error: Package: vlc-core-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libmatroska.so.2()(64bit)
Error: Package: vlc-1.1.4-2.fc14.x86_64 (rpmfusion-free-rawhide)
Requires: libstdc++.so.6(GLIBCXX_3.4.14)(64bit)
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest
I'm running fedora 13.
Help me get this issue sorted please.

P.S. I've been a regular forum member before and I know how irritating it is if someone asks repeated questions... So If I've miss missed out on a similar thread, Ive tried my bit searching, please be patient and point me to it...
Cheers :)

alunduil 09-26-2010 03:49 PM

Can you also give us the output of `yum repolist`?

Regards,

Alunduil

knudfl 09-26-2010 05:18 PM

Quote:

* rpmfusion-free-rawhide: mirrors.163.com
This one from your listing in post # 1 must be disabled.
Is for Fedora 14 only, and the vlc from this development repo
requires dependencies only available on Fedora 14.

su
gedit /etc/yum.repos.d/rpmfusion-free-rawhide.repo
.... and please edit to : enabled=0
....

John VV 09-26-2010 05:37 PM

then after you disable the TESTING ONLY "rawhide"
rawhide is the NEXT version of fedora and is NOT released for the general public use


check your fedora 13 64 bit ??? i think that is what you have installed ?????

CHECK YOUR SYSTEM !!!!!!!! to see if there are any fedora 14 rpms on it ( they can AND will kill fedora 13 )
Code:

rpm -qa | grep fc14
and UNINSTALL ALL of them if any
then rebuild the yum database to REMOVE the entries for fedora 14
Code:

su -
yum clean all
rpm --rebuilddb
yum update

then AND ONLY THEN once you have a CLEAN fedora 13 install
see dangermouses help page for ffmpg conversion, guides
http://www.dnmouse.org/
http://dnmouse.org/forum/
http://dnmouse.org/forum/viewforum.php?f=3
and his VERY useful "autoten" script
http://dnmouse.org/forum/viewforum.p...e09f5921221021

rohanvr_21 09-27-2010 01:36 PM

Thanks for your help guys,.. Got my problem solved :D :)

When John VV and knudfl pointed out the rawhide rpm problem to me, I remembered selecting it in the software managment section... lol never expected it to cause such issues....

@ alunduil the repo list op is this

Code:

[Rohan@Rohan ~]$ su
Password:
[root@Rohan Rohan]# yum repolist
Loaded plugins: fastestmirror, presto, refresh-packagekit
Loading mirror speeds from cached hostfile
 * fedora: fedoramirror.hnsdc.com
 * livna: wftp.tu-chemnitz.de
 * rpmfusion-free: mirror.cse.iitk.ac.in
 * rpmfusion-free-updates: mirror.cse.iitk.ac.in
 * rpmfusion-nonfree: mirror.cse.iitk.ac.in
 * rpmfusion-nonfree-updates: mirror.cse.iitk.ac.in
 * updates: fedoramirror.hnsdc.com
repo id                    repo name                                      status
adobe-linux-i386          Adobe Systems Incorporated                        18
fedora                    Fedora 13 - x86_64                            20,840
livna                      rpm.livna.org for 13 - x86_64                      3
rpmfusion-free            RPM Fusion for Fedora 13 - Free                  457
rpmfusion-free-updates    RPM Fusion for Fedora 13 - Free - Updates        514
rpmfusion-nonfree          RPM Fusion for Fedora 13 - Nonfree                156
rpmfusion-nonfree-updates  RPM Fusion for Fedora 13 - Nonfree - Updates      129
updates                    Fedora 13 - x86_64 - Updates                    6,831
repolist: 28,948
[root@Rohan Rohan]#

though i dont think it'll be needed now...
thanks a lot again guys
cheers :)

and yeah ill check out those conversion guides..


All times are GMT -5. The time now is 03:28 PM.