-   Linux - Software (
-   -   Codecs,Encoders,Drivers? (

ekel 06-30-2005 12:07 AM

Well I have recently just installed Gentoo, and Gnome. Most things run alright with the exception of certain issues.

1.) I tried to run CD Player, but it crashed :/.

2.) I tried to run Audacity, but it said i was unable to encode or play music.

3.) I tried to play " Super Tux " , but it just opens and closes really quickly with a black screen.

4.) I tried to run Totem, but it also crashed just like CD Player.

Im pretty sure I need some sort of module or driver, but im not sure what.. I downloaded LimeWire and listened to a few songs alright, but Im not sure about why I wouldnt be able to encode or play music on the Sound Recorder or Audacity.

I have a ac97 Audio Codec sound driver, an SIS 32mb ( model: 650? ) video card, a p4 processor with 2.4 gigs and 512 ram.

Could someone please help me?:(

tremend0us 06-30-2005 05:22 AM

As you suggested, it might have something to do with missing codecs. Here is something related to it for Fedora 4 - I think your problem might be similar.

(I've edited the post because I just ran into it and realized it was a harsh answer and the answer wasn't even that good. In any case, try searching a bit more in depth and reading this.)

motub 07-05-2005 11:11 AM

As a fello Gentoo user, my first guess would be that you've missed out kernel support for your motherboard's chipset --you're using onboard sound, right? You may have missed out other stuff as well (I suspect you have no OpenGL support), but since most of the applications you've mentioned rely on sound even before graphic support, I'd think that's the first issue. In any case, one problem at a time :) .

Please post the output of the following 3 commands (in a terminal as root):

# uname -a

# lspci

# lsmod

Basically, we need to know what kernel, what hardware, and what drivers for what hardware is actually loaded. Any error messages that you see in dmesg at boot would be useful, too.


All times are GMT -5. The time now is 05:00 AM.