LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-23-2009, 11:36 AM   #1
Muideen
LQ Newbie
 
Registered: Mar 2009
Posts: 15

Rep: Reputation: 0
Question code to install php5.1.2 using yum on fedora 9


Please can someone give me the code to install php5.1.2 on fedora 9 using yum
 
Old 03-23-2009, 12:54 PM   #2
sarin
Member
 
Registered: May 2001
Location: India, Kerala, Thrissur
Distribution: FC 7-10
Posts: 354
Blog Entries: 2

Rep: Reputation: 34
I don't know if f9 uses php 5.1.2. But, if you just want to install php, use "yum -y install php". If you want a specific version, try to get the rpm for that version and try "yum localinstall <downloaded.rpm>"
 
Old 03-24-2009, 07:31 PM   #3
JaksoDebr
Member
 
Registered: Mar 2009
Distribution: Fedora, Slackware
Posts: 104

Rep: Reputation: 21
Even Fedora 8 is using php 5.2.6 already, so Fedora 9 should have a problem with that. The previous posting has all the needed info. I just wonder what causes the need for an older php version? It is usual to make a distinction between php4 and php5 for compatibility reasons with older scripts, but it's quite uncommon to go for an outdated version within the php5 branch.

Linux Archive

Last edited by JaksoDebr; 04-02-2009 at 06:19 AM.
 
Old 03-24-2009, 07:56 PM   #4
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,465

Rep: Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605
well WTF happened to my post here .
If for some very strange reason you must use a OLD , VERY OLD version of php5 --- this begs the question Why
you MUST build that version from the old source code
the current version of php in the fedora 9 repo's is 5.2.6
so
Code:
yum install php
will install php 5.2.6

grab it from cvs
http://us2.php.net/anoncvs.php
Code:
 cvs -d :pserver:cvsread@cvs.php.net:/repository checkout -r PHP_5_1 php5
 
Old 03-26-2009, 02:36 PM   #5
Muideen
LQ Newbie
 
Registered: Mar 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Well guys, I was only trying to install VTigerCRM, but the installation gets to a point that it tries to install php5.1.2, and later gives an error stating that an error was encountered while installing php5.1.2, setup cannot continue. So that makes me feel the VTiger app may be running on php5.1.2 and not the latest because I have used yum to install the latest version of php on my box. So what do u guys think?
 
Old 03-26-2009, 03:12 PM   #6
Muideen
LQ Newbie
 
Registered: Mar 2009
Posts: 15

Original Poster
Rep: Reputation: 0
Well guys, I was only trying to install VTigerCRM, but the installation gets to a point that it tries to install php5.1.2, and later gives an error stating that an error was encountered while installing php5.1.2, setup cannot continue. So that makes me feel the VTiger app may be running on php5.1.2 and not the latest because I have used yum to install the latest version of php on my box. So what do u guys think?
 
Old 03-26-2009, 03:36 PM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,465

Rep: Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605Reputation: 2605
seeing as "VTigerCRM" has not been updated in over a year . I would look into using something else
http://www.vtiger.com/index.php?opti...d=30&Itemid=57

what do you need to have running on a crm . I have had no issues with " geeklog"
but i was not using the sales ( credit card or paypal,... ) modules
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
php4 to php5.2 breaks old code? bad_gui Programming 1 03-04-2008 08:34 PM
having problem in porting php4 code to php5 in sessions mohtasham1983 Programming 3 04-10-2007 03:56 AM
Can't install Yum Extender on Fedora Core 5 tron_thomas Linux - Software 2 11-02-2006 02:27 PM
problems with yum install (fedora core 5) emu103 Linux - Desktop 5 08-16-2006 09:55 PM
PHP5 yum repos? (FC1/2) neocookie Fedora 2 07-29-2005 06:21 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 06:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration