LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-29-2010, 09:29 PM   #1
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 412

Rep: Reputation: 31
cmake configure error


Code:
KDE4_KDECONFIG_EXECUTABLE-NOTFOUND
google doesn't give me a sensible answer.
 
Old 12-29-2010, 09:39 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
Does your system have a kde4-config executable?
Code:
[andrew@andrew-msi ~]$ ls -al /usr/bin/kde4-config
-rwxr-xr-x 1 root root 26584 Dec  2 16:51 /usr/bin/kde4-config
 
1 members found this post helpful.
Old 12-31-2010, 12:29 AM   #3
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 412

Original Poster
Rep: Reputation: 31
yeah i eventually traced it to some bug that looks for /usr/bin/kde-config instead of /usr/bin/kde4-config... im further hammering out the kde backends to get kde 4.5 started building.
 
Old 12-31-2010, 02:13 AM   #4
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
Quote:
Originally Posted by ninja master View Post
yeah i eventually traced it to some bug that looks for /usr/bin/kde-config instead of /usr/bin/kde4-config... im further hammering out the kde backends to get kde 4.5 started building.
It couldn't hurt to create a link.

Code:
ln -s /usr/bin/kde4-config /usr/bin/kde-config
 
1 members found this post helpful.
Old 01-03-2011, 10:13 AM   #5
ninja master
Member
 
Registered: May 2008
Distribution: funtoo/gentoo amd64 xwrt
Posts: 412

Original Poster
Rep: Reputation: 31
im pretty sure the symlink is what i used to fix the issue... how ever i have another problem right next to the old....

Code:
KDE4_DATA_DIR-NOTFOUND
 
Old 01-06-2011, 07:14 AM   #6
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 311Reputation: 311Reputation: 311Reputation: 311
You might want to look in the configure.log and find some option to pass to set the data directory:
Code:
KDE4_DATA_DIR:PATH=/usr/share/apps
If you need more help, post the configure.log.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
cmake: Using find_package(Boost) when FindBoost.cmake is not in the default location damien_d Programming 3 10-27-2010 04:40 PM
Tool to convert configure.ac into CMake baudolino Programming 3 02-18-2010 11:30 AM
[SOLVED] Cmake error ~sHyLoCk~ Slackware 10 12-07-2009 02:00 PM
CMAKE error, some help needed here! Rasmus Linux - Software 1 10-26-2009 10:35 AM
PBuilder error after cmake Patrick793 Linux - Software 0 10-13-2008 06:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 09:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration