LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (https://www.linuxquestions.org/questions/linux-software-2/)
-   -   clueless (https://www.linuxquestions.org/questions/linux-software-2/clueless-45460/)

ddrumguy 02-15-2003 12:00 AM

clueless
 
Totally new to linux.

Have 2 problems with my fresh redhat 8 installation

1. machine will not boot from hard drive. Boots fine from floppy. I have fdisk'd the mbr (through linux) and have also reinstalled boot loader (grub). Drive had ntfs filesystem before .

2. I accidentally downloaded the src for xmms-mp3 meant to grab the rpm. now whenever i try to install any package it wont install. If i try to see packages on the system it reads headers and then disappears - never showing me the packages that are on the machine.

help?
Thanks!:Pengy:

Allen614 02-15-2003 07:38 AM

1. What's the Boot Sequence in your BIOS?
2. How are you trying to see the packages on the machine?

ddrumguy 02-15-2003 07:56 AM

I am having trouble getting into the bios for some reason - it is a gatewway machine with a amd athlon 950 mhz. it appears to be floppy/cdrom/hda

if i recall - (i am not at the computer right now) i clicked on the red hat in lower left corner (start button?) and then i think it was either system tools/packages or preferences packages?

this used to work, where it would show me all the packages installed on the machine

Allen614 02-15-2003 09:02 AM

Lets fix the first one first. I haven't worked on a Dell in a while but F1-F4 or Del (one of those 5) will get you into the BIOS. What error do you get when you boot without the floppy? Boot RH from your floppy and from a root terminal run:

/sbin/grub-install /dev/hda1

http://www.redhat.com/docs/manuals/l...e/ch-grub.html

ddrumguy 02-15-2003 09:05 AM

I think i have done that command

when i boot from floppy it gives me an option to pass parms to the linux kernel or wait 10 seconds and it will boot from the floppy.

Hang on a sec and i will go run the command again and reboot to see how I fair. I'll be right back.....

ddrumguy 02-15-2003 09:13 AM

just did the command and it still comes up with
"Reboot and select proper boot device"

ddrumguy 02-15-2003 09:17 AM

Have also read the doc (link that you sent)

is there a way to see if I am even getting to the stage1 .. at this point I don't even think I am hitting the mbr (where this is supposedly installed)

ddrumguy 02-15-2003 09:38 AM

finally got into my bios (F1) and noticed that there is an error in one of my machines logs saying that the cmos options are not set, must of lost my cmos settings . Now to figure out how to do that ... been awhile (like 2 years).......
I'm off to gateway's site to see if i can find this out

Allen614 02-15-2003 09:55 AM

Here's an excellent read. It's so good I bought the book.

http://wwwacs.gantep.edu.tr/linux/rute/

Check out Section 3.3

ddrumguy 02-15-2003 10:28 AM

Great Book. I will definately pick it up

In looking in my bios - when i go to look at the hard drive none is listed
also everything is aet to auto-detect (the only thing currently detected drive wise is the cdrom) my hard drive is set as master - maybe setting it to cable select is the next best choice - i will also try unplugging the cdrom to try to isolate.

stay tuned

ddrumguy 02-15-2003 10:38 AM

YAH -muthaf*&(*&king HOOOO !!!!!!

I found it !

the drive needed to be on cable select although it is on a different bus than the cdrom there apparently is some conflict there (perhaps the cdrom is also master - will need to chek this.

THANK YOU THANK YOU THANK YOU !!!!!!!!
for giving me idea's on things to check.... I was thinking that maybe my bios was corrupt somehow and turns out it was a stinkin cable setting! gawd i love%hate computers. I'm so happy I could run around in the 10 inches of snow we just got this morning - not really .... I hate snow. i need to move to Texas !

ddrumguy 02-15-2003 10:38 AM

any thoughts on the package issue?

Allen614 02-15-2003 11:05 AM

Yea,once you go through one of those problems you never forget again. If you ever install another harddrive you might have to repin it (some HDDs don't play well with others) but your up and running. I have a copy of RH 8 coming but haven't seen the GUI. I ran Mandrake for a while and it's rpm based too. You might try in a root terminal. "rpm --rebuilddb" and then check it again but I always used this link for RPMs.
http://www.rpm.org/

It's not much better here. It's not snowing yet but the way it looks outside it could any minute.

ddrumguy 02-15-2003 12:23 PM

rather than waste time dinking with it, i decided to just reinstall the os (since i have probably done it at least 5 times now,,, hahahaha ) works like a champ now !

man i have got to go buy a linux book and soon

far different world than windoz (thank GOD )

Thanks MUCHO for all of your help !

now to go figure out why apache didn't start on my other box... yep it never ends;)


All times are GMT -5. The time now is 05:04 AM.