Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 02-05-2009, 03:03 PM   #1
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 564

Rep: Reputation: Disabled
Clients Cannot Find Network Scanner

I currently have a network with an older machine, which is (usually) operated in headless mode as a data & backup server, with a fixed IP of I have two client machines, a desktop & a laptop, which use DHCP. All three computers are running Slackware-12.2, the clients with a full install & the server without any X components.
I want to set the server to serve a scanner & have been following this link, which is mostly a rewrite of the man page for sane.d. I set up saned per the article, adding the saned:saned user. 'scanimage -L' works for both root & my local user on the server. I can ssh into the server as my desktop user & 'scanimage -L' works. Ditto if I ssh into the server, then 'su -' to root. I can scan either locally from the server or via ssh from the desktop machine. BUT, I cannot get the scanner recognized on the network.
On the server, I have this line in /etc/sane.d/saned.conf:
this line in /etc/services:
sane-port  6566/tcp  #SANE network scanner daemon
& this line in /etc/inetc.conf:
sane-port  stream  tcp  nowait saned:saned /usr/sbin/saned saned
I have changed the line in /etc/sane.d/saned.conf to just "+", for testing. That didn't work either.
On the clients, I have these two uncommented lines in /etc/sane.d/net.conf:
connect_timeout = 60
My desktop user is in these groups:
users lp wheel floppy audio video cdrom plugdev power scanner data vboxusers
My server user is in the same groups, less vboxusers.
The server is identified in /etc/hosts & I can connect to it via ssh & mount nfs shares from it. What am I (not) doing that is killing network scanning?

Last edited by TSquaredF; 02-05-2009 at 03:04 PM.
Old 02-05-2009, 04:24 PM   #2
LQ 5k Club
Registered: Aug 2005
Distribution: OpenSuse, Fedora, Redhat, Debian
Posts: 5,399
Blog Entries: 2

Rep: Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908Reputation: 908
Well, I don't actually know squat about the sane service specifically, but here's one place to start, which should be an easy test. The sane server is supposed to be listening on port 6566, so I would try making a tcp connection to the server using netcat (nc) from one or more of your client hosts. If netcat can make a connection, then at least you know that something is listening on that port. If so, turn off the daemon, and see if a connection can still be made. If no connection can then be made, then you've pretty well established that the network side is okay, and that the server daemon is listening on the correct port. If netcat is still able to connect, then it probably indicates that some other process has already grabbed that port, and you can use lsof to track down what the process is (actually, maybe that is a good pace to start, too).
If the server is failing to listen on the port, I would look into SELinux and/or an iptables firewall as the culprit(s).
Consult the lsof and netcat manpages for details on how to use them.
--- rod.
Old 02-07-2009, 01:10 PM   #3
Registered: Dec 2005
Location: "The South Coast of Texas"
Distribution: Slackware64-current
Posts: 564

Original Poster
Rep: Reputation: Disabled
Re: theNbomr's post, above

I did use netcat to check the servers port, 6566. It is open when the sane-port line in inetd.conf is uncommented & closed when the line is commented out. I also uncommented the line "localhost" in /etc/sane.d/net.conf. I then ran:
scanimage -f "scanner number %i device %d is a %t, model %m, produced by %v"
which gave me this output:
scanner number 0 device epson2:libusb:001:003 is a flatbed scanner, model GT-9300, produced by Epson
scanner number 1 device net:localhost:epson2:libusb:001:003 is a flatbed scanner, model GT-9300, produced by Epson
so the network backend is also working on the localhost.
The manpage/How-Tos say that the only modification needed on the client is to add the host name/IP address to /etc/sane.d/net.conf. I have tried all variations of host name/IP address to no avail. Anyone have any ideas?
Old 02-12-2009, 02:12 PM   #4
Senior Member
Registered: Dec 2005
Distribution: Slackware
Posts: 1,134

Rep: Reputation: 277Reputation: 277Reputation: 277
I had the same problem, and it took me some hair pulling to figure it out:

You're going to love the solution....

Add the user 'saned' to the 'scanner' group


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to distribute Network bandwidth between Network clients dynamically ? p_s_shah Linux - Server 1 02-27-2008 10:31 AM
Can I have a network w/ a Linux Server & Linux clients & a few MSFT Windows clients bhowerton Linux - Networking 1 04-21-2007 01:45 AM
How to find out which clients are connected to a WLAN ozymandias Linux - Wireless Networking 2 12-09-2006 04:55 AM
Is there a scanner software that can be used for thin clients? banner Linux - General 1 08-14-2005 12:49 PM
sane over network - can't find scanner Smerk Linux - Networking 1 07-18-2004 04:56 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:58 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration