LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-31-2017, 08:41 PM   #1
swamprat
Member
 
Registered: Sep 2005
Location: New Jersey, USA
Distribution: Centos 7 , Linux Mint 18.1 Under VMware in Win7
Posts: 542

Rep: Reputation: 34
Clantk on CentOS 7


Can Clamtk be installed and work on CentOS 7 ?

I have it working on CentOS 6 but can't seem to get it working on 7 due to Perl @INC issues.

Thanks

Last edited by swamprat; 01-31-2017 at 08:42 PM.
 
Old 01-31-2017, 09:01 PM   #2
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
What errors or complaints is Centos 7 giving you?
You may be missing libraries.

What exactly is the message about Perl @INC issues?
 
Old 02-02-2017, 10:36 PM   #3
swamprat
Member
 
Registered: Sep 2005
Location: New Jersey, USA
Distribution: Centos 7 , Linux Mint 18.1 Under VMware in Win7
Posts: 542

Original Poster
Rep: Reputation: 34
Please check the output below and perhaps you can identify what's wrong here. Thanks


[root@localhost Downloads]# yum upgrade perl
Loaded plugins: fastestmirror, langpacks, priorities
Loading mirror speeds from cached hostfile
* base: mirror.math.princeton.edu
* epel: mirror.vcu.edu
* extras: chicago.gaminghost.co
* remi-php71: repo1.ash.innoscale.net
* remi-safe: repo1.ash.innoscale.net
* updates: centos.mirror.constant.com
332 packages excluded due to repository priority protections
No packages marked for update


root@localhost Downloads]# rpm -ivh clamtk-5.20-1.el7.noarch.rpm
error: Failed dependencies:
perl(Digest::SHA) is needed by clamtk-5.20-1.el7.noarch
perl(Glib) is needed by clamtk-5.20-1.el7.noarch
perl(Gtk2) is needed by clamtk-5.20-1.el7.noarch
perl(Gtk2) >= 1.248 is needed by clamtk-5.20-1.el7.noarch
perl(Gtk2::Gdk::Keysyms) is needed by clamtk-5.20-1.el7.noarch
perl(LWP::Protocol::https) is needed by clamtk-5.20-1.el7.noarch
perl(Locale::gettext) is needed by clamtk-5.20-1.el7.noarch
perl(Text::CSV) is needed by clamtk-5.20-1.el7.noarch
perl(Time::Piece) is needed by clamtk-5.20-1.el7.noarch
 
1 members found this post helpful.
Old 02-02-2017, 11:47 PM   #4
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
All of those failed dependencies are required in order for Clamtk to operate.
Until those dependencies are satisfied there is no point in trying to install Clamtk.

First ensure that Perl isn't already installed by using 'yum list <name of lib or application>'
If it's not install than:
Code:
yum install perl
Than

Cd to the directory that you have clamtk in and than:
-::- Use yum to install clamtk-5.20-1.el7.noarch.rpm-::-

https://access.redhat.com/documentat..._Packages.html

https://www.centos.org/forums/viewtopic.php?t=55742

-::-Kindly put output from the command-line in [Code Tags]-::-

Use the # (pound sign) and click in the middle of the code tags and paste the output.
 
Old 02-03-2017, 01:25 AM   #5
swamprat
Member
 
Registered: Sep 2005
Location: New Jersey, USA
Distribution: Centos 7 , Linux Mint 18.1 Under VMware in Win7
Posts: 542

Original Poster
Rep: Reputation: 34
Below is a list of all dependencies required. At the end of this list is this module JSON.PM Seems to be something that's need by Perl but it is in something like a list that Perl search to find the above module.

So I have no idea how to resolve this. Thanks

BTW, also tried to start the GUI but nothing happens.


Installed:
clamtk.noarch 0:5.20-1.el7

Dependency Installed:
perl-Cairo.x86_64 0:1.104-1.el7 perl-Digest-SHA.x86_64 1:5.85-3.el7 perl-Font-AFM.noarch 0:1.20-13.el7
perl-Glib.x86_64 0:1.305-1.el7 perl-Gtk2.x86_64 0:1.2495-1.el7 perl-HTML-Format.noarch 0:2.10-7.el7
perl-HTML-Tree.noarch 1:5.03-2.el7 perl-LWP-Protocol-https.noarch 0:6.04-4.el7 perl-Mozilla-CA.noarch 0:20130114-5.el7
perl-Pango.x86_64 0:1.226-1.el7 perl-Text-CSV.noarch 0:1.30-3.el7 perl-Time-Piece.x86_64 0:1.20.1-291.el7
perl-gettext.x86_64 0:1.05-28.el7

Complete!
[root@localhost system]# clamtk
Can't locate JSON.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at /usr/share/perl5/vendor_perl/ClamTk/Analysis.pm line 27.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/ClamTk/Analysis.pm line 27.
Compilation failed in require at /usr/bin/clamtk line 22.
BEGIN failed--compilation aborted at /usr/bin/clamtk line 22.
[root@localhost system]#

Last edited by swamprat; 02-03-2017 at 01:27 AM.
 
Old 02-03-2017, 06:02 PM   #6
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
The good news is that Clamtk and it's dependencies are installed.

The bad news is that the compilation failed and was aborted.
There is something wrong with line 22.
In other words something is missing and Clamtk can't find what it needs to launch.

Try typing clamtk in your terminal w/o being root. Are the results the same?

Did you have a GUI before all of this started to happen?

You can always re-install the DE if you have to.
What DE were you using? Gnome?
 
Old 02-03-2017, 08:03 PM   #7
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,523

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
to add

Do you really need the old TK gui to clam

it was never of any use to me

and WHY would one want a tk based gui for clam ?

the terminal is all you need to use it
and the terminal output and logs are all you need to fix anything


you did install ClemAV first ?
and update the database with "freskclam" ?

Last edited by John VV; 02-03-2017 at 08:04 PM.
 
Old 02-04-2017, 12:09 AM   #8
swamprat
Member
 
Registered: Sep 2005
Location: New Jersey, USA
Distribution: Centos 7 , Linux Mint 18.1 Under VMware in Win7
Posts: 542

Original Poster
Rep: Reputation: 34
This is how far I've gotten. Can't (don't know how) to resolve the message below.

Yes clamav is installed and I did run freshclam.


[root@localhost clamtk-kde-0.17]# clamtk
Icon 'gtk-new' not present in theme at /usr/share/perl5/vendor_perl/ClamTk/GUI.pm line 282.
[root@localhost clamtk-kde-0.17]#
 
Old 02-04-2017, 12:53 AM   #9
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,523

Rep: Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619Reputation: 2619
clamtk-kde-0.17

you using the KDE plasma desktop and not the default Gnome ?


you were trying to install clamtk-5.20 now for some odd reason you have clamtk-kde-0.17

you are grabbing the rpm from here ?

https://dave-theunsub.github.io/clamtk/

https://bitbucket.org/dave_theunsub/...el7.noarch.rpm


the current is 5.24 and not 5.20 !
 
1 members found this post helpful.
Old 02-04-2017, 05:10 PM   #10
swamprat
Member
 
Registered: Sep 2005
Location: New Jersey, USA
Distribution: Centos 7 , Linux Mint 18.1 Under VMware in Win7
Posts: 542

Original Poster
Rep: Reputation: 34
Thanks for all the replies to my post.

I'm in process of trying a number of different things.

I found what seems to be a number posts on the internet with instructions install both Clamav, Clamd and Clamtk. Of interest is that all are different. There isn't one post that matches the install process of the above of any other post so I'm in the process of reinstalling all of the above. The closest to success I've come you can see in my last posts.

So I really don't have any idea what's going on. Shortly I'll try again and advise. If anyone has any more suggestions it will be appreciated. Thanks again.
 
Old 02-04-2017, 06:21 PM   #11
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
Are you getting Clamtk from the link that JohnVV posted?

Best to answer his questions so he can help you.
 
Old 02-04-2017, 07:07 PM   #12
swamprat
Member
 
Registered: Sep 2005
Location: New Jersey, USA
Distribution: Centos 7 , Linux Mint 18.1 Under VMware in Win7
Posts: 542

Original Poster
Rep: Reputation: 34
No, If I remember correctly I downloaded it for Sourceforge or using RPMFIND.
 
Old 02-04-2017, 07:55 PM   #13
Ztcoracat
LQ Guru
 
Registered: Dec 2011
Distribution: Slackware, MX 18
Posts: 9,484
Blog Entries: 15

Rep: Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174Reputation: 1174
It's most likely best to download it from where JohnVV linked it.

https://dave-theunsub.github.io/clamtk/

The current like John said is 5.24:-
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error unpacking rpm package httpd-2.2.15-45.el6.centos.x86_64 on centos 6.5 rookie5 Linux - Server 5 01-09-2019 05:55 PM
Error unpacking rpm package httpd-2.2.15-45.el6.centos.x86_64 on centos 6.5 rookie5 Linux - Newbie 1 08-16-2015 11:14 AM
LXer: Install CentOS Web Panel on a CentOS 6 Linux VPS LXer Syndicated Linux News 0 03-24-2015 10:42 AM
[SOLVED] NFS on CentOS 6 can talk to Centos 5 but not Centos 6 clients deathsfriend99 Linux - Server 2 11-08-2013 02:33 PM
LXer: Install CentOS 5 DomU on CentOS 5 Dom0(64 bit) from NFS share LXer Syndicated Linux News 0 11-09-2007 03:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 03:12 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration