Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 02-11-2009, 03:28 AM   #1
Registered: Oct 2006
Posts: 302

Rep: Reputation: 32
charset/locale for es_ES


I use kubuntu 8.04 in Spanish. I'm not sure the configuration I've to use for language spanish/spain.
I create and edit files form kwrite, konsole, windows (with samba), html pages,....

My problem. I don't know how I have to configure locale and applications for everything to being compatible (to show spacial characters like ραι....
I thing that for being compatibles files creation i have to use LANG=es_ES.utf8 and applications must be iso885915 but not sure. That makes that pages made with kate not be well displayed when accessing with firefox http.

Please, can you tell me how do I have to configure locale and applications for being compatible with spanish/spain (es_ES).

Old 02-11-2009, 03:40 AM   #2
LQ Guru
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
You should probably use the es_ES.UTF-8 locale; using ISO-8859-15 should provide those letters, but my experience is that it should be used only if you need to. UTF-8 is the way to go..if you have problems with html pages you created, make sure that you (1) save the files using UTF-8 encoding (for example that) -- in kwrite I think you can select the encoding in one of the menus -- and that (2) in the html document head section you tell that the document is using UTF-8 charset by adding a line like this:

<meta http-equiv="content-type" content="text/html; charset=UTF-8">
Of course you can use other charsets if you want to; I've found UTF-8 most suitable for my own needs. After that you can get picky about your html file's content, how you should do things and how you shouldn't..
Old 02-11-2009, 04:17 AM   #3
Registered: Oct 2006
Posts: 302

Original Poster
Rep: Reputation: 32

Yes, your are right. If I always use utf8, it works fine.

I think that the problem was that I createf files with is08859-15. But even saving them as utf-8, something was wrong.
If I create them with utf-8, it works fine.

Thanks again.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
locale: Cannot Set LC_ALL to default locale: No such file or directory. asym Linux - General 11 10-24-2018 06:54 PM
How to change the locale by setting the system default locale letdoit Slackware 6 08-18-2011 04:34 AM
System locale charset Problem With K3B browser Linux - Newbie 2 06-14-2009 11:42 PM
after-Installation errors. locale error. unsupported locale settings and two more gh0st Fedora 1 05-02-2008 06:06 AM
locale: Cannot set LC_ALL to default locale: Invalid argument GadgetWiz Mandriva 1 04-01-2006 12:38 AM > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:24 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration