LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-08-2003, 05:26 AM   #1
GŠutama
Member
 
Registered: Jun 2003
Location: Tokyo
Distribution: Gentoo
Posts: 78

Rep: Reputation: 15
changing window manager in gnome


I would like to change the window manager gnome uses from metacity to fluxbox. I know that I previously read a guide for changing the defatult window manager but now I just can't find it again (sic). When googling on the subject I find that there should be an option in the gnome control center that allows you to change the window manager but when I fire up gnome-controll-center I can't find this option.
I use gnome-session 2.0.5

After a bit of fighting and mucking about I found that the script gnome-wm determines the windowmanager gnome uses. So I edited the script to launch fluxbox instead of metacity. This worked. Fluxbox started. BUT (there is always a but, in the beginning) gnome does not finish startup. After starting window manager step gnome stops not starting Nautilus and what ever other services it should.
I have to kill X with ctrl-alt-backpspace.

None of the apps that start during my normal fluxbox startup start when I start start gnome with fluxbox.

Do any one know of a better way to change the window manager or how to get gnome to start all the way?

Cheers
 
Old 11-08-2003, 09:37 AM   #2
watashiwaotaku7
Member
 
Registered: Oct 2002
Location: wisconsin -- The Badger state
Distribution: gentoo
Posts: 654

Rep: Reputation: 30
ive always seen the options for that in the gnome program menu but i havent used gnome in a long time, try editing your .xinitrc add the line exec /usr/bin/fluxbox or wherever your fluxbox binary is, you may need to search for it, or try using just exec fluxbox because it may be in your PATH
 
Old 11-08-2003, 10:00 AM   #3
GŠutama
Member
 
Registered: Jun 2003
Location: Tokyo
Distribution: Gentoo
Posts: 78

Original Poster
Rep: Reputation: 15
I am starting flux from the .xinitrc already. If I want to start gnome from this file I add the line
gnome-session

this works fine and gnome starts.

But this does not effect the window manager gnome uses. Beacuse if I add fluxbox before gnome-session, fluxbox boots then when I shutdown fluxbox gnome starts. And exactly the same btu the other way around if I put fluxbox after gnome-session.

So I need a way to tell gnome to boot fluxbox instead of metacity. This was done with the gnome-wm script, but it also made gnome stop booting. So it did not solve my problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing Window Manager in GNOME Jose Muņiz Linux - General 0 07-21-2004 10:05 AM
Changing the window manager used by GNOME sylvain_gnu Linux - Software 8 05-21-2004 04:40 PM
changing window manager in gnome sanjith11 Linux - General 3 12-09-2003 10:15 AM
Changing Window Manager downinthemine Linux - Newbie 11 08-03-2003 09:10 PM
Changing your Window Manager nigma Linux - Software 6 05-05-2003 02:03 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 05:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration